OSMC boot: my request External Hard Drive?


At the boot of OSMC, He asks me to connect my external hard drive. Otherwise it will not launch.

My fstab file is correct ?:

UUID=5EFEFAE2FEFAB0FF /media/DDE ntfs-3g defaults 0 2

A solution ?

Thx !

Nobody ?

Did you install to USB? Paste /boot/cmdline.txt please.

NO, here paste cmdline.txt:

root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp2

Removing that drive from fstab fixes it?

What do you mean? OSMC has no function to ask for a drive in order to complete boot. Send a screenshot if you must.

Removing that drive from fstab fixes it? No

Here pics, when my drive is not connected:

Nothing ?

Why are you trying to manually mount the drive in /media using /etc/fstab ? Just let the automounter (udisks) mount it for you automatically. (Remove your fstab line and reboot)

We have a script which runs on boot which deletes empty mount points in /media before udisks loads, so if you have created a mount point directory called /media/DDE it will be deleted on next boot thus it won’t work.

Please read /media/README.

If I remove the line in fstab, my disc mounts more.

Indeed DDE folder was deleted.

How do I do now ?

Are you saying the disk is mounting automatically, or is not ?

Yes, The disk does not mount automatically.


Really? Did you read /media/README ? If you had then you would know you need to change your fstab mount so it mounts in /mnt instead of /media.

You mean I have to return it in fstab ?

UUID=5EFEFAE2FEFAB0FF    /mnt/DDE    ntfs-3g    defaults    0    2

What I’m doing, but he always asks my startup disk when it is not connected.

I do not know what else to do, or so, I did not understand

I have still not solved my problem. I changed fstab to mount in / mnt.

Can you please remove the fstab lines you have added, run updates to make sure that you are fully updated, reboot, and see if your external drive mounts properly ? If they do not please post a full debug log.

I have fixed a number of automount issues yesterday and pushed out updates to everyone.

That’s what I did and now impossible to start OSMC.

He asks my hard drive. I am blocked. How do I do now ? I can not login via SSH.

I need to modify the fstab file. How make on windows ?


I not delete the line apparently

Plug in a USB keyboard and press Ctrl-D.

Hold down shift on a USB keyboard when you boot and you will get to the recovery console where you can edit /etc/fstab.