OSMC Hanging on Boot

Hi

I’ve been using OSMC for ages and have been able to fix all my problems with the help of google. However, this one has stumped me so I was hoping someone could help me please!

I installed CRON via MyOSMC and when the Pi rebooted (Pi3) I was stuck in the load with the following messages:

(Bluetooth load info - loads fine)
(Samba load info - loads fine)
(Checks time)
Reached target Multi-User System
Reached target Graphical Interface
Starting Update UTMP about System Runlevel Changes…
Started Update UTMP about System Runlevel Changes.

and there I am stuck.

I can login via Putty and have run any upgrades but this hasnt helped.

Thanks in advance for any help!
DB

Provide logs please. To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Thanks and sorry for not doing this already

Logs are: http://paste.osmc.io/ewabazejuq

Thanks!

The root cause of your problem seems to be that you tried to uninstall python-requests, which is a requirement for My OSMC which is in turn a requirement for Kodi, so this caused Kodi to get uninstalled:

Removing rbp2-device-osmc (1.2.9) ...
WARNING: You have tried to remove a package that is essential to OSMC's operation.
To undo these changes, run 'sudo apt-get -f install'.
dpkg: error processing package rbp2-device-osmc (--remove):
 subprocess installed pre-removal script returned error exit status 1
Removing python-pip (1.5.6-5) ...
dpkg: python-requests: dependency problems, but removing anyway as you requested:
 mediacenter-addon-osmc depends on python-requests.

Removing python-requests (2.4.3-6) ...
dpkg: ca-certificates: dependency problems, but removing anyway as you requested:
 armv7-network-osmc depends on ca-certificates.

Removing ca-certificates (20141019+deb8u1) ...
Removing dangling symlinks from /etc/ssl/certs... done.
Removing openssl (1.0.1k-3+deb8u4) ...
dpkg: armv7-network-osmc: dependency problems, but removing anyway as you requested:
 rbp2-device-osmc depends on armv7-network-osmc.

Removing armv7-network-osmc (1.6.1) ...
WARNING: You have tried to remove a package that is essential to OSMC's operation.
To undo these changes, run 'sudo apt-get -f install'.
dpkg: error processing package armv7-network-osmc (--remove):
 subprocess installed pre-removal script returned error exit status 1
dpkg: rbp2-mediacenter-osmc: dependency problems, but removing anyway as you requested:
 rbp2-device-osmc depends on rbp2-mediacenter-osmc.

Removing rbp2-mediacenter-osmc (16.0.0-1) ...

It looks like you ran the command to reinstall rbp2-device-osmc, and mediacenter-osmc is re-installed, so the issue is probably just that the mediacenter service is no longer enabled on boot. So just do:

sudo systemctl enable mediacenter
reboot
1 Like

Ace, thanks! All sorted. Please note I did none of those things myself! I just installed Cron as mentioned!

At least it is all sorted! Thanks muchly!

There’s more going on there than “just” installing cron. The apt history.log for when the problem occurred is here:

Start-Date: 2016-04-30  10:39:47
Install: libpython3-stdlib:armhf (3.4.2-2, automatic), python3.4-minimal:armhf (3.4.2-1, automatic), cron-app-osmc:armhf (1.0.2), python3:armhf (3.4.2-2, automatic), libpython3.4-stdlib:armhf (3.4.2-1, automatic), libpython3.4-minimal:armhf (3.4.2-1, automatic), dh-python:armhf (1.20141111-2, automatic), libmpdec2:armhf (2.4.1-1, automatic), python3.4:armhf (3.4.2-1, automatic), python3-minimal:armhf (3.4.2-2, automatic), cron:armhf (3.0pl1-127+deb8u1)
Upgrade: python3-pkg-resources:armhf (0.6.24-1, 5.5.1-1), python3-setuptools:armhf (0.6.24-1, 5.5.1-1)
Remove: python-pip:armhf (1.5.6-5), python3.2-dev:armhf (3.2.3-7), rbp2-mediacenter-osmc:armhf (16.0.0-1), mediacenter-addon-osmc:armhf (3.0.610), openssl:armhf (1.0.1k-3+deb8u4), libpython3.2:armhf (3.2.3-7), armv7-network-osmc:armhf (1.6.1), python-requests:armhf (2.4.3-6), ca-certificates:armhf (20141019+deb8u1), python3.2:armhf (3.2.3-7), rbp2-device-osmc:armhf (1.2.9)

Prior to this you have installed and removed all sorts of Python related packages. The problem was nothing to do with cron, but do with a required python package, as I mentioned previously. Be careful with what packages you remove as some are required by OSMC.

Hi

Whilst I can see from the logs that this has happened, I can assure you I have no idea how this happened. I have never removed a component and don’t even know the command to do so. All I did with the pi on that day was install cron.

How very strange, but thanks again for the help.

Db

From the app store or following some tutorial?

From the App Store. I know this might sound like I’ve done something, but I haven’t.

A post was split to a new topic: ATV installation problem