OSMC Kodi 16 Airplay

Hi , I made yesterday on my pi 2 in osmc a update to kodi 16 and when i send audio only from my iphone with ios 9 to osmc there is no sound i try also from my mac with itunes to send audio to the osmc there is also no sond.
I read in the kodi 16 changlog that they fix the airplay problem with ios 9.
What can i do to fix the airplay promlem in kodi 16 to play audio over airplay ?

Thanks Philippe

Maybe the I-people have to wait also for this?

kodi 16 changlog that they fix the airplay problem
Changlog say it works now but not on osmc

(Added initial support for AirPlay from iOS 9 music streaming capability)

It works, two things:

  • Disable from Settings - Services - Airplay the support for pictures and videos, if you are running iOS 9
  • activate from MyOSMC the wait for network flag and then reboot, so that your correct mac address is broadcasted by Kodi
3 Likes

Thanks i will try it today

I test it dont work :frowning: some new solution,some files updates ?

Try enabeling bluetooth on your iPad, restart everything and hopefully it works. It also did not work with me untill I enabled bluetooth. Put also the sound from your iPad at maximum. I heard a lot of noise and a very low volume. I was trying to correct this in Kodi (did not work) until I saw in the Airplay panel that you can adjust the volume also there.

Hi i try the trick witch bluetooth it dont help me on the iphone and ipad :frowning:

Airplay does not use Bluetooth. It works over Wifi.

Those options are not available in my version (raspberry pi 2 image freshly installed)

In settings you might have to change your level to “expert”

This definitely is in MyOSMC -> Network. If not then provide debug logs

Right, I had it set to Advanced. Thanks. Still confused though, as it does not work yet. This is what I did:

  • Disabled the Airplay Images and Video
  • Checked the wait for network flag.

Now, osmc does show up in my iphone youtube app, and when I choose that it does think it is airplaying, but no sound on OSMC. Should I Choose some menu option in OSMC, or should it automatically switch to the airplay stream?

I don’t use airplay. But as you disabled Video I guess youtube stream doesn’t work but only audio (music files).

The iOS Youtube app does not work with Airplay on Kodi and has not done so for over two years now, due to changes that Google made to the iOS app.

Also, Jarvis only supports Audio Airplay from iOS 9 devices - you won’t get video working from any apps on iOS 9. This is not likely to change in the near future and you can find more information about this over at http://forum.kodi.tv

Ok, thanks for these answers. So I tried the Music App with Airplay. It thinks it’s streaming, but the music app I’m running on my Pi just keeps playing like there’s no tomorrow.

What can I do to troubleshoot this?

The sound of the youtube app works with Jarvis, I’ve just tried it, iphone 6 and ipad air 2 running both iOs 9.2.1.

For anybody not getting it to work, try installing the Bonjour browser on a laptop in your LAN and have a look at the broadcasted services, to see if kodi identifies itself correctly. Nevertheless, as I said, for me it was straightforward: expert settings, services, airplay - deactivate the support for videos and pictures, programs - myosmc - enable wait for network. Reboot and voila!

Ron: define “the music app I’m running on my pi”. When I start streaming, kodi just waits in the main menu, nothing running, when airplay starts it plays automatically (showing the tags, album art if any etc)

Its works by me now i install the sd card new airplay works now with ios 9 kodi 16

Thank you for instructions.
Updated to newest OSMC - did these two things and it worked for me.
Finally got back AirPlay on AppleTV1 Hooray!! :slight_smile:

Anyone successfully airplay with Ios 9.31 with Pi 2?

Despite all the methods, my iphone still could not detect my Pi in Airplay

Thank you! It works!