OSMC Remote and LibreElec

On a Raspberry Pi 4 with LibreElec newest version. Finally got my OSMC remote and was excited to use it but it doesn’t play very nice. It will be zippy sometimes, then suddenly stop responding. I thought perhaps it was the Pi but the other remote works fine in these moments. This remote requires line-of-sight which isn’t a huge deal but sometimes you have to be very close for it to work; sometimes the couch is OK (about 10 feet maybe).

Any ideas on how to get better performance out of it or is this what I should expect from it?

Are you sure you have an actual OSMC remote? A real one comes with an RF dongle and isn’t line of sight. It should also work closer to 30’ away. But generally speaking if your having that kind of an issue I would look at rf interference from a metal object that could be acting as a shield or another device close by that would be transmitting strongly like another dongle or a wireless router. You might try putting the dongle on a USB extension cable to locate it to a more optimal location.

I certainly hope so, I purchased it from OSMC’s store on this site. It has the RF dongle but it will not work if the TV stand door is closed or if I’m not pointing directly at it. If the dog walks in-between me and the Raspberry PI, it won’t work.

There isn’t any metal around it and the closest WiFI router is in the office which is the room behind the living room where this is set up.

The OSMC remote is RF based rather than IR, so line of sight is not going to make a difference.

It does sound like you have some kind of other interference.
Is anything else attached to the Pi?

I would also recommend holding the Home and OK buttons on your remote to re-pair the remote with the receiver.

That should certainly not be the case.

I assume you’ve also ruled out a defective / low battery?



The only thing attached to the Pi is an external drive for file storage; I wouldn’t assume that is causing problems.

I will try the re-pairing and see what that does.

I’ve not tried a new battery yet. The other had the tab in place so I assumed it was still good.

There is a non-zero possibility that there could be some interference caused by the high speed USB 3 communication. You might try it without the drive connected. If that makes a difference try a USB extension cable on the dongle as a work around.

You could also try connecting it to a USB2 port instead of USB3 as a test.

@darwindesign I will try that this afternoon. It would be a rather unpleasant solution.

@sam_nazarko I have swapped ports, didn’t change anything.

It is an inconsistent behavior except the line-of-sight which is constant.

Have you tried on another device?
The remote certainly does not need line of sight.

Can you also let me know your order number?

Not yet. My other Kodi device is a Raspberry Pi 3 and my desktop. I can try them now actually.

Yeah, one of the big selling points, other than the made for OSMC/Kodi, was the no line-of-sight.

My order number was #41774. It took a while to ship it, we didn’t get it until June 23rd.

It would be good if you could try it on the desktop.

Did you try re-pairing and try a new battery?

So it works fine on my desktop, snappy as one would expect. Did not re-pair it nor change batteries. Also no line-of-sight issues.

Not sure why line-of-sight is a thing with the Raspberry Pi 4 or why the performance is so inconsistent.

Now – sorry to be a pain, try it on Pi 3.

If it works there, then we need to narrow down what the issue is with Pi 4.

No pain at all! The Pi 3 actually worked perfectly, which I didn’t expect.

Even more unexpected, after trying it in my desktop and Pi 3 -then- plugging it back into the Pi 4, it seems to be fine. I’m not sure what changed, if anything, but now the line-of-sight issue is gone and the performance is smooth.

Very strange. Does changing devices do anything internally? I can’t imagine it does.

It doesn’t. I can think of a couple of things:

  • You’ve put it in a different USB port – maybe one on the Pi 4 was faulty
  • You didn’t have it fully inserted in the Pi 4 and re-seating it (removing and re-inserting) has made a better contact.

Let’s keep an eye on things.

Yeah, I didn’t think it would be you never know sometimes. And will do! Glad it is working optimally now.

Thank you for all your help!

Well, that was foreshadowing. Yesterday the remote just stopped being responsive again. Line-of-sight issues, failure to respond to button presses, etc. Nothing else changed. I have considered the unplug / re-plug rotation with my other devices to see if it revives it again.

What could that be?

I would try plugging both the hard drive and dongle into the USB 2.0 ports (the black ones) for a period of time to see if that makes the problem go away. If it does, then that may indicate that the dongle is picking up interference from the USB 3 device.

When you say “unplug / re-plug rotation” what do you mean by this? Are you having to regularly re-seat connections for other things? If so, that isn’t something that should normally need to be done.

Can do. I’ll test it tomorrow as it is getting late here.

By “unplug / re-plug” rotation, I mean that last time I tested it on my PC and then a Raspberry Pi 3, afterward plugged it back into the Raspberry Pi 4 and it worked as expected. There really wasn’t any logic to it, other than possible re-seating the USB dongle, but I figured why not try it again. It did not work.

1 Like

A little late on the reply, sorry about that. I moved the external drive to USB 2, along with the dongle, and so far so good! They are playing nice together. So far it seems to have fixed the issues.

Any idea why being on USB 3 would affect line-of-sight or general usage like that?