OSMC's December update is here - OSMC

Last month, we launched Vero V, our fifth iteration of our flagship device. We've been working tirelessly to ship our new device and the best way to enjoy OSMC as promptly as possible.


This is a companion discussion topic for the original entry at https://osmc.tv/2023/12/osmcs-december-update-is-here-3
4 Likes

Hi Sam,
Java run time does not work by default on my Vero V even after a complete system re-install.
Since I’m not familiar with SSH commands, shall I wait for new operating system image file and then reflash Vero V with December image to have java and BD-J menu fully working?
Thanks!

This may be your best option. Once we have more feedback about stability of the update (it’s the early hours yet), we’ll upload images for this release.

I’ll let you know personally when these new images are available and also make a hotfix available via My OSMC for those that don’t want to reinstall.

Sam

Thank you very much for your prompt support!

Thank you for the great update!
I am using two Vero V and tried to switch the UI resolution to 4K but still got the message 1080p is advised. Is this correct?

I read in the post about this release 4K UI should be possible with this release?

Kind regards,Olaf

Yes, it’s possible, and will work. There are some corner cases with video playback where the resolution and refresh rate may not change optimally however

Unless you are planning to look at photos in 4K, you probably won’t notice the difference, which is why we have kept the advisory.

Sam

1 Like

Hi Sam,

Having a very weird error on my V since the update. 1080p content still displays full screen, whereas anything 4K now shows only on the top left of the screen at quarter size. I’ve tried changing the UI resolution etc., but I’m stumped. Any idea why it would be doing this? It was fine yesterday prior to the update.

Cheers,
Tom

There is an issue when you either imported an old guisettings file or when GUI resolution was set before a certain update. I think if you share your logs (see below) we can give advice how to fix.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks for jumping on this so quickly, Fzinken.

Log URL here: https://paste.osmc.tv/ovuhohejeb

Looks like I got bit by the “tiny 4K in the upper left” thing too. Hopefully whatever fix is suggested for tomwalker1 will work for me too, but just in case:

https://paste.osmc.tv/oreluzuvot

P.S. I reset all the options in the System > Display setting menu to see if that helped (it didn’t). The log files above are after that reset.

It should work for you.

Seems that the reset did not remove all resolution entries. If you are OK with the command line just remove all resolution entries in guisettings.xml as described here.

Otherwise you would need to wait for a hotfix that might come.

I have used the command line a time or two on my Veros. '-)

That did it for me. Thanks for the tip.

Is anyone able to kindly guide me through how I can access and modify the XML? I’m meant to be hosting a movie night tonight so this is a big of a nightmare!

Make sure the ssh-server is installed/enabled in appstore/services, use a ssh client of your choice. Connect to your Vero’s ip-number. User:osmc Password: osmc if you haven’t changed it, which I recommend.

then issue this command series:

sudo systemctl stop mediacenter (blacks your tv, no worry)
nano .kodi/userdata/guisettings.xml

Make the needed changes, exit and save, and restart mediacenter(start instead of stop, in that systemctl line)

Ps. To stop editing and saving changes, press CTRL+x, y, ENTER

goodluck

Wouldn’t the commands @darwindesign posted in that thread be easier?

systemctl stop mediacenter
awk -v RS='' '{sub(/<resolutions>.*<\/resolutions>/,"<resolutions/>"); print}' .kodi/userdata/guisettings.xml>tmp && mv -f tmp .kodi/userdata/guisettings.xml
systemctl start mediacenter

Can’t test if it works (for everybody), but it sure worked for him.

2 Likes

Sure that works, I hadn’t read that thread.

Thanks so much joakin_s and Theetjuh. Managed to get in via Termius and fix it. 2160 content running perfectly now. Really appreciate the assist.

2 Likes

Worked for me too (removing the <resolutions> node from guisettings.xml)

How come the <resolutions> node is not ‘needed’ anymore ?

It does, and I tested it quite carefully. I’ll ask Sam to put it into a hotfix so people can reset their calibrations without going to the terminal.

1 Like