OSMC's July update lands (a little late) with Kodi 15

WiFi seems to be completely broken in the last couple of updates. I’ve gone with OpenELEC 5.0.8 which is working as Raspbmc and earlier versions of OSMC used to.

Really appreciate your efforts Sam and co., but that both of my TP-Link adapters to suddenly stop working was quite shocking.

Please start a new forum post with debug logs. We’re not aware of any WiFi issues here. If this was a widespread issue I’m sure we’d see a fair few complaints



While upgrading the device, it chrashed. now osmc is not booting anymore. Before I reinstall it, I would like to provide the some debugs. How can I do it ?

any news when the july update will make it to the image download page
upgrade worked just great for my old pi1, but now i have a pi2 and it seems silly to download then upgrade :slight_smile:

Thanks a lot for this great update!
Is Cubox-i support still on schedule for the september release?

Its gotten very slow compared to last release.

Slow in what way ?

Keep in mind that going from Kodi 14.x (Helix) to 15.x (Isengard) is a big jump - a lot of stuff has changed under the hood including a lot of new features.

There are a couple of specific changes I can think of that might make it seem slower though - one is that omxplayer is off by default on Pi 2 now, (dvdplayer does not perform as well in some situations, but adds more functionality) also the “seek steps” function means that there is now a delay (by default 750ms) between pushing left or right and the seek occurring, to allow time to count the number of presses for different seek sizes, however this can be reduced or turned off.

For new installs, you can download the latest image here: edited

As I have advised in other posts. I would not do that because those images have bugs in the first time run code. I also edited your post – please do not link directly to mirrors in the future as it can cause disproportionate traffic.


Thanks Sam, I just learned the hard way! Installed one of the images, noticed a few things were off and I could not select anything in lists. Going to install the normal image from the homepage.

I like the OSMC skin because it is clean and basic. But two things are a bit annoying:

  • you can hardly see what you have selected. Try to change the port for HTTP server. It’s nearly impossible because you do not know where the cursor is at (using TV Remote/CEC or Yatse remote on Android). Please change the color of selections!

  • scrolling in a loop: When you are at the top of a list (tested in the menus) you cannot hit the UP button to go to the bottom of the list. Viceversa, you cannot hit DOWN when you are at the bottom to go back to the top immediately. This requires a lot of scrolling (I know you can scroll through pages via the scroll bar on the right side).

I run the JULY update on my old Pi 1 (version B)
And I must say it is LAGGING and lagging and lagging.
Menu is responsive without overclocking, but whenever I choose an item the pi just hangs for 10-30 seconds and becomes unresponsivem before it’s “back up” again.

With each update addons stop working. example is pulsar.
I’ve had to re-install my PI 3 times the last week alone to get it back up. It’s quite tiresome to do this over and over. I really hope the august update will be more stable for me than this.

Now I do plan to buy the new PI but so far I actually miss the old RaspBMC.


  • No logs
  • Not in a new thread
  • Expects developers to solve problems which they have not been made aware of when the extreme majority of users are happy with it.

Please start a new post with some logs, then perhaps we can find out what’s going on

Sigh indeed.

Sam I’ve been following you since RaspBMC 1.0.
So I know you’ll fix it, I receive no Errors, so there’s no logs to show.

Don’t get me wrong, I am overall very pleased with your work.
I suspect problems lay in that Kodi is becoming a bit too much for my old Raspberry 1.

So maybe, just maybe, I shoud revert back to the old RaspBMC until I can buy the new PI.
Problems may also lay in the convertion from the old SQL to the new. I don’t know.

If you tell me what I should report back, I will do so - very happily.
Because I want your work to be good.

I highly anticipate the new build.

thanks for the reply, understood.
im new to discourse and couldn’t work out how to search all previous posts in this thread. i was expecting a ‘show all posts’ button somewhere so i could ctrl+f in the browser. i found the tickbox under the magnifying glass now though!

Hi @sam_nazarko

I was just wondering, if the ATV1 has been skipped, or if it’s possible to get an update as to the progress ?

A clean install can often help performance. Updating between major versions of kodi can leave behind unneeded/incompatible add-ons and settings which may slow it down.
Obviously switching from Pi1 to Pi2 would bring a bigger performance boost.

It is still planned


My RP1 is doing just fine but it is overclocked to the max

OK, so I bought a new Samsung card, flashed OSMC for Vero and had it running. Updated the library overnight. Went to do a manual update this morning and once again, after saying yes to the restart prompt, I got the OSMC home screen, frozen, with the following messages in the upper right corner of the screen:

[TIME] Timed out waiting for the device dev-mmcblk0p1.device.
[DEPEND] Dependency failed for /boot.
[DEPEND] Dependency failed for Local File Systems.

Pulling the plug and restarting did nothing but deliver the same set of messages.

Last week while waiting for my new SD card to arrive I dug out my old RPi model B and Vero ran fine on that including all updates. There must be something seriously wrong with the current batch of manual updates. I’ll re-flash the card and start again, but will sure has hell not do a manual update!

I hate to create a new topic for such a small question, forgive me for abusing this thread:

What would be the appropriate location in the filesystem to install 3rd party apps like Flexget, Syncthing, Owncloud?
I installed Transmission via My OSMC and notice it is in /home/osmc/.config
Other options would be: /home or /etc
Perhaps in the future it will be possible to install some of these apps via My OSMC. I just want to have it installed in the right place from the beginning.