Passthrough not working in 19.1? (solved)

TLDR: atmos/passthrough audio wouldn’t play after update. Turning off stereo upmix in system audio settings fixed it.

I accidentially got a dev 19 build earlier and couldn’t get passthrough working so I went back to the nov build, no biggie. Now that it’s finally released I updated again but alas, still no passthrough?
The settings are correct, same as before, but whenever I play ATMOS/DTS-X etc it just says stereo and there’s no sound. got some logs here in case they can help. I’ll reinstall the nov build for now so the kids won’t scream :smiley: // Martin

1 Like

I upgraded to the August version (stable), no issues with Atmos or DTS:X. Passthrough works fine.

I had the same issue… Fixed it by setting “audio output device” to a other value in kodi and then it started working like before.

1 Like

@demon326 I can only select default or hdmi, tried flipping between them but no difference. I’m back on the Nov release now and everything is working as it should.

That’s good, perhaps it’s just my setup that’s messed up. I might just do a clean install and see if that works.

1 Like

Just to add got same/similar issue.

Using earc with LG GX TV and GX soundbar and no audio with passthrough. If change from passthrough get audio with Kodi. Audio set at 3.1 plus 2 rear speakers, hear it but centre channel not working well, volume too low for audio 5.1 and above.

Tried passthrough on different media player and all good.

Need Vero4k+ for HDR as other player doesn’t support HDR.

Was this working before for you?
I’ve got my vero → HDMI to denon receiver → TV so no earc stuff or anything. I haven’t had time to try a fresh install yet tho.

Yep was all working well on Vero4k+ before 19.1.

Tried both HDMI audio settings and most other Kodi settings but no audio via passthrough since update. Dont use HDMI lock option but even tried that and every setting I could think of. Returned all settings to v18 options but still no good.

Tested with movies with Atmos etc. that were fine before update. Tested Suicide squad and The Doors using both media devices and passthrough fine on both files using earc on other player but no go on Vero.

Have you tried this? Maybe it works for you as well :slightly_smiling_face:

I tried it on a dev release but didn’t change anything, haven’t tried it on the public release.

Have you tried to switch the audio on your AVR. On my Denon it seems to remember what I had it set to last for any given input profile so if I happen to have set for example stereo playback on a surround DD+ file then it switches back to that the next time I play a DD+ file. My Denon has an info screen buried in the menu system as well that allows me to verify exactly what it sees for input format. The display on the front of my AVR only shows the processing mode which is not necessarily the same as what it is receiving.

Yeah I’ve tried flipping it around but it just receives some bad stream. Thing is, it works flawlessly in the previous osmc release.

Just a quick reply to say after updating I have the same issue. I’ve switched it to the HDMI device only (rather than HDMI, S/P-DIF and analogue) and touch wood it’s working. I’m the same Vero 4K+ into a Denon AVR-X4500H. I have a separate issue with HD video (1080p24 and 1080i50) now being jerky but I’ll raise that separately when I have time to grab logs.

Thanks, I’ll try updating again and try this. It didn’t work in the dev release a few weeks ago (had the same issue) but perhaps something’s changed.

@Martorias: I’m using a Sony AVR STR-DN1080 with no issues regarding Atmos and DTS-X. I compared your audio and video settings with my actual configuration and would like you to test the following settings, to see whether this makes any difference:

  • settings → player → adjust display refresh rate to always or start/stop (this should be set in any case!)
  • settings → system → audio → output device to AML-MESONAUDO, HDMI
  • settings → system → audio → stereoupmix to NO
  • settings → system → audio → keep audio device active to ALWAYS
  • settings → system → audio → send low volume noise to TRUE

It cannot hurt to de-energize your AVR for a minute or so.
A fresh set of logs afterwards would be helpful if and only if the problem persists.

1 Like

I’ve got a Sony STR-DN1080 and was getting no audio stream on most films and white noise on others after the update after advice on the forum I turned stereo upmix off now the audio is back to normal


Just out of curiosity: Why would you enable stereo upmix when passing audio on to an AVR via HDMI? Doing up or down mixing of any sorts should always be the AVR’s business.


Kodi never did a good job of explaining what stereo upmix is…it is basically the same thing a receiver does when it upmixes 2 channel inputs to Dolby Surround…its a feature that Kodi has had forever and seems to be forgotten about…until it causes problems.

1 Like

To be honest I don’t realise stereo upmix was enabled the audio was working perfectly before the update but everything’s fine now

1 Like

Thanks all - after disabling stereo upmix it works as before. Not sure if that setting was on or off in the previous release but hey atmos and dts-x is back on the menu :slight_smile: thanks all