Pi b crashing

Also, you seem to be on Amber skin. Does the same thing occur if you switch back to Confluence?

Yes it drops SSH session when it crashes.
By any list I meant, any data source you browse.

I enabled the debug setting in advancedsettings.xml, rebooted, went to movies, started browsing, it crashed, when it came backup, I uploaded the logs via OSMC log upload function.

Is there a graceful way of rolling back?

Of course not… The point of “development” is to move forward…

As I asked before, is the same behavior present in other skins besides Amber?

Yes, crashes in Confluence and OSMC skins as well.

finally got the message that flashes before OSMC screen:

waiting for root filesystem device /dev/mmcblk0p2
/dev/mmcblk0p2: recovering journal
/dev/mmcblk0p2: clean 41038/962880 files, 685197/3844352 blocks

If the SSH connection drops then it sounds like the Pi is rebooting. What overclock settings are you using and if not “normal” have you tried setting it back to normal ?

Have you tried a different power adaptor ? Spontaneous reboots especially when doing something that would cause CPU use spikes such as navigating the menus is more often than not power related.

What USB devices are powered from the Pi ?

Why is power adapter always the go to culprit? This Pi was running solid until the december update.
But in order to rule it out, I will test with different power adapter (from my other PI that has not been udpated to december udpate and is running stable). Will also set overclock to normal.

Back in 10 mins.

Different Power adapter used, still crashes.
overclock set to normal, still crashes.

No USB devices other than remote sensor.

Maybe because it is the number one cause of spontaneous reboots on a Pi by far, especially the older model B Pi ?

Maybe because we have seen the same kinds of symptoms hundreds of times before and seen the same disbelief from users that their issue could possibly be power related when it “worked fine before” only to find out in the end that it was in fact the cause ?

No it’s not always the cause but spending ages doing all kinds of software troubleshooting when the symptoms likely fit a power or overclock issue is just a waste of everyones time.

As you can see in your dmesg you are still using sdhost driver
Jan 01 11:23:17 osmc kernel: mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)

Take a way the comment sign from #dtoverlay=mmc reboot and check then with dmesg | grep sdhos

Maybe because it is the number one cause of spontaneous reboots on a Pi by far, especially the older model B Pi ?

I second that.
I did all myself some months ago.
Crashing crashing crashing. WiFi and wired network working in waves.

Original power supply, not made any important changes to my B Pi. So what?

It turned out to my own disbelief that the power supply had gone bad. Still delivering some power to keep the Pi alive but failing to give enough in moments of higher demands.

Changing it did solve everything.

Sleepy

1 Like

I have tried both with dtoverlay=mmc and without. still crashes.
Also used different powersupply … no help either.
Set overclocking to normal… still no help.

Since this crash is happening on browsing media sources, I am going to delete them and recreate… perhaps something to do with database. (long shot but worth the try as it does not crash playing a movie).

tried deleting and recreating media sources… didn’t help.

What’s next? fresh install?

try renaming /home/osmc/.kodi to something else and then restarting. That should pinpoint if the problem is something within your Kodi configuration or not.

OMG… renaming the /home/osmc/.kodi did the trick. Such a simple fix!.. not sure what was the problem with the folder… that started only after applying the December update.

Thank you all, every time I come close to throwing this thing out the window… the community presents the solution. Gold stars for ActionA !! :smile:

So this would indicate that something in either the Kodi configuration or possibly some problematic addon that you had installed was causing an issue. Anyway, enjoy OSMC!

I’ve also got a RPi model B and I’m having this exact same issue.
It started happening after the latest updates.

I done a clean install, changed some settings, and after a while the issue creeped up again.
The only way I can make the system stay more or less stable (though it still happens) is remove my external disk before boot so OSMC can’t scan the libraries (I’ve got scan on boot).

It happens with Amber skin and with the OSMC skin, both are installed.
I can try installing everything again except the Amber skin and see if it’s anything it adds.

Here’s a paste of my logs and configs: http://paste.osmc.io/ukivagujer

EDIT: I’ve tried using the dtoverlay option to no avail.
The logs before the crash aren’t captured.

I’m going to try renaming my kodi folder and re-doing my settings (without installing Amber) and see if that has any impact.

EDIT: Deleted .kodi, rebooted, added debugging, rebooted, added media, system rebooted by itself soon after. http://paste.osmc.io/hudesopixa

My first suggestion is to remove your overclocking, that definitely could be a reason for your crashes.
Also how is your power supply?
It is important that your device receives a stable and sufficient power supply. This may be the problem if you see a multi-coloured square in the corner of the display. Not having a good PSU can cause many problems with your Raspberry Pi; including but not limited to random freezes or glitches, unexpected network dropouts, randomly seeing external drives unmount and remount (caused by dips in power), repeat remote presses. If you are experiencing these problems, please ensure your power supply is sufficient, and don’t be offended when we ask you to do so.

I’ve tried with and without the overclocking, different power supplies used for my two raspberry pis (B rev1 currently with my folks and rev2 sitting under my TV).
This is a setup I’ve been using for years.
As stated by irobot in his previous posts, this only started happening after the latest update.
As soon as any library interaction is initiated, the whole thing reboots.
The only thing in the logs is a few lines of �������.

Well if you have taken out all overclocking and overvoltage and you are confident about your power supply the only last resort is that the SD card is dying or got corrupted

I’m sorry but I have a hard time believing the hardware is at fault after an update has been applied.
I’m going to try downgrading the kernel using the method described here and I’ll check it out when I get home for lunch.
I’ve already rebooted successfully to the previous kernel.

osmc@YuuBMC:~$ uname -a && uptime Linux YuuBMC 4.3.0-10-osmc #1 PREEMPT Sun Nov 29 17:03:54 UTC 2015 armv6l GNU/Linux 11:11:17 up 7 min, 1 user, load average: 0,14, 0,18, 0,13