Problem with 7.1 E-AC3 audio streams

#1

I hope someone can help me with the following problem:

When I try to play a file with a 7.1 channel E-AC3 audio stream, it seems like only 4.0 channels are sent to the AVR.

I’ve added these 2 screenshots for better understanding.


Furthermore the audio stream selection menu shows a channel layout of only 5.1 channels as you can see here.

Everything seems fine with a 5.1 channel E-AC3 audio stream.
See these screenshots.


MediaInfo for the file with 7.1 E-AC3 audio stream
MediaInfo for the file with 5.1 E-AC3 audio stream

My Setup
Vero 4K+ -> HDMI -> Onkyo TX-NR636 -> 5.1 Speaker Setup

I’ve set my audio settings according to this:
https://discourse.osmc.tv/t/audio-setup-and-information/74203

#2

Hi

Which version of Kodi are you running?

Sam

#3

Version 17.
Can’t tell the exact version number cause I dont have my Vero next to me right now.
But it has to be the newest version before yesterdays v18 update.

#4

Can you post a debug log and let us know the make and model of your receiver?

Thanks

Sam

#5

Right now I only could do it on my Raspberry Pi cause i don’t have my Vero here at the moment.
But the problem both happen on the Pi and the Vero.
The screenshots above are also from my Pi

I don’t know if it helps you but I also use Plex and the Plex web browser interface also displays a channel layout of only 5.1 channels

#6

I need to see how the settings are configured under Settings -> Audio
Raspberry Pi cannot pass through EAC3; nor should there be a prompt to do so, so I’m not sure you configured your audio settings as suggested in @chillbo’s post.

Sam

1 Like
#7

Like I said in my initial post.

I’ve set my audio settings according to this:

#8

It’s not possible to set those settings on a Raspberry Pi – so I’m not sure that you have indeed configured the settings as described in that post.

That post is for the Vero 4K / 4K +

#9

Yes I know.
I only reproduced it on the Pi to take the Screenshots.
On my Vero I have it exactly like in the post.

All passthrough options are enabled.
And as far as i can tell the Onkyo TX-NR636 is capable of decoding all of the formats.

#10

Please post a screenshot of those settings on the Vero and upload a full log via My OSMC -> Logs (debugging enabled) after playing the file so we can identify the issue at hand.

The Raspberry Pi will not be able to pass through 7.1 EAC3.

Thanks

Sam

1 Like
#11

OK, I’ll do it “tomorrow”. It’s 01:30 AM in Germany right now.

Thanks in advance for your help.

#12

No problem. It’s also quite late here.

Take care,

Sam

#13

Hey Sam, should I upload only Kodi Logs or “All Configs and Logs”?

#14

All of them, please.

#16

Here are the logs and screenshots



#19

I suspect a bad rip. Mediainfo says there are 7.1 channels, ffmpeg thinks only 5.1

12:42:10.563 T:3654349568 INFO: ffmpeg[D9D0F300]: Stream #0:1(ger): Audio: eac3, 48000 Hz, 5.1(side), fltp, 512 kb/s (default)

and Kodi thinks there are 4.

12:42:10.648 T:3097486080 INFO: CAEStreamParser::SyncAC3 - E-AC3 stream detected (4 channels, 48000Hz)

#20

Actually it’s a Remux. And I have some more Remuxes and all of them have the same problem.

#21

Try with these samples: https://kodi.wiki/view/Samples#HD_Audio_Test_Clips

If the problem is still there with those samples, there really is something wrong.

#23

With Dolby 7.1 test clip there, everything seems to be working OK. And Kodi is indicating only 4 channels. What does your (@ainsley) Onkyo indicate?

#24

Same as before. @grahamh why do you say everything is ok, if even with these testfile, kodi shows only 4 channels

New log

Onkyo only shows the normal Dolby Digital logo. When I try a 5.1 E-AC3 stream it shows a + symbol next to the Dolby logo.