Problems detecting and handling deinterlacing and pulldown

For me, a Pi 3B running OSMC from August this year matches a V4K running OSMC with the 3.14 kernel, so if you have one of those to hand it could give a reference, as it plays the Timeflight clip with better handling of diagonal edges than the test Vero build that the team has kindly been working on.

I did a quick grab-logs -A: https://paste.osmc.tv/ufumiculut

Could be it’s working better on the V then?

It is. I just updated a vero 4k and the deinterlacer isn’t kicking in at all. Investigating …

I’ll double check the patch series is correct for 4K / 4K +

It’s correct – the VFM map should be:

setVfmMap(“default”, “decoder ppmgr deinterlace amlvideo amvideo”);

Permissions on /sys/class/vfm/map (ls -l), OK?

Third time lucky. Further updates for Kodi for both V and 4k should by now be in the mirrors. I’ve checked on 4k and Timeflight is looking very similar to how it looks on V now. You should find the divergent line patterns improved as well.

No-one quite knows how V got updated but 4k didn’t yesterday. But we know where the buck stops :stuck_out_tongue:

Oh, wow, yes: huge improvement! :+1:

(I’ll have to see if I can find something to test if this is working on h.264 as well - I don’t think I have a test clip for that at the moment. But hopefully it is!)

That, however, I can’t agree with: the 480i wedge pattern (the one I’ve named 480i_60_deinterlace_test_fixed.mkv ) is still playing correctly in software but wrongly in hardware: it’s frame-interlaced but treated as field-interlaced with hardware playback. (There may even be more going on there than a simple cadence-detection error. Maybe it’s the result of it attempting to do full-screen diagonal filtering? But certainly it looks terrible!)

I can’t be bothered reinstalling OSMC v18.9 to check :slight_smile: but I’m 90% sure it used to be handled correctly in hardware under 3.14 kernel / Kodi v18.

(Note that in software it plays correctly, even with Deinterlace method to “Deinterlace”).

OK, thanks. I will say @scottosan’s wedges play better than yours and yours play better on V than on 4k. There are too many variables.

I’m not seeing any obvious differences between my 480i wedge clip and his 00727.m2ts, but maybe there is on the V.

It’s possible I’m seeing things but, looking at some of my other test clips, I’m wondering if some of them may now be looking worse than they were. In the “Sherlock” clip, for example, round about 00:12-00:14, I don’t remember seeing that much shimmer around the lines on Benedict Cumberbatch’s forehead before; is it possible the thing is slipping into field-interlaced mode now when previously it wasn’t? And round about 00:35, I feel like the vertical lines in Mycroft’s suit may be less sharp than they were. Maybe diagonal filtering being enabled actually worsens the impact of it slipping into field-interlaced mode when it shouldn’t…? :thinking:

I have several Vero’s around and I just installed the test build on a V4K to compare to another V4K on the 3.14 kernel and also to a Vero V on the test build. Based on a quick look, the V4K on the test build is matching the 3.14 kernel on the Timeflight clip (pop the champagne corks!). However, the V is slightly inferior, some jaggies do bleed in during motion in places where they are not present on the V4K. Can follow up with photos later.

Thanks, both. I have to say that @tanio99 and I have spent hours with these test clips and it’s obvious to me we are not going to find one set-up that suits all these different formats. In the course of this there are some things we haven’t been able to fix and can’t without at least investing far more time on it and both of us would rather get on with something else. Note this:

  • you don’t necessarily see the same things with each run of a video. The Planet Earth clip is notable for this. It can stutter like heck one time and be smooth as butter if you play it a second time. (It’s more reliable played as field-interlaced although it’s clearly frame-interlaced.) Same thing if you play clips in a different sequence. Despite best efforts we can’t nail why this is.
  • I’ve noticed that my Panasonic TV is also doing some processing, for example when playing the wedges there are weird effects near the TV’s OSD
  • the ‘2:2 pulldown’ clips render worse than the 3:2 clips. I find this surprising - you’d have thought it would be easier.
  • we still haven’t found an easy way to switch between frame- and field-interlace on the fly ie on every frame that the parameter changes. I can’t help feeling this ought to be in AML’s code somewhere as it’s surely quite fundamental. For VC-1 we still just check the interlace type at the start of each sequence which means there can a be a few frames with judders (eg at the start of rolling credits).
  • we haven’t found the hooks by which we might bring deinterlacing options out to the GUI for MPEG2 and h264

I’m just saying this to manage expectations. It won’t be long before Vero moves to a 5.x kernel, which may or may not be better on these things. We’re grateful for your patience but I’m not sure we can do much more unless AML come up with some proper documentation.

Understood, appreciate all these efforts when as far as I know there are only 2 people on the forum who keep pressing on this :slight_smile:

I am really pleased with the field-interlaced 50i on the V4K with the new test build. I think you’ve nailed it there. The V isn’t quite there but better than it was, when before the jaggies were really noisy. Following two shots captured during a tracking move (same AVR input and TV settings each time).

V4K: super clean

Vero V: console jaggies

That’s the “25fps video stuttering at 50Hz” issue. If you set deinterlacing to Off and then manually switch the output mode to 1080p/25Hz rather than 1080p/50Hz, it’s smooth as glass 100% of the time.

I assume you’ve got “Intelligent Frame Creation” (or whatever Panasonic calls motion interpolation) turned off? If not, try that. I guess it could be a scaling issue too.

Will the Vero 4K be getting a kernel upgrade, or only the V?

This is what that frame looks like here (paused, but I don’t see jaggies like yours when it’s playing). Can you drop a log so we can check you setup?

here’s a log:
https://paste.osmc.tv/ipuwesirex

I know what’s happened. There will be yet another Kodi for V available shortly :roll_eyes:

In our tests, just setting ‘deinterlace’ on is enough to play it smoothly. I should have said it’s only variable if you turn deinterlace Off or set Auto.

@tanio99 is all for removing the option and treating everything as (field-) interlaced but that doesn’t solve the issue of Dr Who’s shirt and the Tardis pipework in one of the other clips we have (? from @ac16161 IIRC).

Only the Vero V.

hi, I’m looking forward to testing this when the update lands for the V. Is there an ETA for when that might be? Thanks.

Soon – I’m just changing a couple of other things which stopped us doing a new Kodi build for Vero V at the moment.

I’ll let you know when it’s available.

1 Like