Raspberry Pi 3 - **Booting Mega Thread **

Hello, I have just received my pi 3 and im trying to put OSMC on, Each time I try the Pi puts up the rainbow splash screen and the green light flashes 4 times long and 4 times short in that cycle, it never gets any further, I have tried reformatting the SD card several times, and put NOOBS on the SD card to see if it was the card, and NOOBS booted first time, tried OSMC again and got the orriginal result. Any one have any ideas? id really like to upgrade my pi but its not looking too promising. Oh and further to that, I have tried a KNOWN working version of OSMC from my pi 2 that I am looking to replace and got the same result (different SD card) any help will be hugely appreciated!



I’ve just seen the same thing with the latest image downloaded from OSMC: rainbow splash and no further. I’ve tried the latest image on several SD cards to eliminate the SD card problem.

The same Pi 3 will boot and run OSMC with an online updated image that has been running on a Pi 2. It looks as though the latest downloadable image isn’t as up to date as an updated image from a 2.

My pi 2 version wont work, or rather didn’t work, so I just assumed I needed a fresh install, trying NOOBS to get OSMC working now, will let you know how that goes…just a thought on the trailing end of what you said, I’m not sure if I locally updated the image before I tried it, its a spare I have, that will be another avenue to try!

i have the sane problem with the pi3

I edited my first post: see the second paragraph for a temporary solution if you have a Pi 2 with an updated OSMC installation.

1 Like

Doing the process via NOOBS does not work either, and Openelec does not work either. the later option from my previous post suggested Knightlorish to update a pi 2 version and try that.

Look at the main Rpi3 thread. Everything you need to know is in there.

1 Like

Knightlorish, did you just swap the sd cards and boot?

Sam Nazarko talks about this in another thread: OSMC Pi 3 and confirms that an image updated on a Pi 2 will work on a Pi 3.

Stephen, yes, I took the SD card from the Pi 2 and put it in the Pi 3. I’ve now used that image to create a new SD card for the Pi 3 and it’s working nicely.


agreed, didn’t think to look there thought it was going to be too generic for my specific problem, just updating on the pi 2 to test on the 3 im sure it will work as the guys work their asses off and are superb at what they do :slight_smile:


Stephen, for clarity, you need to put an SD card into a Pi 2, update the software version by going to Settings, My OSMC, Updates (cloud at the top in the middle), then go to Manual Controls, and Scan for updates now, update the card in the Pi 2, once it has rebooted, shut it down, remove the card and it should work in the Pi 3, this has worked for me.


would be a good idea to put a notice on the webpage somewhere to inform others? (you guys are probably already working on that, I know…)

Attempting this now. Cheers

I just used the wizard to update mi microSD card to the last version and compatibility with Pi3

and this is the result… :frowning: I tryed with different microSds, and same issue… any idea? I’m using a 5V 2A power supply.

The same microSD with Pi2, works fine…

waiting your comments…


I posted the a solution that worked for me a couple of posts ago, with regards updating the software using the pi2 to enable it to work on the 3

1 Like

Minor Mod edit to thread title. I’m funneling all duplicate threads (yes, that’s like 4 already today) here because ppl can’t seem to read todays posts or even be bothered to use the forum search function.

Sorry I didn’t mean to create work, I never thought to look in the announce forum and didn’t see anything relevant elsewhere. :slight_smile:

It’s cool bro… Not your fault people don’t read/search instead of wasting keypresses on a new post that resolves the issue as yours did. We anticipate the RPi3 image imminently…

I will try asap and update you! thanks!