Raspberry Pi fails to boot when connected to TV via HDMI

This seems like a strange problem. My OSMC installation is on a Raspberry Pi4 which has normally been running headless. I have bunch of video material on local storage that I want to be able to play on a smart TV. I tried using the Pi as a UPnP server which the TV can connect to OK but cant then handle some of the video aspect ratios. So I thought to just connect the Pi to the TV via HDMI cable and use OSMC/Kodi as the video player. Of course, it does this perfectly OK when connected to a separate monitor. However, when connected to the TV HDMI it fails to boot correctly. The splash screen appears then disappears and then nothing. I can boot OK with the HDMI cable disconnected but then connecting it seems to crash the Pi.

Power supply issue?

Are you using the same HDMI cable on the monitor and the TV?

Yes. There’s a micro-to-standard HDMI adapter from the Pi and then a 1m HDMI cable.

I believe these adapters are known to be less reliable than a single cable that has the correct ends already. Perhaps your Pi is trying to output to a higher bandwidth output on your TV than it is on the monitor and the adapter is reducing the connection enough that it can’t handle it.

Are you sure your pi4 not boot completely? or simply you don’t see anything on your tv?
remove your sd from pi4… on your tv you should see the whole bootloader procedure.

It definitely fails to boot - I am also unable to contact it via a SSH and its (fixed) IP address doesn’t appear on my local network.

I shall hopefully be trying a different HDMI cable and power supply to see if either of those suggestions change the behaviour.

Is your device on the latest version of OSMC?

This sounds like a DRM / DKMS parsing bug, but recent versions of OSMC have addressed this.


Yes it is, VERSION_ID=“2023.01-1”. It was a recent clean install on the Pi4.

With the help of good people here, my troubles with HDMI have been solved.

As others suggest here, check first that your Pi4 has a good power supply and high qualityHDMI to micro HDMI cable adapter. The latest was the problem.

I’ve got the same issue. It works with other SD card but when I tried to use the latest osmc release 2023.12-1 on a RB pi4), I see the installation process, then the screen with OSMC logo and then nothing. I’m able to connect to the raspberry via putty. I’ll try with another power supply and let you know.

I’ve created this issue for this : Latest raspberry pi 4 release 2023.12-1 doesn't boot

Did you read this?

I just tried with a more powerfull power supply and I have the same issue. HDMI cable is ok because when I use another SD card with a different OSMC release installed couple month ago, it works fine.