Remote not working after May 2017 update

After I updated my Vero 4k this morning both the original remote and my Harmony remote (rc6-mce-lidcd.conf) stopped working completely. I checked the lircd.conf and it did not change. A reboot didn’t help. What else can I troubleshoot?

Can you log in to the device via SSH?

What does lsmod show?
Assuming meson-ir is there, the output of dmesg would be useful.

root@vero4k:/home/osmc# lsmod
Module                  Size  Used by
btsdio                  3146  0 
bluetooth             242696  1 btsdio
6lowpan_iphc            5799  1 bluetooth
8021q                  18519  0 
dhd                   710852  0 
cfg80211              355989  1 dhd
dwc_otg               230789  0 
wifi_dummy               806  0 
ir_lirc_codec           4780  2 
lirc_dev                7898  1 ir_lirc_codec
mali                  194319  5 
meson_ir                3745  0 
rc_core                22087  4 lirc_dev,meson_ir,ir_lirc_codec
fuse                   77545  1 
amlvideodri            11426  0 
videobuf_res            5330  1 amlvideodri
videobuf_core          16064  2 amlvideodri,videobuf_res
videodev              149326  1 amlvideodri
media                  20743  1 videodev
root@vero4k:/home/osmc# dmesg|grep meson
[    0.000000]            linux,meson-fb: 0x000000007e000000 - 0x0000000080000000  (32 MiB)
[    0.000027] meson_bc_timer: mclk->mux_reg =ffffff800000c990,mclk->reg =ffffff800000e994
[    0.234697] vout_serve: meson_vout_probe OK
[    0.342118] meson-rng c8834000.rng: hwrng registered
[    0.352732] meson_uart c81004c0.serial: ==uart0 reg addr = ffffff80005844c0
[    0.352756] c81004c0.serial: ttyS0 at MMIO 0xc81004c0 (irq = 225, base_baud = 1500000) is a meson_uart
[    0.352769] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 0 to 115200
[    0.391922] meson_uart c11084c0.serial: ==uart1 reg addr = ffffff80005864c0
[    0.391943] c11084c0.serial: ttyS1 at MMIO 0xc11084c0 (irq = 58, base_baud = 1500000) is a meson_uart
[    0.531191] meson-fb has 1 memory regions
[    0.531219] meson-fb meson-fb.15: assigned reserved memory node linux,meson-fb ok
[    2.522359] cpufreq-scpi cpufreq-meson.7: enter  cpufreq
[    2.522390] cpufreq-scpi cpufreq-meson.7: probe  cpufreq okay
[    2.524385] gxbb_pm: enter meson_pm_probe!
[    2.524416] gxbb_pm: meson_pm_probe done
[    3.914220] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 115200 to 115200
[    4.288537] rc rc0: meson-ir as /devices/c8100580.meson-ir/rc/rc0
[    4.294995] input: meson-ir as /devices/c8100580.meson-ir/rc/rc0/input2
[    4.295212] meson-ir c8100580.meson-ir: receiver initialized
[    4.349486] rc rc0: lirc_dev: driver ir-lirc-codec (meson-ir) registered at minor = 0
[   11.255979] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 115200 to 115200
[   11.256102] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 115200 to 115200
[   11.270923] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 115200 to 115200
[   11.271088] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 115200 to 115200

root@vero4k:/home/osmc# dmesg|grep lirc
[    4.344676] lirc_dev: IR Remote Control driver registered, major 230
[    4.349486] rc rc0: lirc_dev: driver ir-lirc-codec (meson-ir) registered at minor = 0
[    5.200747] input: lircd as /devices/virtual/input/input3

The full dmesg output would be more helpful.

Have you enabled the RC6 decoder in My OSMC -> Remotes? It’s not clear to see but, does

root@osmc:/home/osmc# modprobe ir-rc6-decoder
root@osmc:/home/osmc# modprobe rc-rc6-mce

help?

When you say the “original” remote stopped working, are you referring to the black remote shipped with the device ?

If so this remote is not IR based and uses the receiver plugged into a USB port. So I suspect your problem is not remote related as it would be highly unlikely that both a USB and an IR remote would stop working at the same time.

Can you navigate with a keyboard plugged into a usb port ?

[quote=“DBMandrake, post:6, topic:37293”]
When you say the “original” remote stopped working, are you referring to the black remote shipped with the device ?[/quote]
Yes.

This surprised me as well.

Yes, a USB keyboard works fine.

I updated my rpi1 this morning and now none of my remotes work at all, not even Yatse Android App.

Help!!

Thankfully I have another rpi that has not got update so I have swapped it over for now so my wife can use osmc today

Please post some debug logs so we can look in to it further, otherwise we can only really speculate.

That is not a “remote” in the common sense but a remote using the webserver of Kodi so would more likely be related to a network issue.
As Sam wrote debug logs would help to understand your issues.

What logs do you need?

To investigate all your problems (physical remotes and yatse) enable debug logging and then provide URL of grab-logs -A
see https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request) for help

Yatse works fine on ‘non-updated’ rpi1 so looks like something has changed there too.

I cannot use the remote to produce a log, please could you let me know know what commands I need to run in SSH

Then as a start just provide URL from grab-logs -A

OK, I’ll do that when I get home

You also can enable debuging via SSH as explained here http://kodi.wiki/view/Log_file/Advanced
You would need to stop kodi before editing the file with sudo systemctl stop mediacenter and after you edited the file use sudo systemctl start mediacenter to start.
Then try your remote and yatse and upload the log files with grab-logs -A

I don’t think this is related to the original post. You’ve completely threadjacked the other person’s post…

Please start your own thread outlining your symptoms fully and providing full logs. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/. Your issue may not necessarily be related to the original poster’s, and to ensure that both they and you are able to get their issue resolved, we would like you to start a new thread for clarity.

Hi Sam,

I’m afraid i disagree, the original post, although about Vero 4K, is directly related.

Since the update our remotes no longer work…

You seem to be talking about Yatse.
The OP is talking about a physical remote.

Sorry Sam, my post states that my physical remote is not working, I also added that Yatse didn’t work to 1. make you aware 2. to avoid being to to ‘use a remote app’