Retroplayer (Emulators list)

List was last updated: 2019-09-23T22:00:00Z

Frequently ask questions

I am missing emulator (x)
The simple answers build errors it doesn’t build at the moment that’s why its not included

This works in distrobution (x)
Retroplayer is NOT Retrosmc or Retropie the source is different it bases of Libretro.

Posters on the frontend why isnt that working?
SImple there isnt any scrapers yet, there will be scrapers in the future but at the moment its just backend stuff, there are some early stuff like IAGL and Gamestarter although buggy and tends to create more issues then help out’’.

How to help out

if you have knowledge of programming you can help out sending patches to Kodi on Github other then that there is only one thing to do that is wait for it to be fixed and its not OSMC its the Kodi developers that needs to fix it.

Now with that outta the way im back once again gonna start with a small list of working emulators at this time from my own tests first off ive read up on Retroplayer at the Kodi forums and garbear recommends turning off the setting for rewind for RPi since it can have a negative impact, that doesn’t mean that its forever just for the moment this list is not gonna be covering standalone games just the emulators.

Feel free to contribute to this list with possible settings that can get the emulators working and which system your on.

if you get blue screens and crash feel free to post your crash log here as it will help the developers to fix issues make sure to have debug log enabled..

If your missing and emulator that is available feel free to ping a moderator or post on the thread and they will get added, but only if they can be available in Kodi under installed addons. Many of the emulator doesn’t compile at this moment due to code not being compatible this will get better over time with each revision of Retroplayer.

Here is a list from Kodi on the other platforms that has been built.

Compatibility list

Platform RPi1 RPi2 RPi3 Vero 2 Vero4(k)
Beetle bnes
bsnes-mercury Balanced
FCEUmm x x
Gambatte x
Genesis Plus GX x
GW x
Mame2000 x x x x
MAME 2003-Plus
mGBA x
Nestopia UE
Quicknes x x
Scummvm x x x
Snes9x x x
Stella x
VBA Next
Vectrex x

Compatibily notes

  • bnes - Crashes / Sadface
  • BeetleGBA - Black Screen on launch / GLES Bug (Note: Solved in 18.8-73 of testbuilds)
  • Beetle - Black Screen on launch / GLES Bug (Note: Solved in 18.8-73 of testbuilds)
  • bsnes - Crashes / Sadface
  • Colecovision - Crashes / Sadface
  • Dosbox - Black Screen on launch / GLES Bug
  • Famicon - Crashes / Sadface
  • Gambette - Crashes / Sadface
  • Mame2003 - Doesn’t launch games even after advanced settings tweak
  • Mame - Some games does not launch due to missing drivers (ntig)
  • Meteor - Freezes
  • MetorGBA - Slow emulation
  • mGBA - Crashes / Sadface
  • Nestopia UE - Black Screen on launch / GLES Bug
  • Snes9x - Reported crackling sound on RPI2
  • Stella (Atari 2600) - Black Screen on launch / GLES Bug (Note: Works in 18.8-73 of testbuilds but breaks Kodi)
  • VBA Next - Slow emulation
  • Yabause - Crashes / Sadface

Additional Troubleshooting

Some additional troubleshooting for Retroplayer


The emulator needs a .scummvm file for each game ids
the list can be found here ScummVM :: Compatibility - DEV

File association

Remove file extension association with advanced settings, this is typically done in with the following commands

nano .kodi/userdata/advancedsettings.xml

append this to the file


Archive issues

if you run into issues with archives you can try the following to disable VFS archive support

Settings->Add-on browser->My add-ons->Virtual filesystem->Archive support

set it to disable


Well Atari 2600 works via VNC. On the TV it just shows a black screen but if you login via VNC you can play.

Wierd that needs further investigation

Yes detective @Toast :slight_smile:

is that Stella ? the emulator name ?

Yeap Stella = Atari 2600

added to not working as intended, tnx :slight_smile:

@fzinken yepp indeed it did i managed to get some picture when i did a rewind but it went back to black as soon as i stopped rewinding


In order to get scummvm to “work” , you need a .scummvm file for each game, containing the unique gameid for the game. For the freeware version of “Beneath a Steel Sky”, you need to create a text file for the game, containing the unique game id. which in this case is “sky” and save it with a name that ends with .scummvm. Here are the game ids: ScummVM :: Compatibility - DEV



Genesis Plus GX (Sega Genesis/Megadrive and master system)

Semi working:

Dosbox Blackscreen but sound (no vnc or OSD helps)

Not working(reboot or Sadface)

Colecovision (debug-log of the start of the game: )

Try changing the emulated_machine setting in the dosbox settings. svga_s3 on dosbox see if that works

That was the setting i had, no change setting vga_only either, or setting it back to svga_s3

I have to change my statement: Dosbox, OSD show the background, just had to use the controller to trigger OSD, esc on the keyboard didn’t work that’s why i couldn’t get OSD while in Dosbox.

This is what garbear said on github about blackscreen with OSD lighting it up:

“I believe this is due to OpenGL initializing too early before the fullscreen window opens. I won’t have time to look into this for at least the next few weeks, so if you know anyone who wants to do some opengl debugging I’m eager to guide.”

1 Like

so the latest gmc build includes test fixes for dosbox and stella

Tried it quickly and no luck, might need more testing. Just tested dosbox and stella.

And Mame2003 isn’t working, cant test the other due to lack of roms.

is Mame 2003 effected by the same bug as Dosbox and Stella ?

Nope issues with loading of ROMs, and since it associated to zip files I had to change association in advancedsettings.xml

Yeah thats expected until they solve the logistics of handling files

OSMC 18.8-23, Pi3 Retroplayer test


Gensis plus gx(works, no vfs)
GCE Vextrex (works)

Blackscreen-with emulator running(showing with OSD)

Nestopia UE


MetorGBA(choppy sound and slow emulation)
mGBA (working for 1 min then just crashes, no debuglog yet, ssh not even working, SD indicator just shines)
VBA Next (choppy soound)
VBA-M (choppy sound)
Gambette(gbc.working for 1 min then just crashes, no debuglog yet, ssh not even working, SD indicator just shines)
Famicon(bnes)(sadface directly, no debuglogs yet)
Mame2003(nothing happens when clicking on Rom, even with advancesettings.xml .zip tweak)

Not Tested(lack of roms)

HandHeld Electronix (GW)
Nec- PC engine

VBA-M works just perfect for me been running Castlevania on it for plenty of hours without issues. updated the list btw tnx for the additional reports :smiley:

Might depend on rom then.

updated the list and added more systems really want users to confirm which systems are working on which platforms that doesnt have info.