Sad face after update

After trying to update to 19.1 (was prompted to update and accepted) - the Vero 4k restarted and ends in sad face.

Getting this error on screen before:
[FAILED] Failed to start Load Kernal Modules.
See 'systemctl status systemd-modules-load.service"

Restarting the device (unplug power) results in same error.

I’m having the same issue. Loops to sad face then black screen then sad face.

Ehh?? There’s nothing in that post of thread about Sad face loop.

If I click on “continue discussion” I get to this link:
Kodi v19 Matrix is here. Here's what you need to know - OSMC - #120 by Smack
Searching within that gives no hit on Sad face …

I have no network connection to the Vero 4k :frowning:

I get this when powering off

The first Q under “Frequently asked questions” is about sad face loop…

Please re-read. The very first Q: specifies exactly the sad face loop.

Click Kodi v19 troubleshooting FAQ

1 Like

Click the post title, not “Kodi v19 - what you need to know”.

I’m sorry - I found it now. I wasn’t aware that you could click in the top right corner of the quote you “linked” - that revealed the help.

BUT it doesn’t help me - there’s no network access to it, The Vero 4K isn’t getting an IP at all.

You may have to temporarily connect a keyboard and/or ethernet cable to the device.

I fixed using the keyboard local connect

There is a ethernet cable connected - there always is.

Getting this error at the beginning:
[FAILED] Failed to start Load Kernal Modules.
See 'systemctl status systemd-modules-load.service"

So the network module doesn’t seem to have been loaded.
When I connect a keyboard and log in - I cannot ping my own router.
Network is unreachable

Your issue might not be related.
You could take a backup and reinstall.

Thanks - is there a guide for that?

Nevermind found it :slight_smile:

Reinstalled using the guide on Download - OSMC
That leaves you with a clean install.

After reinstalling I did this:
Changed resolution to 1920x1080p - was 1920x1080i as default (!)
Changed Player “Adjust refresh rate” to On start / Stop
Removed the annoying click when click on something in the GUI :slight_smile:
In .kodi/userdata I created “advancedsettings.xml” with settings for my “mysql” database
Changed sources.xml to fit my files on NAS (using /mnt/)
Changed /etc/fstab to my needs so the NAS shares are mounted
reboot

Then it worked

This is a pretty weak solution even if it does work. Ive got 2 hosed units that I have to rebuild and aside from autofs they were bone stock. Both rigs same issue, no network connectivity. I moved setup into my office and connected to ethernet instead of wifi and still no connection. Really frustrating having to redo these things from scratch.

Please upload debug logs so that we can understand what your problem is. If it is the name resolution there are other options than reinstall.

Latest update… so, it fortunately turned out to be stupid easy to get these 2 fixed. Had to plug into Ethernet instead of wifi… and then for whatever reason I had to manually turn on eth0. Solution was:

plug into ethernet instead of wifi
sudo ifconfig eth0 up
sudo apt-get update
sudo apt-get dist-upgrade
sudo restart

Worked for both down units and we are gold for those. I have a 3rd rig that I decided to do the update from command line instead of gui, and its stuck at 65% for the last 45 mins… going to go try and figure that one out now.

My early impression is this update doesnt seem to play well with wifi, but thats purely speculation at this point.

You could also do that ethernet enable/disable via MyOSMC

Are you using 5Ghz Wifi with channel above 100? There is an issue that would require you to set your Region via CRDA to connect to wifi channel > 100