Saying goodbye to Apple TV


#1

This blog post is written by Sam Nazarko

For almost ten years, we've been supporting the 1st generation AppleTV. It's where it all began, before OSMC was called OSMC, and before Raspbmc.


This is a companion discussion topic for the original entry at https://osmc.tv/2017/09/saying-goodbye-to-apple-tv/

ATV: Crystal-HD Card not working
#2

This kind of sucks. I just bought an Apple TV and while I’m not at the same level as anyone else on this forum, I just started Computer Science and was looking to help improve on the design.

At the same time, I know that this must not have been an easy decision and I respect it. Thank you for the work that you have contributed to this project, and I will be using what you have used for years to come. Thank you.


#3

There is no longer any reason to use the atv for media consumption. You get much better performance at the same or even lower price elsewhere. Like raspberry pi or cheap amlogic-boxes, at around $30. You might even get some 4k and h.265.

If someone still insists on working on the atv, I would love it if someone did a project like dietpi (http://dietpi.com) for the atv. Have 3 or 4 atvs on a shelf collecting dust. They can still do good work, just not as a media center in 2017->
Just a thought :slight_smile:

Almost forgot (shame on me), but I have to give a great big thank you to sam and anyone else working on this project from the start. Very nice work which has given me and many more lots of good use of these old machines. :ok_hand: :+1: :clap:


#4

1st Gen Apple TV. ? You really bought as 1st Gen Apple TV?
I still have one with a broken disk in the basement (Not using it).
You realize that box has 256MBytes of Ram (or was it 128MB) ? that box is not really usable anymore for that.
Any raspberry PI is faster now :slight_smile:


#5

You could follow the instructions to disable Kodi from starting on the Wiki. That would give you a pretty minimal foundation to start with, and you’d have Debian Jessie which is still fairly modern and is still maintainend.


#6

Yes already did this on one of them, and that’s certainly a simple way to keep it going :smiley:


#7

Just wanted to say a big thank you to Sam for developing Crystalbuntu all those years ago.

Amazingly my atv1 is still going strong as my main media player. Well I say strong, but it crashes every 1-2 days and I think I’m running XBMC 11.0 Eden. I bought a Pi1 when they were released but never switched. The atv just won’t die, and you know what they say, if it ain’t broke…


#8

Want to say a big thank you to Sam as well for giving the old girl CPR for this long, you really did breath new life into it! ! I have been using my apple tv for over 10 years ! As off today it’s in our bedroom and Funny enough I ordered a vero 4K couple weeks back and it arrived today! So the vero takes pride in the lounge and the apple tv upstairs now. So I logged into the forum to get some hints and tips and seen this thread and had to comment! Many thanks for the years of updates and usage you gave to us originals Apple TV purchased after Apple washed there hands 18months later!


#9

Yes, a really big thank you to Sam for all the work he has put in to supporting the ATV1 over the years. Although our immediate family quickly moved on to using Mac Minis as our media devices, I have had a couple of ATV1s deployed with elderly relatives since the beginning, and that has worked well for them. They are only interested in older programs, so 720p is fine. I did use the CrystalHD cards for a while, but they were unreliable (due to overheating?) and the wireless (n!) was much more useful. I also replaced the hard drives with msata adapters and cards and that made a big difference. Lastly I have been using RealVNC software to remotely help out as needed (as well as SSH), and so all has been pretty good. Although there will be no more updates, I am hoping these devices will be useful for a another couple of years yet. Cheers, and wish you well.


#10

Thank you Sam for all your work on this project. I have unfortunately just bought an original  tv 1st gen on ebay to play around with after good memories of using a version of xmbc on my  tv 2 quite a lot of years ago now. I know there are better alternatives out there as have been mentioned, I just love the design of the box and always wanted one. I hope to use it for watching media on my NAS, podcasts and some tv streams. Can anyone recommend the most stable version to use? I can’t get my box to shut down properly.


#11

The box is designed to always be on and doesn’t implement ACPI


#12

Thanks for responding and clearing that up for me Sam. I am very impressed with the software! Best wishes Andrew


#13

Agghhhhhh :wink: No I don’t want to say Goodbye to my ATV, any one care to help me?

My story with the ATV Gen 1

This is a bit of a’ let it all out post’… Yes an old thread , but maybe if any one wants a chuckle and in the end cares to help me out, that would be awesome. Yes after all my waffle I do have question at the end of this post. I hope you can bear with me and read to the end.

Thanks to Sam for creating this to work on an ATV, even though it seems I am maybe nearly 10 years late to this party :slightly_frowning_face:

A few months ago , in sheer annoyance, due the GF’s nagging, I spent two days trying to get the ATV Gen1 to log back in to YouTube. She wanted her YouTube music vids on the big TV screen in the living room. She is more technically challenged than I am, she could work the remote control of the TV, Amplifier and ATV all at once and play her vids…till it stopped a few months ago. Nagged for months about it I finally thoug ti’d better have a look. After two days of trying and reading and scouring the net I gave up, ripped the ATV out and in anger chucked it out the third floor window I was so fed up. The I went down and stamped on it :wink:

Turns out YouTube removed support for ATVG1 login
It now also turns out that Apples latest iTunes and store also blocks the ATV G1 so I cant even sync or download my iTunes purchases on it.

I posted my dissatisfaction with this state of affairs on the Apple Community Forum and my messages were blocked and sent threatening e-mails by moderators…typical Apple !! If the big motor corporations like GM, Ford, Renault etc etc stopped support for older cars and disabled them with software updates, after 10-12 years there would be outrage, yet we all just accept it with tech

That annoyed me also, to be beaten by tech, so I dug around and bought another ATV Gen 1 on e-bay and this time I am determined to get it running with something.

Was so pleased yesterday :smile: to find OSMC as all my attempts so far with ATV bootloader had ended badly. I got it running in minutes with the excellent boot stick creator on here :smile: Seems that so many of the ATV bootloader tutorials I tried to follow end in dead 404 links, because what I am trying is now so ‘old’

So I got Sams OSMC bootloader USB creator from here and got my OSMC install working in minutes :slight_smile: Then I tried an upgrade, and failed, :frowning_face: I searched the forum, found a thread and posted.
Sam replied and informs me that ATV Gen 1 support is ended . :cry: At first I thought he merely meant support by Apple has ended, but no :fearful: .my only saviour, OSMC has ended support too :sob:

I know an RPI is better and quicker, I have two here already doing stuff, (RTL-SDR and heyu/HA-Bridge ‘engines’ but I want my ATV to work…as much as a 'up yours to Apple as for anything !! :stuck_out_tongue_winking_eye:

I don’t actually need a media centre as such, my NAS4Free box in the attic does all my audio serving needs to my sound system and TV/Video is not something I care for. Music is my thing.

But I do still want to get the ATV 1 running some *nix distro, so I can at least feel a sense of achievement that I have got it working.

I do not need |Kodi, Chorus, OSMC as such but would like to get it running with an *buntu OS if I can.

I am at a level where I am not even sure about the differences between *buntu and Debian OS’s, and if the command line stuff for them is the same or all different beasts.

I did see a link somewhere above, that I have not yet got to reading, about removing Kodi and having a basic Debian Jessie running on it.

But my question is ….yes finally getting there, and yes I know …not directly to do with OSMC, in fact nowt to do with OSMC, but maybe some one can take pity on me and give me some guidance :wink:

Yes, here it is ……the question :wink:

Can I just rip the original ATV HDD out and put in a bigger HDD and then boot with the OSMC Boot creator USB ? or is there stuff on the original HDD that I need to salvage to get it to boot to start with ….
maybe take out the old HDD, fit it up to a IDE caddy, and dd the contents to a bigger HDD first ?

Even good links to point me in the right direction ?

Thanks

Neil P


#14

The OSMC installer will format any sized disk.
Just reimage another USB stick and you should be fine.


#15

so there is no boot stuff on the original HDD that first tells the ‘system’ to look to the USB to boot…no boot sectors or stuff .

I 'll give it a go.

What about stopping Kodi and the media centre and blue boot screen on the local ATV screen.
I did
sudo systemctl stop mediacenter
sudo systemctl disable, mediacenterand

but when the ATV reboots I just get the blue OSMC screen with the logo. Was hoping to get just the command prompt.

I can ssh to it when the blue screen is there.

what ‘apt remove’ commands woudlo I need to use to get the ATV just running the base Jessie OS with none of your carefully crafted OSMC /kodi/ chorus running / removed.

Then I can start adding my RTL-SD stuff, I have tutorials from the RPi for Jessie for getting RTL-SDR stuff up and running Hope to get it working on the ATV too.

Thanks


#16

If you disable the Kodi, the system is pretty stripped down.

Sam


#17

Hi
sorry to be a PITA , but when it is disabled it boots to a blank blue screen, with the OSMC logo, no command prompt .

Yes I can SSH to it, but how to get the CMD prompt at the actual ATV with screen and keyboard connected ?


#18

You would enable a GeTTY via systemd.


#22

Really sorry to be a PITA but try as I have over the past few weeks not been able to do it, get Getty working

Not really sure how to do it
Have tried all sorts of commands , systemctrl Enable and similar

Can you give more of a clue please.

Just fitted a Broadcom BCM70015 Video Decoder
Does not seem to have improved playback of Go Pro video at all
How do I check it is using the new Broadcom card ?

I have version2017.08-1 installed


#23

Use an older version (2017.01) or earlier for good results with the CrystalHD decoder.

Sam