Sound does not work on live TV after update. TV and videos freeze

I posted about bluetooth streaming audio not working after latest update. IN common with another poster I find the latest patch this morning restores the connection to Bluetooth
Now however, although I can connect the bluetooth audio and I can get sound out when I play music no sound comes when watching live TV
FWIW I use DVBLink pvr and backend. In common with yet another post the last two upgrades have degraded the performance of DVBlink - it takes a lot longer to load the guide and PVR info. The playback is now very blocky and freezes every few minutes where it did not before Some channels simply wont play when they did before the update.

BUT my initial problem is that live TV play no sound over bluetooth or analogue. Videos DO send sound and at first seem not to freeze - but I have tried playing 2 just now and both completely locked the Vero (power off reboot) after a few minutes play.
I have just uploaded the logs - I recall these are supposed to be ‘debug’ but I cant find any setting to switch ‘debug’ on or off.
the logs are

FWIW I use a Vero 4k and have had relatively hassle free operation for nearly twelve months until the last updates

PS I’ve just replaced the Vero4k with a Raspi 3 running OSMC - bluetooth works fine streaming audio. Videos play without freezing. Live TV using DVBLink produces sound - have not had it on long but it does not freeze or block. This is on April 2017 2017.04.-2 - I think an open and shut case of the cause being the latest updates

Hi John,

You seem to have a lot of errors from the DVBLink PVR client:

10:45:18.970 T:3658478576 ERROR: AddOnLog: DVBLink PVR Client: Could not get timers (Error code : 2000 Description : HTTP request failed with error code 2000 (An error occurred when trying to establish a connection to the DVBLink Connect! Server).

Also, there’s one (memory leak) from BT Player Addon:

10:41:12.829 T:3857708016 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
Error Type: <type ‘exceptions.AttributeError’>
Error Contents: ‘NoneType’ object has no attribute ‘Stop’
Traceback (most recent call last):
File “/usr/share/kodi/addons/service.osmc.btplayer/”, line 196, in onPlayBackStopped
File “/usr/share/kodi/addons/service.osmc.btplayer/”, line 165, in stop
AttributeError: ‘NoneType’ object has no attribute ‘Stop’
–>End of Python script error report<–

Looks like these two are not compatible in some way with the version of Kodi/OSMC.
You could try removing/re-installing either/both of these?


Best regards,

ps I’m using LiveTV with TVHeadend on Vero4K, and have had no issues with any updates including latest July update.

thanks Nigel much appreciated

the hot fix fixed the bluetooth connection but I am getting no sound over either bluetooth or analogue when tv streaming (music and videos are ok)

For the help of anyone else - I accidentally stumbled on an answer to this - I disabled pulse audio rebooted and reenabled it

DVBlink still causes problems - slow load and lots of freezing - think I’ll disable bluetooth next and rely on analogue (not ideal but can live with it)

FWIW Nigel how would I remove and reinstall either the BT player or the whole sytem - for example if I wanted to go back to a previous version?

same issue on my end as well. audio has been killed and video is also stuttering. I also have a vero 4k and it started with the latest july update. thx.

Same issue here after july update. Heres my old thread(which includes another update problem with livetv): Vero 4K and DVBlink channel loading slow - #18 by fzinken
Hope OSMC / Vero team fixes it soon.

Belay that last story of success by disabling Pulse. I switched off bluetooth in Myosmc and rebooted
I get a BTPlayer error warning (presumably because there is no bluetooth) but there is no sound over analogue.
Tried disabling pulse again but once one reboots it comes back up again - dont know how I managed it last time.
So I am back to no sound either analogue or BT over live TV using DVBlink pvr.

Also the DVBlink live stream is now struggling badly (remember I said I’ve had nearly twelve months trouble free with the Vero 4k)
The buffering icon circle appears every 20 seconds and after a few minutes the whole thing freezes
This is on a wired network with lantest speeds of 93Mbps.
I’ve reverted to a raspberry pi with April’s OSMC and everything works fine. DVBLink suffers from the occasional 2 second stutter - which I cant understand given the lan speed - presume thats a dvblink server issue.
The Vero 4k is now a paperweight for the time being.

BTW if anyone’s interested I set up the raspberry pi with LE (or should I say another open Kodi) just to see what that was like with the same set up and it is almost unworkable - not a patch on OSMC.- well at least when OSMC -
works :wink: - but maybe its something in Kodi itself

I suppose what I should do is set up the Pi with the latest july OSMC and see if the same thing happens or if it is a Vero 4k thing. Trouble is I’ve spent more hours than I can spare already. The logs are here if anyone can make more sense of them than me for dvblink/sound failures JulyOSMC

BtPlayer is getting there but it’s still a little touch and go.

If you want to isolate this:

Try a fresh install without btplayer
If that works, install btplayer

If things go wrong then, you have your answer


thanks Sam
but how do I do a fresh install without BT player on the vero 4k - all hte installs I’ve done have been upgrades really using My OSMC and this will not let you do anything if it thinks everything is up to date. I guess its some Sudo command line magic?

Sam, I have the exact same issue with PVT, and i’m not using any bluetooth. Everything was just fine till the last update. It is definitely the Vero’s issue, as with other clients (e.g. DVBLogic’s own ios app, on the same network) everything is just fine.

@a1840317 I see a bit of crossposting from you but not your own thread with logs, so hard for me to speculate whether the issue is indeed the ‘exact same issue’.

OSMC can be reinstalled from Reinstalling OSMC - Vero 4K - OSMC. If you want, you can stick with the June version for now until Kodi v17.4 is released.

We are using the same DVBLogic add-on as other Kodi platforms, but it is more recent than some other versions (so there may be a regression). The add-on isn’t related to the iOS app.


Here is the log Sam:

Looks like a DVBLink bug.
But I notice your content being played is MPEG2. Disabling HW acceleration for MPEG2 might work as a temporary workaround

Thank you, will try. BTW is HW enabled by default on Vero for MPEG2? Also it seems something has changed in Vero if DVBLogic is the same version but has a “bug” on the new OSMC system right?

Not necessarily – we update the binary add-ons when we rebuild Kodi, so the issue might have been introduced by a new version of the add-on. I haven’t seen any reports of Live TV issues with other PVR add-ons (i.e. IPTV or TVHeadend).

Yes – unless you disabled it

Tried disabling the MPEG2 HW acceleration but same.

When you are saying you updated some binary add-ons, does it mean it won’t be updated through the add-on manager but somehow “hardcoded” into osmc? Just wondering who and when will fix this.

Okay – that confirms that it’s almost certainly an issue with the add-on itself, and not changes to OSMC’s hardware acceleration; as ffmpeg has problems too.

Binary add-ons are distributed in OSMC but we do not develop them. So we need to wait for a fix from the maintainer of this add-on.

Thanks Sam!

So the earliest when we can see this update would be the Sept release? (if DVBLogic fixes it + considering the update frequency of OSMC)

There hasn’t been an August update yet, so you might be in luck there


Under Windows Kodi + DVBlink addon work just fine! Later on today i will try Android + SPMC.
June update worked with DVBlink addon just fine. Under Android 7.1.1 with Kodi 17.3 works also flawlessly.

Try disabling amcodec in settings>playback (I think that’s where it is, going from memory)