Spontanious reboot after 2016.2-1 update

Hi. Updated to the most recent update today (via manual update). I had to click “search for update” twice Since it just stopped after a couple of downloaded packages. When the download was completed my pi2 rebooted and started the installation. When the update was done I waited for the initial freezing that was announced in the releaseblog.
However, i got sad-smiley and reboot, after this reboot the pi froze for almost two hours. However I could access the pi via ftp (which I found weird).
Eventually i could reboot, but now I get sad-smileys every one or two minutes. At first i thought it was the screensaver since it sometimes happened right after the screensaver kicked in. But I get sad-smiley if I play a movie, go into settings, go into myosmc, or just plain do nothing at all.
My initial thought was that the update somehow failed so I went into myosmc to search for updates. It downloads new files and then states “no updates availiable” and in the lower left corner it says “osmc february 2016 2016.2-1”

I don’t know what to do next…

I have created logs here:
Http://paste.osmc.io/fasuradepu

Would really appreciate it if someone could help me.
Thank you

Regards ftwtysken

I have the exact same issue on my RPi2, coming from OSMC 2016.01-1. I don’t have tv headend or anything, only a USB drive and a Bluetooth dongle.

I simply performed the update via MyOSMC. Nothing funky. But after the update (blue screen with progressbar) finished and the Pi restarted, I ended up in a bootloop.

Constantly switching from sad face > Kodi home screen > Sad face > Kodi homescreen etc.
The Sad face stays for about 10 seconds, Kodi screen just 1 second.

Logs via ssh (“grab-logs --all”):
http://paste.osmc.io/bukotozemo

Now I can’t watch TV :sob:

This topic is a duplicate, the issue is already being discussed here:

This topic can be closed.

Not really, because that post is from October. Symptom may be similar but the cause certainly will not be. A quick glance at that thread shows me he is running a web server and that may have caused issues with Kodi’s web server

Edit: read it more thoroughly. If Vcio isn’t accessible Kodi will not load at all yet some users say they can use Kodi for a few minutes before a restart, so it is not the same issue necessarily

Oops sorry, I thought the topic was just a few hours old! Sorry.
@tterrafan must have thought so too.

I did try your suggestion from the other topic, nothing changed, still in a bootloop:

osmc@KodiTV:~$ sudo apt-get install --reinstall rbp-userland-osmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  apt-transport-https libbluray1 rbp2-image-4.4.0-1-osmc
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/1790 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 31902 files and directories currently installed.)
Preparing to unpack .../rbp-userland-osmc_1.1.7-6_armhf.deb ...
Unpacking rbp-userland-osmc (1.1.7-6) over (1.1.7-6) ...
Setting up rbp-userland-osmc (1.1.7-6) ...
Processing triggers for libc-bin (2.19-18+deb8u3) ...

Yeah I read that topic, but since it was pre-february-update I thought I Would create this as a new topic.
And I have not installed any new add-ons since I did the last update.

Forgot to mention: I removed the 2 video sources in Kodi (Movies and TV Shows) it needed to be cleaned anyway but I thought I just remove the sources (Kodi performs a clean automatically) and then reboot. After that I performed the update.

I would simply add sources again after I cleaned up my harddrive (now I have plenty of time to do that :slight_smile: ). Trakt addon will sync the watched status of everything after adding the sources.

edit: is it actually possible to rollback to the previous OSMC version?

From your log it isn’t possible to tell much more than that Kodi is crashing, but there is no obvious cause. The most likely reason is that you have an addon or Skin that is not compatible with Jarvis.

You could go back to the default OSMC skin (and other default Settings) by deleting /home/osmc/.kodi/userdata/guisettings.xml

I would try this first. If that does not help I would try removing any 3rd party addons until Kodi loads again.

You can do this by removing them from /home/osmc/.kodi/addons/ by moving them to another directly such as your home directory.

I assume you are answering me?
I’m using confluense, but will go back to osmc and try removing other add-ons. Will reply here tomorrow with results.

13 posts were split to a new topic: Mediacenter crash after update (CEC related)

So, i have now disabled all add-ons, and returned to osmc-theme. But I still get sad-face.
(could not find the “.kodi”-folder via ftp so I’ve uninstalled and disabled them via the pi itself)
I’ve also disabled CEC.

I enabled debug loggning and uploaded a new log here:
Http://paste.osmc.io/ewocikohuf

It’s a hidden folder, you need to enable display of hidden folders. Anyhow for such kind of work I would recommend to use ssh to access OSMC.

1 Like

Can’t test now, will do tonight but from reading these observations, my issue is different. It reboots within 1 second, I only see Kodi in a flash. The sad face stays for a bit longer.

The addons I have:

  • the official Youtube addon
  • the Radio addon
  • the Trakt addon
  • the Eminence skin

That’s it. Nothing funky. I’ll back up those folders and delete them to see what happens.

I doubt that the Eminence skin is compatible with Kodi Jarvis

You’re right, it seems Eminence 2.0 (still in beta) is the version to use with Jarvis : http://forum.kodi.tv/showthread.php?tid=237538

Then I would recommend posting a new thread

As @fzinken suggests – the Skin is likely the issue

I suggest you fall back to osmc skin by changing in guisettings.xml the skin default
<skin default="true">skin.osmc</skin>
in the lookandfeel section.
And let us know from there

A post was merged into an existing topic: Mediacenter crash after update (CEC related)

Sam I think this is ok, actually zilexa started the thread which then got a bit hijacked by another topic which I now have moved out.
I think “Spontanious reboot (of the mediacenter)” is very likely a skin issue.

I have done the following:
Disabled or deleted all addons
Disabled CEC
Changed to osmc skin

I then used ftp to delete guisettings.xml

And that seems to have done the trick. It’s been running smoothly ever since.
After this I enabled most of my addons without problems, and changed my skin back to confluense - also no problems. CEC I left disabled since I don’t need it.

So for me it seems like it was guisettings.xml that was the reason for my sad-smileys and I now consider my problem resolved. Thanks for the help guys.