Stutter using tvheadend

Hi guys

I’ve just received my 4K. Everything’s fine except that it would appear that it doesn’t change refresh rates correctly. When playing back 50hz tv(live) there’s an noticeable stutter. This only happens with the four channels I have that are 50. The 24hz and 24hz media in general played back through Plex kodi add on works just fine.

I didn’t have this issue with rpi 3 and libreelec.

Any ideas what the issue is? Change refresh rate is set as usual.


Can you post a debug log?
It will explain the rationale between refresh rate changes, or lack of.

Also: does changing GUI to 50Hz manually and pressing play look OK?


Hi Sam


Changing refresh rate doesn’t help

This isn’t a debug log.

Are you using HW acceleration? I have similar issues from july update: Vero 4K and DVBlink channel loading slow - #28 by teetniin

Probably not related: is your issue only that there isn’t refresh rate changing?
I thought your problem was slow load times.

Sorry to hijack this topic! Two updates in a row messed up my OSMC! First one was channel loading problem(in june). I found settings that worked well. Then was next update(july) that made my LiveTV stutter and have no audio. I have quite thoroughly looked into the problem. Sam please read my topic again, there might be something useful. It might be HW acceleration drivers related.

I’m sorry to hear that. Unfortunately I need to reproduce the problem to be able to see why you are experiencing this problem.

We had a DVBLink problem with a user in June but this was affected by disabling transcoding.

Hi Sam

I’ll get the logs tonight

Hi Sam,

Is this it?

I’ve turned on debugging, rebooted, then tried playing TV2(problem channel) - then switching to Kanal 4 - which works.

Here is Mediainfo on a recording from the 50hz channel, exhibiting the same issue when played back through Kodi

ID : 2820 (0xB04)
Menu ID : 1282 (0x502)
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4
Format settings, CABAC : Yes
Format settings, RefFrames : 4 frames
Format settings, GOP : M=4, N=24
Codec ID : 27
Duration : 1 h 4 min
Bit rate : 10.0 Mb/s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate : 50.000 FPS
Standard : Component
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.218
Stream size : 4.56 GiB (89%)
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709

20:04:27.085 T:3557139440 DEBUG: CRenderManager::Configure - change configuration. 1920x1080. display: 1920x1080. framerate: 25.00. format: AMLCODEC

TVH seems to be reporting 25.00 as the framerate.

For the channel that does play correctly:

20:03:55.958 T:3557139440 DEBUG: CRenderManager::Configure - change configuration. 1280x720. display: 1280x720. framerate: 50.00. format: AMLCODEC

I think it’s an issue with the channel specifically.

Are you saying recordings are problematic too? That’s useful to know and could help me solve issues. Can you send me a recording / sample?

Yes i’ll PM you a link of the recordings, its the same issue on the same channel.

Hi Sam,

I’m not sure, but is it possible to PM you the link, i’d rather not post it in public.

Hi Sam,

Any way i can get you the recording?

Same trouble here I believe.

Here in the UK it seems to be HD Freeview channels that I’m having problems with (served by tvheadend on an Rpi2 with USB tuners and NAS storage - all fine accessed by OSMC on Rpi3).

There have been stutters/judders with live streams and the recordings, but in some cases live looks ok and only playback of the recording is affected. Given the 25/50Hz issue I’m wondering if it relates to interlacing?

Just posting to say I’ll be weighing in on this by the weekend with some logs, samples etc.
I was trying to nail down the pattern a little better before posting is all. Just making slow progress as I’ve had to fall back to the Rpi3 for daily use. Family have forced my hand over this and the other teething problems I’m having with the Vero4K.

Can’t you just use dropbox?

@sam_nazarko @hissingshark

Here is a link to a news segment from this morning, particularly good because there is scrolling which is jerky because of the failed frame rate adjustment.

Hi @Trekster

Thank you for this sample.

I think this is a duplicate of 25Hz content playing back at 50Hz - #20 by brifletch. Can you see the advice I have put there?


Hi @sam_nazarko

I created a advancedsettings.xml in the user directory of kodi with:


And rebooted Vero. But it doesn’t seem to have fixed the issue for me. I don’t have a 4K television this is a plain 1080p Sony Bravia 2015 Android tv.(55W805C)