Stuttering / frame skipping with various content

Hi all,
I’m happily using a Vero 4k+ for more than 6 months but recently I’m experiencing some weird stuttering issues, mostly on h265 1080p24 and 1080p23* content.
About my setup: all content is stored on a NAS and it is connected to the same router as the Vero via Gigabit Ethernet (both wired :slight_smile: ). I’m using NFS to access the files. Never had any issues with this setup and nothing changed in the network chain since I’m using the Vero unit.
My display settings are:
Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> Always (but it’s the same effect with “On start/stop”)

Sync playback to display is off

The Vero is connected to a relatively recent LG LCD TV and all audio is passthrough via HDMI (Vero → TV → ARC Soundbar).

So what I see: after starting the video, stuttering starts almost immediately (apart from being visible, it is also quantified when I enable Player Debug Info). What I can see in the debug info is whenever the pc frames drop to zero, that’s when frame skipping occurs.
If I restart the Vero, it seems the effect is not present, at least not for the first video I’m playing.
All in all, it’s sporadic but also somewhat deterministic :exploding_head:

Note: For whatever reason I don’t see this effect on UHD content at all (also h265 encoded)… also very rarely on h264 HD content. But I can see it on SD MPEG4 and h264 content :thinking:

I’ll upload logs as soon as I can.


It would be good if you could post some logs when you experience the stuttering, as this may give us some clues as to why you are experiencing this issue.



1 Like

Hi Sam,
Enabled logging, restarted the Vero and reproduced the stuttering.
Logs are uploaded here.

Mediainfo exports for the two files I tried:
Escape from New York
Twelve Monkeys

I noticed (again) that the stuttering gets worse with the number of videos I play after restarting - the first video I play has no skipped frames, then stopping and playing another one (or even the same one again!) will result in stuttering.

Edit: I copied Escape from NY to a proper USB stick (formatted to NTFS) and played it from there too. Same stuttering :roll_eyes:

I’ve also been experincing some of the same problems as Tom recently. I have my media on two USB hard drives connected to the Vero 4K+ directly with exfat format. Up until recently never had any problems even with 4K/HDR content. Now I often get frame drops and juddering for 5 seconds on certain content, but the audio remains unaffected. One of my USB hard drives is portable and powered only through the USB, recently it has been making seeking beeping noises occasionally. I figured perhaps with age power issues were causing the problem so boughy a new hard drive with dedicated power supply, copied thecontent over… and yet the problem remains! All the content plays back perfectly on my macbook and tablet.

From Tom’s post I am just realising now that perhaps it only happens with SDR or non 265 content as some film and series I have been watching I’ve had no problems. I’ve attached a log with the problem happening on two different files (both SD content). The first has constant frame drop/stuttering the second (curb episode) as intermittant stuttering every 5-10 mins.

Thanks for any help

Try setting Adjust display refresh rate to On start/stop.

1 Like

I will try that, thanks.

I set “on start/stop” as advised, then restarted the unit. Same content. Still stuttering unfortunately :persevere:


Here they are.


Please try nfs kernel mounts, rather than kodi soft mounts. Easiest way IMHO is with autofs:

Mounting network shares with autofs (alternative to fstab)?

Thanks Tom.

I don’t see how that would improve the situation as I tried playing back the same content from a USB stick with the same results. Also, the stuttering effect is relatively recent, I started noticing it a couple of weeks ago.

I can’t see anything that might have happened 2 weeks ago that might have changed things. You haven’t updated since December, but I doubt there’s been any relevant updates.

Did you try playing those videos from USB with On start/stop?

Now I tried playback from USB as well - same results. For reference, I tried playing back UHD content from the NFS share too - no frame skips (~10 times the bitrate).
Actual logs here.

Just a question: do you think that the official Kodi V19x release (which I believe are now imminent :wink: ) would help in this?
I’m OK to wait that much, but it would be nice to know why this anomaly popped up recently anyway.

Agreed. There are a number of things that can cause stuttering so we couldn’t say whether the upgrade would help you.

Ok… so what’s next then?

I used to have stuttering issues with a lot of SD content on kernel 3.x, but all those issues disappeared when I switched to the 4.9 kernels (the testing branches). So your problem may disappear after the upgrade.

I distinctly recall many SD h265 having issues, as well as DVD iso.
Two things you can try now though:

  1. bring up the video options when playing one of your SD files, and try turning off de-interlacing and see if that helps, If you try using anything above “nearest neighbor” it causes a lot of stuttering (too much for the CPU)

  2. Go into Settings->Player->Video and try turning off hardware acceleration and see if the SD videos play ok with it off. (don’t remember the exact options under Leia, they changed in Matrix)

I’ve been having stuttering issues as well.
Sometimes apparently resolved with a reboot, sometimes not.
Decided to come on here and see if there’s a known issue and sure enough this thread was right here at the top.
I also noticed major hangs when navigating menus as well.
I’ll grab some logs next time I watch something.

These may be related:

Interesting, in my case, the GUI works just fine, no hangs at all.

Hi everyone,

I also observed stuttering with some Bluray content (mostly concerts). That was very disappointing as I’ve just replaced my RPi with the Vero player and the Pi didn’t have theses problems. However, what fixed my problems was to set the Settings > System > Display > Refresh Rate from 23.98 to 60 Hz which is the native rate of my projector. ‘Adjust display refresh rate’ is OFF and hardware acceleration enabled (with default settings). Now I’m very happy with my Vero player and hope this tip will help you too.