Stuttering menu on Vero 4K+ and Aeon Nox

I’m a little bit desperate.

I had (and still have) a Pi3 with Libreelec and AeonNox (Silvio) on a FullHD SonyTV and hoped that with a Vero4k everything would be a bit faster and smoother.

I made all the settings on the Vero4k exactly as on the Pi3, but then the disappointment: on the Pi3, the horizontal scrolling through the main menu (Movies <-> Music <-> Settings, etc) is almost always smooth, with the Vero4k it stutters constantly. Only slightly, but everytime. That drives me crazy… When I watch a movie and fade in the information with the “i” button or with “OK”, there is always(!) a small stutter in the movie, this is not the case with the Pi3.

I tested AEON Nox: Silvio and AEON Nox, the same for both.

Display refresh rate is set to 60.00. Tried others but it didn’t helped.

What can I do? If it stays that way, I have to send the device back, stuttering menues would make me mad… :frowning:

Would appreciate your help,
Thanks and sorry for bad english :wink:


Can you please upload some logs via My OSMC so we can see how the device is configured?
There are a number of users using the Aeon Nox skin on the Vero, so we should be able to solve the problem for you.



I tried to upload it via the Log uploader in My OSMC but it says “Could not retrieve URL.”

Tried also the new Vero4K update from today: doesnt help

I have also tried to make a complete reset of OSMC but over MyOSMC it doesnt work. Nothing happens

Sorry, i’m a complete newbie with these things :wink:

It sounds like the device is not connected to the Internet.
I would suggest re-installing OSMC from Reinstalling OSMC - Vero 4K - OSMC if you wish to start fresh


You are right, after the OSMC Update the Vero lost his wifi connection. Also it can’t recognise any of the wifi-networks in the house now…so i connected it via cable.

Upload of the log is working now. ULR is: imofanugoc

thanks for your help!

Just update once more while connected via cable and WiFi should work again.

Thank you, fzinken (Bist du Deutscher? :))

I made a complete reset of the Vero4k+ and did nothing more than install the nox silvio skin but the menu is still stuttering.
I uploadet the logs once again:

For testing i also installed kodi with nox silvio skin on my Amazon FireTV 4k Stick and the menu there runs as smooth as on my raspi 3 with libreelec.

Any ideas?

Thanks for your efforts

That’s quite strange. While there are surely performance limitations of the Vero it surely should perform better than the Pi3. Also doing a search here on the forum seems other people are using it.

If you switch to the OSMC Skin, does the performance immediately improve?

Have you made any customisations to the skin like menu or shortcut changes?

I can try the skin tomorrow myself to try and reproduce the problem.

The menu of OSMC Skin is completly different, but yeah, it runs smooth. Switching back to Silvo or Aeon Nox 5: Redux and the menu is jerky. I made no changes to the menu, just installed OSMC and then the skin. Aeon Tajo seems to run fluid too (but has a different menu style), Aeon Madnox is jerky

It is not everywhere, it is especially if i navigate horizontal left and right between the main menu symbols (Movies<->Music<->System<->…) I have always a slight stuttering which i dont have on raspi3 or FireTV Stick.

Tried out different HDMI cabels, ports, menu frequencies, resolution and other settings over hours now, but nothing helped

Seems that nobody can help :frowning:

Can you show us a video of the problem?

I made two videos, shooted with my mobile phone:

Menu with Pi3:!AobN_Z9g5NIlog75EseTBosrZ1UO

Menu with Vero4k+:!AobN_Z9g5NIlog9u_dSxNS8nu6OU

These are OneDrive links, please download the videos for best picture quality. Hope you can see a difference

Thanks for uploading the videos.
I’m struggling to see a difference. Can someone else see the issue?


Have you downloaded the videos completely before watching? Because the Onedrive-Videoplayer has a really bad picture quality.

I think the sluggishness comes from the audio delay in gui on the Vero 4k. I had that too until I changed one setting, I think „keeping audio device alive„ or something… after I changed that, audio in GUI was instant and everything felt snappy again.

You won‘t notice the difference on the videos he posted above if you don‘t watch it with sound, The impression that menus are stuttering and behave sluggish comes from the oh so slight audio delay. As mentioned, that is fixed by changing the setting above…

So he’s referring to sound stuttering and not visual (picture) stuttering?

Its a visual stuttering, not sound. Changing the setting of “Keeping the audio device alive” to “on” didn’t help.

The stuttering is small but permanently. Also when watching a movie and press “i” on the remote there is a small stuttering in the movie before the information-menu comes. On Pi3 i have no stuttering here.

OK – final question. Can you reproduce this on a blank installation, ie without a video library? If so, then I can download the skin on to a system and see if I can reproduce the issue. It might be easier to set it in person.

Yes, the stuttering is with or without a video library. I only installed osmc, then immediately the skin. Please test also, if you have the stuttering while watching a movie and pressing “i” on the remote.