[TESTING] Kodi v19 builds for Vero 4K / 4K +

It seems to help. Problem is I’m not 100% sure because if I get a 4k movie to start and then I stop it I can’t get back to kodi. I get a blue screen from the projector. It’s something not playing nicely with the projector. It’s a JVC rs500 and it takes its sweet time between refresh rate changes

Fair enough – is it possible for you to test on a TV temporarily to eliminate this factor?

Ideally we need more logs after that command.



Log attached. I have another vero connected to a denon receiver that is connected to a tv and no such issues. Very strange behavior from the projector. I turned on the logs and restarted the vero and kodi didnt come up so i restarted media center via the command line and it came up. I tried to play a 4k movie and it failed. I ran the command you gave me and tried to play the same movie. It failed. I immediately tried a different 4k movie and it worked. I was able to replicate this behavor 3 times in a row. The same movie would fail but a different one would work immediately after. Seems like an hdmi handshake issue with the 4k movies.


Think I spoke too soon about my other vero working 100%. That one plays 4k movies and regular blu-rays fine every time. It’s having trouble with 3D movies though. Fails every time. Here is the log:


Just updated to the newest beta and now I got this :frowning:
Just a bluscree with a sad face.

Well either provide logs via grablogs -A and/or remove the user data following the instructions here

just did a clean reinstall and updated to the latest beta. now the vero is booting correctly. but my problem with the missing covers from collections still exists :frowning:

Here is the log file:


Thanks Tanio99,
Now in Blue ray ISO container which have 2d and 3d subtitles is ok , as it should be.
Works perfect !


Would it be possible for you to share the file that would allow us to reproduce this on a different site temporarily? If you’d prefer you could also send us a link via PM.

Just want to make sure the two logs I posted don’t get lost in the shuffle. This one for the 4k movie issues with the projector https://paste.osmc.tv/komuqulewi

And this one for @tanio99 for 3D movies not playing on my tv https://paste.osmc.tv/yubiyetana

You’re using a GUI resolution of 1920x1080 @ 59.94i. Can you try a progressive/non-interlaced resolution?

Ah. That did the trick. I wonder if that is what is messing with my projector too for 4k movies. Let me go test that as well. It must have defaulted to that when I upgraded to Matrix. Thanks!

1 Like

So I managed to fix my playback issues. The answer was to turn off adjust display refresh rate. This actually makes sense as the projector handles this. By having it on, kodi and the projector were trying to negotiate what to do against each other. Everything plays straight away now.

1 Like

I’ve got the looping smiley face issue, too. Removing user data didn’t work and ‘grab-logs -A’ returns “command not found”.

Sorry typo from my side grablogs -A (corrected my earlier post)

HLG HDR used to work after a fresh install (stream UHD test channel using pvr addon vdr vnsi). After a recent update using the testing repository, my TV no longer triggers HLG HDR.

I’m seeing issues with HLG too. HLG videos on YouTube are triggering the TV to switch to HDR, but not HLG HDR. And the UHD test loop in iPlayer is actually being output as SDR.

Do y’all need logs?

Logs are always needed to debug. :slightly_smiling_face:


The first video played here is the iPlayer UHD test loop; the second one is on YouTube. I tried playing the iPlayer loop in Kodi Matrix on my Amazon Fire TV Cube, and that correctly triggers HLG; so it’s probably not an issue with the TV or with the iPlayer add-on.

We’ve tested HDR10+ and HLG here with different TVs now… All have reported HLG correctly, same as HDR10+. Only VP9.2 HLG is reported as HDR10 which is a known bug that hasn’t been fixed yet :slightly_smiling_face: