[TESTING] TVHeadend 4.2.4


There have been a few requests for TVHeadend 4.2.4. While preparing it for Debian Stretch I’ve also updated it. Things should work as expected, with a few improvements.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.



I have started testing.

_update went smooth no problem for the moment

Made the update some minutes before. Before I start testing TVHeadend a first comment

After update the flag

** settings -> interface -> Skin -> Configure Skin -> Background -> Use default OSMC background colour **

is disabled which makes it nearly impossible to see the white menu items everywhere.

Possibly related to this skin update:

There was some discussion here: How to replace background - #26 by seamonkey420

I’m not sure why it’s not quite working for you. A debug log might give some hints.


1 Like


As I told the flag is disabled, here how it looks like with disabled default OSMC color in the logging menu:

I see – and if you enable it again, it looks OK? But the problem is that it’s disabled by default?


Yes, exact what I wanted to say. :wink: Sorry for my English.

1 Like

I’m using an AVM DVB-C and I’m the author of the How-To-article [HowTo] Configure Tvheadend 4.2 and the Sat>IP Server AVM FRITZ!WLAN Repeater DVB-C on OSMC.

With the TVHeadend 4.2.4 I get mediacenter crashes (sad face) whenever I try to switch to a TV channel.

  • How can I collect senseful information after the crash which helps you? Should I simply try grab-logs -A afterwards?
  • How do I revert back to previous TVHeadend?

sudo apt-get install --reinstall armv7-tvheadend-app-osmc

Check TVHeadend logs and exit code from systemctl.

root@osmc-vero4k:~# systemctl status tvheadend -l
* tvheadend.service - TVHeadend Server
   Loaded: loaded (/lib/systemd/system/tvheadend.service; enabled)
   Active: active (running) since Mon 2017-11-20 07:40:09 CET; 5min ago
  Process: 1336 ExecStart=/usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u osmc -g video (code=exited, status=0/SUCCESS)
  Process: 479 ExecStartPre=/bin/sleep 10 (code=exited, status=0/SUCCESS)
 Main PID: 1338 (tvheadend)
   CGroup: /system.slice/tvheadend.service
           `-1338 /usr/bin/tvheadend -f -p /run/tvheadend.pid -C -u osmc -g video

Nov 20 07:40:35 osmc-vero4k tvheadend[1338]: htsp: [ osmc | Kodi Media Center ]: Disconnected
Nov 20 07:40:35 osmc-vero4k tvheadend[1338]: subscription: 0002: " [ osmc | Kodi Media Center ]" unsubscribing from "Das Erste HD", hostname="", username="osmc", client="Kodi Media Center"
Nov 20 07:40:35 osmc-vero4k tvheadend[1338]: htsp: [ osmc | Kodi Media Center ]: Write error -- Broken pipe
Nov 20 07:40:36 osmc-vero4k tvheadend[1338]: mpegts: 330MHz in Unitymedia - tuning on SAT>IP DVB-C Tuner #1 (
Nov 20 07:40:36 osmc-vero4k tvheadend[1338]: subscription: 0003: "epggrab" subscribing to mux "330MHz", weight: 4, adapter: "SAT>IP DVB-C Tuner #1 (", network: "Unitymedia", service: "Raw PID Subscription"
Nov 20 07:40:50 osmc-vero4k tvheadend[1338]: htsp: Got connection from
Nov 20 07:40:50 osmc-vero4k tvheadend[1338]: htsp: Welcomed client software: Kodi Media Center (HTSPv25)
Nov 20 07:40:50 osmc-vero4k tvheadend[1338]: htsp: [ Kodi Media Center ]: Identified as user 'osmc'
Nov 20 07:40:53 osmc-vero4k tvheadend[1338]: http: HTTP/1.1 HEAD /imagecache/2 -- 404
Nov 20 07:41:07 osmc-vero4k tvheadend[1338]: subscription: 0003: "epggrab" unsubscribing

Resetted the Logos/user Icons and can start playing any channel from the web interface … but still crashing OSMC.


sudo apt-get install --reinstall vero3-mediacenter-osmc/jessie

This command worked to go back to TVHeadend 4.2.2, after reboot all worked as usual, no crashes anymore. Thx.
I’ve to leave for work till this evening.

I tested your update and after update I have only Realtek tuner visible. Panasonic tuner missing.
Same like this picture:

My logs are here:
The logs was made after restart
Do you have some suggestion what can I test before reverting to 4.2.2?
Thanks for your ideas


Are you saying TVH update has removed some tuners?
This is normally determined by kernel, not TVH.

Edit: I’ve followed up on that post now. I don’t think it’ll be TVH related.

I´m not sure whats happen
I have same problem from begining - sometime the Panasonic tuner was detected in TVH, sometime not.
Looks better after reinstallation of TVH by your recommendation here (Panasonic was detected every time I tested):

Howevere Panasonic tuner still not found DVB-T2 services - only DVB-T
Then I tested TVH 4.2.4 and after this never detected Panasonic part of your tuner

OK. Sounds like we might want to use the older skin for now until @BobCratchett returns.

1 Like

na, its ok. i’ll deal w/the issues. i noticed that if you actually just stay in the settings for OSMC after making menu changes it will keep custom skin background/transparency settings. It only seems to reset when you go back to main menu of OSMC. :slight_smile: and lastly… Sam… you rule dude!! :slight_smile:

After reinstallation of my Vero 4k I gave the mediacenter with TVH 4.2.4 a second chance.

The file /etc/apt/sources.list looks afterwards totally different, so the advice to only remove the added line is not valid (anymore).

/etc/apt/sources.list before this update (original)

deb http://ftp.debian.org/debian jessie main contrib non-free

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://apt.osmc.tv jessie main

/etc/apt/sources.list after this update

deb http://ftp.debian.org/debian stretch main contrib non-free

deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free

deb http://apt.osmc.tv stretch main

deb http://apt.osmc.tv stretch-devel main

The following packages were touched by this update

The following NEW packages will be installed:
  iproute2 libpkcs11-helper1 openvpn
The following packages will be upgraded:
  armv7-connman-osmc armv7-tvheadend-app-osmc base-files-osmc gnupg gpgv
  libssl1.0.0 libwbclient0 mediacenter-skin-osmc openssl tzdata

Again the settings
settings → interface → Skin → Configure Skin → Background → Use default OSMC background colour
was unwanted disabled by the update and the menus are hard to recognize by this Color template with original OSMC skin.

Unfortunately the mediacenter still crashes with a sad face in at least these two scenarios, see “Old Kodi Log” for last activities before the crash

  1. Trying to play a TV recording (file “heute-journal.ts” on connected HDD) made with TVH, play started directly from the OSMC’s video-menu
    Log set: https://paste.osmc.tv/ebuminibun

  2. Trying to play a TV channel (German channel “ZDF HD”)
    Log set: https://paste.osmc.tv/aqofagonax

At least in first scenario TVH is not on board since OSMC just should play a raw video file on disc. Also in the second scenario it looks to me from the log, that the crash occurs somewhere in the VideoPlayer code and not in the TVH but just guessing.

Went back to previous /etc/apt/sources.list and vero3-mediacenter-osmc including TVH 4.2.2 using backup file of source.list and sudo apt-get install --reinstall vero3-mediacenter-osmc/jessie. All seem to work as before after that.

Be careful – you won’t get Stretch updates properly if you tinker too much with sources.list. Or at least you will need to manually change it back later.

So, placed the sources.list with all the “stretch” lines in place, see my post #18. Do I have to remove any line now like mentioned in your initial post?