addon doesn't scrobble or bring up rating dialog

Hi there,

I already searched the web and this forum, but couldn’t find any solution to my problem.

The situation:

Installed latest OSMC and installed addon from official Kodi repo. Did the initial setup and added the RaPi2/Kodi with the pin method to Afterwards I run the addon for a first sync with Than I started to watch a movie and after the movie finished, I expected to get the rating dialog. But nothing. No rating Dialog, nothing.

I switched the skin to Aeon Nox, which I used on my old OpenElec setup and where I get the rating dialog, but still nothing. Switched back to OSMC skin, didn’t work after finished another movie. Checked with and seen there, that OSMC isn’t scrobbling the actual movie.

Switched cards back to my OpenELEC setup and scrobbling and rating dialogs come up after finishing a movie. Switched back to OSMC, nothing.

Any ideas?

2 posts were split to a new topic: Banned addon

Please, have in mind that is not a banned addon, It is available on official Kodi repository under “Programs” category.

Denial of support alleging piracy is a little bit unfair. The OP clearly is indicating that the download of the addon proceeds from official repositories.

Please, correct this situation quickly, there are several threads not receiving correct support for this missunderstanding.


No one has alleged piracy against OP here.

If the addon itself is broken, what do you expect OSMC to do about it?!

The addon is not marked broken over the official repository.

Why are you assuming that it is broken, or worst, banned as you clearly pointing before?

This means nothing. There can be found several broken addons on the official repo that have not yet been reported as broken.

Because that addon is notorious for having API issues with the Trakt website in the recent past. With a total of 3 complaints from literally tens of thousands of OSMC users, it would be unlikely that the problem is with OSMC, until proven it is. Additionally, without logs, we have no idea what those user’s issue may be and exactly zero users who claim to be affected have provided any logs demonstrating the issue as are requested clearly on this forum for all support requests. See - How to submit a useful support request - General - OSMC

You are being quite daft on this point. The removed post clearly broke forum rules, as posted here FAQ - OSMC Forums

So, you’re mixing a previous banned denial of support for other addon to deny support on other thread for a not checked broken (mystically statistically assumed) addon? My point of view stands. Statistics aside, at least suggest after asking for logs to contact addon devs if not OSMC signs of fail encountered. Your previous derivation to the banned addon without any explanation on this thread was wrong. Banning the previous thread without supporting the real question over also was wrong, but I see that you correctly addressed the support after my intervention. Thanks for that.

As a current “no problemo” user of on several OSMC over Pi1, I find your statistics and concept of support are little bit stern, maybe fair, but stern.

Please, this is only a constructive critic over your assumptions only, don’t get me wrong, you always do a fantastic job here.

No one is denying support! We have simply been provided no information with which to begin to troubleshoot an issue. It would be like asking the mechanic to fix your car without allowing him to look under the hood.

In no way are you correct. The banned thread broke forum rules and was handled accordingly. The baby goes out with the bathwater in this situation. There will be no deviation from these rules. If OP had left out a few key words which had zero to do with his issue, the post would have stood. Even now, he could edit his post and have it returned to public view.

This statement makes it quite clear that there is no problem with running on OSMC and makes all of my “assumptions” almost certain to be correct.

You didnt even point to the forum rules as a response of this thread, you only derived to a banned thread for other addon as a response. That was like send the car to the wreck yard because other dude’s car has a tail light problem. Or killing the baby under the assumption that it cannot be saved because other babies are already in the water.

Oh, and my statement of OSMC working well with addons don’t make your assumptions correct. It is exactly the opposite, you’re assuming as problematic addon that for sure will have problems so you didn’t even check & help if the OP has a config problem or if it is an explicit bug in the addon:
You just split the thread pointing to other banned addon thread. If that is not a wrong assumption…what it is?

Enough for me, I don’t want that this go personal and not over support process. In a year i’ve think this the first time I don’t totally agree with a response of yours ActionA, that’s why I wanted to give my opinion. It is ok if you don’t agree. Regards.

You must be kidding. Go back and look at my post that closed the thread. It looks exactly like this -

We have removed your thread from public viewing because it mentions a pirate addon. We cannot provide support for these. To get a better idea of our piracy policy, please see this link here FAQ - OSMC Forums

It is outside of OSMC’s scope of support to advise users on how to configure their addons! Who could give better support on the configuration of an addon than the developer of the addon??

Please! Move on! You have gotten your feelings hurt seemingly after I’ve treated broken rules in this thread in the same way as I’ve treated them in any other thread. Now you expect OSMC staff to spend our free time advising users how to configure specific addons simply because they are available in the Kodi repo? You’ve served to do little else than drag the entire thread off topic.

Ok, let’s do some quoting

I’m talking about this thread, which is not closed. You added information in the other thread after my intervention, because clearly you killed a baby. ¿Remember?. Maybe it was the guilt of killing babies that made you add today information in a 2 days ago closed thread.

So? Point the OP go to the addon devs support no to a closed thread of another banned addon!!!

Is not off topic if it makes you to add support to unsupported threads. You can ask well for logs and you can derive to 3rd parties as usual, but you cannot point to wrong threads, there’s no rule allowing that as correct response in any entire interwebs forum rules.
And please, don’t make any more assumptions specially about my personal feeilings: My feelings are ok, I’m not related neither any user on the threads, just gave an opinion of your proceedings on this. You’re trying to label me as a forum troll not attending a genuine advice of little improvement based on a mistake&wrong assumptions of yours.


Ok, then why should I point OP at forum rules that haven’t be broken in this thread?

I mentioned that OP should probably contact the addon dev, yes. But certainly, you yourself could have done that.

It’s a bit tedious to be asking for logs for 7/10 new threads here. That’s why when every OP makes his first thread with a new account, our fabulous forum software here, throws up a big yellow box that prompts them to read the “How To Submit A Useful Support Request Link”. Even you saw it when you made your first post here on March 18, 2015. That informative thread is also a sticky at the top of this Help and Support forum. We have done our due diligence to make this info available here. Guess how many man hours were committed to doing all this. Guess how much the volunteers who built it were paid.

I typically pass by posts where OP has obviously ignored our easily available, clearly written advice that has been provided to them in obvious places and virtually been offered to them on a platter, they simply must take a little time. If their time is worth so much that they can’t be bothered with such trivialities, why is not mine?

But you are a smart guy, Android developer and all. Surely you could have offered any of the same simple suggestions to OP that I did, but that didn’t make the pain in your posterior subside since you continue to complain on OPs behalf on how he should obviously be entitled to ignore all easily available information for helping himself and I should have polished my silver spoon to feed him with. Please, go have a cool refreshing adult beverage and relax a little.

Wow did this discussion get off in the weeds…

I also use Trakt tv addon. While I’ve not got the most recent version of OSMC running, in the past I’ve had a few issues with Trakt. After the last update, I too thought it wasn’t working. The video would end and the ratings dialogue would not pop up. Or so I thought. Turns out it was just very very slow. Once your movie ends, don’t touch the remote and give it a good minute or two. The dialogue may then appear.
A few other things to check…
Make sure the add-on is up to date
Make sure it really does sync.

Also, I’m not sure how the pin activation works, if you switch back and forth between cards.

Thx for the help. I don’t know what I have changed, but I enabled Debugging to get the logs and rebooted my RPi and afterwards, the problem was gone. I really don’t know what went wrong, but I already rebooted like 10 times without any success and now I enabled debug logs, rebooted and everything works.

And next time I promise to be more precise and provide logs right of the start when I open a new thread.

If you turn debugging off, does the problem return?
(might want to take an image backup before trying this)

No, doesn’t come back when I turn debugging off. Tried to test and reproduce the behaviour with another OSMC install, but couldn’t reproduce it.