TVHeadend (OSMC App Store version)

My bad, i meant “deb http://apt.tvheadend.org/stable wheezy main” That was all i added to my source list and you wouldnt need to add your network as its all updated automatically. Just by the way are you able to get HD channels

Which version is it ?

I would recommend just to use OSMC version that’s the version we support here…

But if all fails, and tvheadend is not working, try to start over like so via ssh

rm -R /home/osmc/.hts

reboot

Hi guys,
I’ve reinstalled the latest version from the App Store today for use with a HDHomerun Dual network tuner.
The TVHeadend doesn’t come up under configuration -> DVB inputs -> TV Adapters as the guides suggest.

Do I need to tell TVHeadend the IP address of the HDHomerun? I can’t see where to add it.

Cheers,
Alan

it may be worth noting that I haven’t installed dvbhdhomerun as I have read this is already installed into OSMC. is this correct?

cheers

as it is now, you will have to follow the guide that i wrote here about dvbhdhomerun: Here

for hdhomerun you need dvb-hdhomerun software "wrapper".

cd /usr/src

ln -s /usr/include/libhdhomerun/ /usr/lib/libhdhomerun

wget http://downloads.sourceforge.net/project/dvbhdhomerun/dvbhdhomerun_0.0.15.tar.gz

tar zxvf dvbhdhomerun_0.0.15.tar.gz

cd /usr/src/dvbhdhomerun-0.0.15/userhdhomerun
make
make install
run like this 
/usr/local/bin/userhdhomerun -u osmc -g video -f

an actual userhdhomerun package is coming, an easier way…

only the kernel module is in OSMC…

awesome, thanks Harry,
I’ll give that a shot tonight.

I’ve just put a fresh OSMC image on the RPi and installed the TVHeadend Server.
Using SSH, I’ve a followed what you’ve written (but added sudo -s at the start), but have the following issues.

When I type “make”, I get “bash: make: command not found”
When I type “make install”, I get “bash: make: command not found”
when I type “/usr/local/bin/userhdhomerun -u osmc -g video -f” I get “bash: /usr/local/bin/userhdhomerun: No such file or directory”

I’m not what you’d say experienced with Linux at all, so I’m probably stuffing something up.

After doing this, I’ve tried the whole guide on the link. Similar issues there.
do I need to reinstall the SD card, then install the App Store version again, and follow the whole guide, or just the exert you’ve pasted?

thanks

I’ve just followed the guide on your link, and when I get ./configure for the TVHeadend it comes up with this.

root@osmc:/usr/src# cd tvheadend
root@osmc:/usr/src/tvheadend# ./configure
Checking support/features
  checking for cc execinfo.h ...                    ok
  checking for cc -mmmx ...                         fail
  checking for cc -msse2 ...                        fail
  checking for cc -Wunused-result ...               ok
  checking for cc getloadavg ...                    ok
  checking for cc atomic64 ...                      ok
  checking for cc lockowner ...                     ok
  checking for cc qsort_r ...                       ok
  checking for cc stime ...                         ok
  checking for cc recvmmsg ...                      ok
  checking for cc sendmmsg ...                      ok
  checking for cc libiconv ...                      fail
  checking for cc libdvben50221 ...                 fail
  checking for py module gzip ...                   ok
  checking for xgettext ...                         fail
ERROR: WARN: no gettext binaries found
root@osmc:/usr/src/tvheadend# make
Makefile:23: .config.mk: No such file or directory
Makefile:559: /support/.mk: No such file or directory
make: *** No rule to make target '/support/.mk'.  Stop.

in the link there is some packages there is needed.

apt-get install git build-essential pkg-config libssl-dev dvb-firmware-osmc dvb-tools libdvbv5-0 liburiparser-dev liburiparser1 libavahi-client-dev zlib1g-dev libavcodec-dev libavutil-dev libavformat-dev libswscale-dev libhdhomerun-dev libhdhomerun1 hdhomerun-config cmake

now you can compile :wink:

Hi there,

I’m new to OSMC and Live TV so it might be I’m a bit dizzy but as I read it: “Tvheadend is a TV streaming server” and HDhomerun does just the same.
So why oh why do i need both of them?

I installed TVHeadend from the OSMC App Store an it worked so far as it found channels which i could map etc.
So when i access tvheadend from my windows Laptop by :9981 and click an “Play”

(Stole the Image from this How To [Obsolete] Instructions for Viewing Live TV by EMJB)
I get a m3U File which makes Windows Media Player showing me the Stream.

But when i try to Play Live TV in OSMC it says: “No Input Detected”.

What am i getting wrong?

Thanks a lot in advance.


Der Deifi

hdhomerun is just a tuner, but it’s a network tuner so you don’t need it ;-), only tvheadend.

try testing with kodi or this

Hi Harry,

thanks for clarifying.
Meanwhile i managed to get it working in that way as i got Audio but no Video Output.
Surfing the Web for hours i found out that i need the MPEG2-Codec Lizenz for my Pi2 because SD DVB-T in Germany still uses it gnarf.
So i bought one et voilà: i can watch TV via OSMC.

Hi there!
Yesterday i decided to leave openelec and install osmc, but tvheadend 4.0.5 from the osmc app store doesn’t recognize any of my tv adapters (usb tuners) that previously works fine in my openelec-tvheadend. No tv adapters showed in the tvheadend web configuration. These are an avermedia a867r and elgato eyetv. Any idea?

Can you please run

lsusb

and paste the output here…

https://discourse.osmc.tv/t/how-to-obtain-provide-necessary-info-for-a-useful-support-request-includes-current-versions/5507

Hi @deifi, this might be coming really late. Most likely the reason for the “No Input” error is because you have not enabled tvheadend client, which i presume in your case is the same as the pi used as the server. You need to enable the tvheadend client, add the ip add of the server and some other basic setting, after which you just need to reboot. if this is not too clear you can google “setting up tvheadend client for raspberry”.

It is possible to install OSCam in osmc

Yes – but we don’t distribute it currently.
Sam

I would like to install to connect with tvheadend

Install as you would on debian linux.

1 Like