Unable to backup Vero 4k settings 'backup failed to copy the tar file'


Related to my earlier post regarding YouTube no longer allowing fast forward / skip etc, I decided to backup the system before checking for updates (as the check repeats entirely even after update files have been download if you abort to do something, such as take a backup)


I have a 32GB flash usb attached. Playback of contents is fine, and there’s 5GB free. I’m not backing up the Thumbnails folder, and don’t scan databases anyway - just direct playback of files from external storage by filename)

Each attempt at creating a backup results in:

‘backup failed to copy the tar file’

Topics on this error seem focused on Raspberry Pi osmc installations, and are relatively old (2015 for many).

Thanks for any help,

Could you post logs? They will probably show where the problem is.

1 Like

Hi @bmillham,

I’ll post logs as soon as I have a moment,

Thanks for responding, it’s much appreciated,


What you could do for now is stop Kodi and copy over the .kodi directory


Thanks @sam_nazarko, I’ll do that, after grabbing some logs.

Cheers, RR

Did you get any resolution for this? I see that was well on Vero 4k after the latest update. Odd thing is that I can start it manually and it runs just fine. It appears only to happen during the nightly backup.

Should I turn on debug logging last thing before I go to bed? I looked at the regular log, but there was nothing out of the prdinary there.

This thread is over two years old.

There is an issue in the current My OSMC utility, but this has already been fixed and is in the staging repository.


OK. Yes. I know that the thread is old, but it is not always clear whether to continue an existing thread or post a new one. Anyway, I interpret your answer that you have identified the cause and that it will be fixed in the next update?


1 Like

This month?

I suspect so. You can already grab the fix via staging repo.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv buster-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

1 Like


Made no difference though.

The mirrors are currently not updating therefore you most likely have not received the fixed version.

Any word on when that might get fixed?

It’s already fixed.


So I should repeat the process?



Appears to work now.

1 Like