Unresponsive Vero 2 after v17 and recent updates

Hit approve on all updates this a.m., and after the “please wait” dialog my osmc screen goes blank.

Went ahead and copied my ~/.kodi somewhere else as suggested, and still no luck


First time I’ve had to use the forum, so everything has been great. Let me know what I can try next.

Did you reboot yet?

Sure did. Maybe twice before moving the ~/.kodi folder. Twice after. _mobile

Strange. You might need to perform a reinstall if you can no longer ssh or access the command line

I can ssh in. Thats how i ran the recommended steps and pulled the logs. Let me look for reinstall instructions.

Okay – I misread. I thought Vero was hanging on Please Wait.

Your setup can be salvaged. Try Kodi Krypton FAQ and Support

Thanks …ive tried those steps. Downgrade next?

It’s not easy to downgrade to v16 so we have excluded it as something we can support.

Which steps did you try, I suspect moving ~/.kodi away will at least get you something on your display, did you try this?

Yes I read the forum first. SSH’d in and ran the commands listed to recreate the ~/.kodi directory. Had no special skins, early release or that many addons.

OK – without any logs or anything, I can only speculate.

Happy to help, but depending on how much you would lose, a reinstall may be the easiest option. Info on how to perform a reinstall can be found at Reinstalling OSMC - Vero (late 2015) - OSMC

There is a pastebin link in the firat post?


Sorry – I wasn’t specific enough. As it’s not a debug log it’s hard to see what’s going on.


Ah. Ok. Will try to reinstall soon

I just pull the recent debian version?

Select the operating system that you will use to write the new Vero image to the SDCard.

I have a vero

You go to Download - OSMC and download an installer for the PC which you use to write the image to the SD card. A recovery from within the Vero is not possible (unless you use specific command line tools).
When running the installer you choose Vero2 as the target device.

How much space do I need on the SD card? Wouldnt mind knowing the CLI method as well. Last question and I’ll stop bugging everyone, but I can’t use USB for a reinstall?

The SD card will be completely erased so you don’t want to have any important data on it. And minimum should be 512M.