Upgrade Failed

Hi

I’m using the latest 20151218 (or whatever it is) image on my SSD. All is well.

I saw a prompt this morning saying there was an update for OSMC available. I installed it.

Updates were downloaded and unpacked and the install routine began (the blue screen with the progress bar).

At the end, I received an error and now I get the sad emoticon on my screen.

I didn’t not down the error number and I need help to find out where to SSH into to extract logs.

Happy to reinstall OSMC (takes only a few mins), so this isn’t an issue for me - but I thought it would be helpful to point this out anyway.

Cheers

Can you upload a debug log?

There was a library mismatch earlier due to changes in Debian 8.3, but this has since been remedied.

Sam

Hi Sam,

Thanks for the reply.

How do I get access to the debug log?

I tried to SSH just now and got a time-out error.

Thanks

Have you been able to ssh into the device before?
Is the device still visible on the network (pingable)?

Check out
Details how to access OSMC via command line locally or via ssh can be found here: https://osmc.tv/wiki/general/accessing-the-command-line/

I also have experienced this issue. After an update prompt it restarted and stated that the update failed. After that I get a frown face display and it tries to restart and loops into the frown face display. I think I should reinstall from scratch.

Re-installing won’t help, as you’ll upgrade and experience this issue again.

Instead, a log will be useful.

Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/.

Should have read your message sooner. I did reinstall and got the same frown face display upon rebooting via HDD.

Will try and send a log file within the day. Need to leave for work.

Thanks Sam.

Same issue. I was able to get logs, not sure which would be useful, so I just grabbed all logs. They’re at http://paste.osmc.io/eruwelatoy

I could not move movies over to the OSMC drive with my finder so I tried the upgrade hoping it would fix the issue…and broke my install. I am getting the same frown. So I just read here that I cannot just re-install, that sucks. I have no idea how to get logs, I was just keeping my head above water. (I am just too old to be a geek anymore)

Looks like a mismatch between the API for the NVIDIA driver and Kernel. I’m just looking at the logs and that’s what I see for an error.

I’ve got same issue Xorg log
http://paste.osmc.io/janoyogebu.vhdl
dpkg.log
http://paste.osmc.io/dujoliwuye.css

Same Here, I installed it to the hard drive then updated it, and after reboot nothing but a sad face.
As others have said a reinstall does not work, so I installed OpenElec for the apple tv to override this and that booted, so tomorrow I will try and reinstall OSMC back over OpenElec.
Hope this gets sorted out :slight_smile:

To reinstall, just install the USB version.

Once you’re running off the USB version:

  1. Use SFTP to copy the .img file from the HDD image to /home/osmc/
    (get the HDD image from the Downloads page and extract, and you will have the .img file)

  2. Use SSH to DD the .img file to the HDD
    (sudo dd if=OSMC_TGT_appletv_COMPLETE_CORRECT_IMAGE_NAME_HERE.img of=/dev/sda bs=4M)

Once you have got the USB version up and running and have downloaded that HDD image, the rest takes about 50-60 seconds to complete. Very simple :slightly_smiling:

I don’t recommend this, and it’s not needed for an HDD Install at all.

Sam

1 Like

This issue was fixed several hours ago. The issue I’m seeing in logs is that boot isn’t writable, so the kernel upgrade is failing. So the kernel module mismatches the userland libs, but only as a result of the kernel upgrade not succeeding.

This can happen if you shut down your Apple TV abruptly. Running the following commands via SSH may help:

sudo -s
umount /boot
fsck.hfsplus /dev/sda1  (or /dev/sdb1 if you are on a USB install)
mount /boot
apt-get -f install

If you have any further issue, please copy the output in this thread.

In future, please be very judicious in how you power cycle your Apple TV. The HFS+ filesystem is very vulnerable to reverting to RO under Linux. I made some changes regarding this today, but we won’t see these benefits until a future update.

Sam

Agreed, Just reinstall with usual method (installer set to HDD) and turn off auto updates for the time being.

That’ll work – but it certainly won’t fix any issues in the long term. Check my post above for a solution, and help your fellow users :slightly_smiling:

Sam

Thanks @sam_nazarko and @skybehind, good advice

Sam, can I ask why the DD image method isn’t advisable?

You’re the guru - but I’m just curious, from a layperson’s perspective!

Because in our HDD Installer, we can distinguish a USB and HDD install and can make performance tweaks accordingly.

Eventually, there will be no difference as we will determine these tunables at run time rather than install time.

I also make this suggestion for simplicity.

Sam

A post was split to a new topic: CPU hits 100% on HD HomeRun Content while not happening with OE?