USB TV Tuner not working

I just installed the 2021.08-1 update and cannot get my USB TV Tuner working. It was working before the update.

First, logs: https://paste.osmc.tv/nepegatufu

I have 3 devices to troubleshoot with: 2 Hauppauge WinTV-HVR-950Q & 1 Hauppauge WinTV-dualHD

All 3 seem to be having the same error: dmesg is reporting after plugging in that it is an “Unsupported device”. I have never been able to get the dualHD to work with Vero 4k+ (was trying now because I was hoping there would be support with the new kernel), but the HVR-950Q was working with TVHeadEnd before the update.

I have tried plugging all 3 in (one at a time) direct to the Vero 4k+, also tried plugging them into the powered OSMC USB hub; getting “Unsupported device” every time. The firmware appears to be in /lib/firmware. w_scan -c US says “NO USEABLE TERRCABLE_ATSC CARD FOUND”

Most of the troubleshooting in this post I’ve gleaned from other posts here regarding WinTV tuners, I’m no expert and I welcome any further recommendations for testing.

The new kernel is a 4.9 based kernel. Your devices may not have upstream support in this version.

If we are able, I could try and backport support, but I don’t have this tuner myself, so it could be tricky.

Thanks for the reply. The WinTV-dualHD probably does not have upstream support, looks like that full support was added in 4.17. But the HVR-950Q has been supported since 2.6.26, and worked great before the 2021.08-1 upgrade. Forgive my lack of knowledge here, but why would support for the 950Q be lost in this upgrade when it was supported before? Whatever the reason, would it be trivial to add support back to the current version since it was supported before, or does all the work have to be done over again on a new kernel?

I would be willing to test a build if you think that would be helpful. I could also donate a WinTV-HVR-950Q to you/your team if you have time to work on it. I’ve seen in another thread that you referenced this guide “How to Obtain, Build, and Install V4L-DVB Device Drivers”, is that relevant to my issues?

Kernel modul for the HVR950Q seems to be included

osmc@osmc-vero4k:~$ cat /boot/config-4.9.113-45-osmc | grep -i xc5
CONFIG_MEDIA_TUNER_XC5000=m

Have checked if you installed the firmware as described?
https://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-950Q

While it seems even not trying to load the firmware

Aug 11 19:24:53 3jane kernel: usb 1-1.4: New USB device found, idVendor=2040, idProduct=7200
Aug 11 19:24:53 3jane kernel: usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=10
Aug 11 19:24:53 3jane kernel: usb 1-1.4: Product: WinTV HVR-950
Aug 11 19:24:53 3jane kernel: usb 1-1.4: Manufacturer: Hauppauge
Aug 11 19:24:53 3jane kernel: usb 1-1.4: SerialNumber: 4035209770
Aug 11 19:24:53 3jane kernel: usb 1-1.4: Unsupported device
Aug 11 19:24:53 3jane kernel: usb 1-1.4: Unsupported device
Aug 11 19:24:53 3jane kernel: usb 1-1.4: Unsupported device
Aug 11 19:24:53 3jane kernel: usb 1-1.4: Unsupported device

I did not install the firmware, but it already exists in /lib/firmware/dvb-fe-xc5000-1.6.114.fw so I think it is included with OSMC.

But you are right, it does not seem to load the firmware even though it exists. The linuxtv page says the firmware will be “added lazily (on-demand) when you first use the driver”, which I’m guessing would be when the device is plugged in. Is there a way to try to manually force the driver or firmware to load?

you could try modprobe <drivername>

sudo modprobe -v xc5000 produced no output, I think this means the xc5000 driver is loaded. sudo modprobe -D xc5000 refers to one file, /lib/modules/4.9.113-45-osmc/kernel/drivers/media/tuners/xc5000.ko, which does exist

lsmod will tell you

Thanks, xc5000 is indeed listed in the lsmod output, but the Used By column lists 0

I tried unplugging and replugging the device and still dmesg reports Unsupported Device

Do we have dmesg from 3.14 and 4.9?

Same problem here. 950Q. A failed upgrade to Debian 11, followed by a fresh install with kernel 5.10.0-8, and now xc5000 no longer loads. I can modprobe xc5000 and it loads (lsmod lists it) but the tuner stays quiet. xc5000 used to load a dependency but it is nowhere to be found now, and modinfo indicates no dependencies needed now.

dmesg is completely quiet about it. The device isn’t recognized, although dmesg will show the cable as being unplugged when I do so. I verified that the USB ports and tuner still work. I don’t know if it’s related, but the Dolphin file browser is very, very slow to start. dbus issues?

We don’t support Debian 11, nor is a 5.x kernel supported on Vero.

1 Like

I am having the same problem described by a couple people above. 950Q was working. I upgraded to the latest version. Now the tuner is not recognized. The same results on dmesg given above. lsmod shows that the firmware is not automatically loaded. when I modprobe it, it then appears in lsmod, but seems to not be used by anything, as commented above. I didn’t see any solutions. If someone solved this problem, could you post your solution?

just in case it is useful, I’ve attached a portion of dmesg. I included extra lines before and after the key lines, just to ensure I include everything useful from dmesg:
3.196274] input: OSMC Remote Controller USB Keyboard Mouse as /devices/platform/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-2/1-2:1.0/0003:2017:1688.0001/input/input3
[ 3.264051] hid-generic 0003:2017:1688.0001: input,hidraw0: USB HID v1.10 Keyboard [OSMC Remote Controller USB Keyboard Mouse] on usb-xhci-hcd.0.auto-2/input0
[ 3.273104] input: OSMC Remote Controller USB Keyboard Mouse as /devices/platform/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-2/1-2:1.1/0003:2017:1688.0002/input/input4
[ 3.273520] usb 1-1.2: new high-speed USB device number 4 using xhci-hcd
[ 3.333894] hid-generic 0003:2017:1688.0002: input,hidraw1: USB HID v1.10 Mouse [OSMC Remote Controller USB Keyboard Mouse] on usb-xhci-hcd.0.auto-2/input1
[ 3.428806] usb 1-1.2: New USB device found, idVendor=2040, idProduct=7200
[ 3.428814] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=10
[ 3.428818] usb 1-1.2: Product: WinTV HVR-950
[ 3.428821] usb 1-1.2: Manufacturer: Hauppauge
[ 3.428825] usb 1-1.2: SerialNumber: 4036068402&40
[ 3.460980] usb 1-1.2: Unsupported device
[ 3.461167] usb 1-1.2: Unsupported device
[ 3.461237] usb 1-1.2: Unsupported device
[ 3.461347] usb 1-1.2: Unsupported device
[ 3.610528] cgroup: cgroup2: unknown option “nsdelegate”
[ 3.618597] systemd[1]: systemd 241 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[ 3.619120] systemd[1]: Detected architecture arm64.
[ 3.625094] systemd[1]: Set hostname to .
[ 3.679798] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 115200 to 115200
[ 3.775804] systemd[1]: File /lib/systemd/system/systemd-journald.service:12 configures an IP firewall (IPAddressDeny=any), but the local system does not support BPF/cgroup based firewalling.
[ 3.775817] systemd[1]: Proceeding WITHOUT firewalling in effect! (This warning is only shown for the first loaded unit using IP firewalling.)
[ 3.882230] random: systemd: uninitialized urandom read (16 bytes read)

Snippets aren’t particularly helpful unfortunately.

Thanks for the very quick reply. I decided to revert to an earlier version of OSMC. FWIW, the tuner is now recognized and everything is back to working. I’ll probably never solve this particular problem, I guess.

With full logs, and a reference to what an ‘earlier version’ is, I’m sure you will.

Sam

Thanks for the continued attention. The earlier version I have installed is OSMC 2020.10-1. However, I didn’t save the logs from the misbehaving system. That makes it basically impossible for this board to help me, obviously. Thanks anyways!