Various issues with vero 4k+: no HDR, deep colour, frame packed 3D & CEC

Hi Sam,

For now posting all my problems in 1 post, as they might be interlinked. Let me know if I need to split them.

First my setup:

  • Vero 4k+ with Oct 2020 firmware
  • Marantz SR7009 AVR with full Dolby Atmos setup (7.4.4)
  • Epson EH-TW8100 projector (full HD, 3D support, some deep colour support)
  • Refresh rate switch in kodi set to “Always”
  • AVR set to react to CEC signals

What I try to accomplish:

  • Playing of Full HD, frame packed 3D & 4k source material (both SDR & HDR) on the projector
  • Auto switch of my projector to 3D mode (which happens when providing frame packed signal)
  • Full audio passthrough to enjoy Dolby Atmos experience (this actually works)
  • Bonus: AVR volume control through the vero 4k+ remote

What I already tried:

  • Special build for frame packed 3D & normal Oct 2020 build
    → Couldn’t get 3D to work in either
  • Connection through AVR & directly to projector
    → No differences observed for any of the problems
  • Both normal (16-240) & full range (0-255) HDMI range.
    → Projector picks this up correctly, so stuck to full range to minimize banding
  • All types of CEC settings
    → Nothing works, and even the projector sees both the vero4k & AVR…
    → Switching off CEC support in the projector: no difference.
  • I did search the forums for all of the below problems, to no avail.

My problems (both using through AVR & direct to projector):

  • No volume control through CEC (actually the least of my problems :wink: )
  • With the Oct 2020 build I just cannot get my colors and black levels right.
    → 4k HDR is over saturated, unwatchable. Moving to full range makes it slightly better, but still unwatchable
    → (Even) 720p SDR shows gray bars above/below for 2.35:1 content when set to extended HDMI range. Black level inside seems ok.
    → Banding when set to normal HDMI range
    → The special frame-packed version I believe did work with HDR content. (Didn’t go back though because upgrading from that one caused the vero 4k to go into a boot loop and had to fully reinstall)
    → Projector always shows 10 bit deep colour signal, regardless of content played.
  • Frame packed 3D just doesn’t work
    → With either firmware it doesn’t do frame packed 3D, and even if the projector switches to 3D mode it is only showing in 2D.
    → Tried all types of recoding into mkv, m2ts, etc etc.
    → Also tried with injected Atmos track, same problems.

Note that all of the above I did manage to get running through my windows PC running kodi, using the same cables. For that one I just got sick of it always losing the IR remote settings at every windows update and the painful login procedure. Bought the vero 4k+ to have a fairly simple out of the box solution but so far I cannot get it working :(.

My suspicion:

  • It is not picking up the correct colour support, HDMI range & frame packed 3D support.
    – With that wrong, all the conversions go wrong & frame packed 3D is just not passed.
  • The current video decoder is confused? I couldn’t find any settings to tweak though.
    – On the windows version I did install a different video rendering engine to get it all working. (DSPlayer with MadVR I believe)

Below I also included two EDID snapshots made when connected through both the AVR & directly to the projector (funny there is a difference, because it doesn’t behave differently in practice.). This was after a fresh reboot through SSH & while idling in the main menu. The EDID file is from the /sys/class/amhdmitx/amhdmitx0/ directory.

I am fairly familiar with logging in through SSH & getting files in and out through SFTP, so if there is anything you want me to do or upload, please let me know.

Really hope you can help me out in getting this up and running!

EDID with vero 4k+ directly connected to projector:
Rx Brand Name: SEC
Rx Product Name: EPSON
Manufacture Week: 31
Manufacture Year: 2012
Physical size(cm): 160 x 90
EDID Version: 1.3
EDID block number: 0x1
blk0 chksum: 0xbd
Source Physical Address[a.b.c.d]:
YCC support 0x03, VIC (native 16):
ColorDeepSupport 0xb8 10/12/16/Y444 1/1/0/1
16 31 32 5 20 4 19 3 2 18 17 7 6 22 21 1 15 14 30 29
Audio {format, channel, freq, cce}
Speaker Allocation: 0x00
Vendor: 0x000c03
MaxTMDSClock1 225 MHz
RR_Cap: 0
LTE_340M_Scramble: 0
checkvalue: 0xbd5f0000

EDID through AVR: (maybe I did something wrong?)
Rx Brand Name:
Rx Product Name:
Manufacture Week: 0
Manufacture Year: 1990
Physical size(cm): 0 x 0
EDID Version: 0.0
EDID block number: 0x0
blk0 chksum: 0x00
Source Physical Address[a.b.c.d]:
YCC support 0x00, VIC (native 3):
ColorDeepSupport 0x00 10/12/16/Y444 0/0/0/0
3 4 5 16
Audio {format, channel, freq, cce}
Speaker Allocation: 0x00
Vendor: 0x000c03
MaxTMDSClock1 0 MHz
RR_Cap: 0
LTE_340M_Scramble: 0

checkvalue: 0x00000000

Looks like AVR or projector (or both) were on standby at the time.

Can you please post full logs, as the current snippets you’ve put up don’t tell us anything about your device’s 3D capabilities for example.

The logs will let us see:

  • If you’ve configured settings optimally
  • If you’ve installed 3D Frame Packed builds correctly
  • What capabilities your devices are advertising to the Vero

Sure thing! I read somewhere else you should put the debug logs on, and play some content I guess. Be right back…

If you need help with this, here’s a boilerplate guide…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Hey tried the upload functionality but it didn’t work.

Did all kind of things and then it gave back this URL: < html >
Then tried store on SD card, but no file appeared there either.

Finally snatched it from the .kodi directory, but cannot upload it here.

Any ideas?

Note that i did switch on component specific logging on the audio/video/CEC libs, maybe that was overkill? Log file is only 4MB though…

You need to reboot. We only accept logs that are <10MB.

Please follow the instructions for uploading logs (we need all logs – not component specific).


Do not do this. Simply enable debug. Reboot twice to clear old logs and try again.

Rebooted twice as instructed and also switched on the normal logs, but I guess a bit too ambitious with the additional logging. Will try again :slight_smile:

P.S. Thanks for the awesome fast replies btw!

That did the trick:

Played various content 4k hdr, 3d frame packed & old scool 720p. Connected through the AVR.

Note that with the debug logging on it doesn’t look like it is switching refresh rate, which usually takes a long time with my projector.

I will now do the same with the vero connected directly to the projector.

When connected to your AVR, the EDID is not being parsed at all.
There is a known issue affecting a few devices from getting a good EDID read using the 4.9 kernel. The 3.14 (stable) kernel is not affected. On 4.9, we fixed most of them, but a couple remain. I’m still looking in to the issue.

I’d suggest trying with a direct connection to the projector.
When you do this, be sure to reboot the system after changing the HDMI so there is full propagation of the EDID changes to userland, kernel and Kodi.

And here is the second log:

This one the vero is connected directly to the projector. First I played the videos on 0-255 range, then switched to 16-240 range. I observe the following:

In general

  • The refresh rate changes from the projector (logging info disappearing for a few seconds)

0-255 mode:

  • 4k hdr: oversaturated
  • 3D frame packed: just playing normal, projector refuses to switch to 3D, indicates it is 2D content
  • 1080p: looks ok I guess
  • 720p: gray bars above & below, but video itself goes to deep black.

16-240 mode;

  • 4k hdr: way oversaturated
  • 3D frame packed: just playing normal, projector refuses to switch to 3D, indicates it is 2D content
  • 1080p: looks great
  • 720p: black bars above & below, and video itself goes to deep black as well

(Uptime = 572.60)

Looks like you didn’t reboot when you changed the HDMI over. Can you try doing so?

Sorry – I’ve just looked at this.

The EDID issue you are experiencing won’t be related to a problem with the 4.9 test builds, because you aren’t running them.

You don’t have the 3D build installed either, which is why this isn’t working.
There are improvements to 4K HDR in the 4.9 build.

I would suggest installing the 4.9 build. See [TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +. Until you do this, 3D MVC will never work.

A report back after doing this with a list of issues will then be useful.

Will do, I remember updating to 4.9 before, but I now realize that was probably cleared when I had to reinstall from scratch. Be right back :slight_smile:

Here is the log after the 4.9 kernel upgrade:, vero 4k+ directly connected to the projector.

Let’s start with the good news, projector switches over on 3D frame packed content! Awesome!
Another time I will check if Atmos also still comes through, but this is already very promising.

What actually got worse is full HDMI range (0-255). While the main menu looks great, during video playback it goes wrong. On all content formats (720p-4k hdr) the blacks are now gray and washed out, whites lackluster. It seems the video decoder simply ignores this setting now, yet my projector picks up the wider range.

On normal range (16-240) the 720p & 1080p look great, but HDR content is still not good and lacks brightness. Colors seem a bit better but not great and still too saturated. Worst offender is Lego batman, which is extremely saturated. What I also notice is that the whole menu system, subtitles & log messages are gray while playing video, instead of white in the main menu system. Text is also white during 1080p/720p content.

Hopefully the logs show something and let me know if there is something you want me to try. I will go to bed now though, since it is 4am over here… :yawning_face:

Thanks for the help so far & to be continued :slight_smile:

P.S. The uptime is long because I tried various files and hdmi range settings in one go.


Not had a chance to look at the logs fully yet. It is also late here.

Do you have another display to test with (that supports HDR) where you could see if colours look more sane on that?

Keep in mind that your Epson projector supports HDMI1.3 and it’s not advertising support for HDR. You will only be able to get HDR tonemapped to SDR on this device., unless this EDID reading is wrong and you are using a much newer projector.


Edited below after looking at some more content.

Hi Sam,

No worries, no hurries :wink:

You are correct, it is indeed an SDR projector, but seems to have some kind of deep color support (either 10 or 12 bit I believe), which should at least help in reducing banding.

For HDR content, tonemapping is indeed what I expect to happen. Not sure what type of mapping is used? Colors still seem a bit over saturated to me, but are already way better than in the previous version, where you could see red/green colors in people’s faces, that is mostly gone now.

Also banding is greatly reduced, e.g. on the Disney logo, and is barely visible now.

Initially I thought HDR didn’t have brightness, but that was incorrect, it is there for sure. It is very content dependent and I was misinterpreting some things on the screen. Some of the log text brightness decrease was actually because the auto-iris of the projector was cutting down overall brightness for dark scenes, which usually you don’t notice. Now it just became obvious because of the debug text changing in brightness.

Note that for very bright content (e.g. Sing) I did notice the subtitles etc getting dark gray, but I guess that is a feature and not a defect?

The 0-255 handling seems like a clear bug though somewhere, especially since it clearly changed between the two versions. Hopefully an easy fix.

Good night & I will dig deeper tomorrow if I can find the time :slight_smile:


Interesting that you report you didn’t have the issue with older 3D builds.

Older builds were based on the 3.14 kernel. We haven’t changed how we handle HDR to SDR processing in 3.14. So if it worked before on that kernel I’m sure we can get it working well again.

4.9 is still a work in progress. Ideally that’s where we want to fix things for you.

Thanks for the detailed reports. It might be helpful to set out what should happen.

  • There should be no advantage/disadvantage in using full-range quantisation if your display supports both but limited is best. For HDR, full-range is forbidden anyway. Many displays don’t support full-range except when fed a RGB signal so you would get distortions if you try to send YCC full-range to them. I think there are bugs with full-range in the latest 4.9 release which we’re looking into but AFAIK limited range works correctly on all SD, HD and UHD material so please stick to that.
  • As you say, deep colour does not mean HDR. For HDR there is a different colourspace and transfer characteristic. If your beamer (or AVR if it’s between Vero and beamer) doesn’t advertise HDR/UHD support we convert HDR to SDR. We are working on adding some user settings to adjust the curves used to support different screen brightnesses.
  • On-screen text like Kodi’s debug stuff top left and subtitles confuse the automatic smarts of a display so when a subtitle comes up, an lcd display (for example) thinks the scene is brighter and can turn up the backlight. Your auto-iris must do something similar. This is annoying but not much we can do about it, except to remove the Kodi debug display, you can put this in ~/.kodi/userdata/advancedsettings.xml:

This sets debug logging on permanently which shouldn’t affect normal use. But best to remove that after any issues are resolved.

3-D and CEC aren’t my department.

Hi Sam & Graham,

Thanks for the info! Much appreciated and another step closer :slight_smile:

I finally had time to do some more testing, this time through my AVR. Some findings:

  • It could not find the right resolution, and dropped back to 1280x720 max.
    • I did have a copy of the disp_cap, so copied that one as per this thread:
      Any way to persist HDMI edid data?
      With this I could switch to 1920x1080.
    • Note that before (older build), I did not have this problem. Maybe something changed in the EDID handshake towards the AVR?
  • Color on 4k HDR still seems off to me, maybe a wrong color space with different primaries? It feels a bit like PAL signal on NTSC color space if you know what I mean.
  • 3D playback is broken with the above disp_cap tweak. The projector does switch to 3D mode, but it shows me 2 halves on top of each other, with the bottom of each half corrupted. A bit like an half-OU video, but then with the bottom parts corrupted for each of the halves.
  • Finally I tried force RGB, but this did not make any difference in color rendering. (Note I stayed on 16-240 limited range all the time as recommended above). This indicates to me it is on the HDR->SDR conversion side, and not related to YCbCr vs YUV or something.
  • CEC seems to work top-down if you know what I mean. So with my projector remote I can actually control both my amplifier volume and the vero 4k menu. The other way around does not work, the vero volume control just changes the volume inside osmc.

This leaves me with the following questions:

  • Any more info on the HDR->SDR tone mapping?
    • Could it be that my SDR deep color does something funky with the colourspace?
    • The fact that my menus & subtitles become gray, is that supposed to happen?
  • Any idea on why the EDID comes back empty through the AVR?
    • As a workaround, is there any more in-depth way to just use the EDID from the projector so that it also works with frame packed 3D?
  • Any ideas on the CEC volume bottom up?
  • And last but not least, anything you want me to specifically test / log / etc?
    • For example, is there a good test set in 1080p, 4k SDR, 4k HDR 10bit, 12bit, etc that I can compare? I saw different resolutions of big buck bunny, but no mention of SDR/HDR or bit depths.