Vero 2 stuck at "please stand by." after update

I just recently purchased my Vero 2. I got it up and running as well as enabled the Transmission add-on and TVHeader from the AppStore. I also installed Sickrage via this walkthrough. All was working fine until I updated the system. It told me that Kodi would have to shut down to install the updates and I allowed it. The download and install of the update completed successfully at which point the system shut down. I unplugged it and plugged it back in to start up the Vero 2 and it came up with the “Please stand by” screen, but it won’t complete the boot process.

I have the OSMC remote, ethernet chord, wireless keyboard, and USB external drive plugged in as well as the HDMI cable. I tried unplugging eveything except the power cable, but it still doesn’t complete the boot proccess. I tried to ssh into the system to see what is happening and it just returns with a “no route to device” error.

Is there a way that I can restore my Vero 2 to factory settings? It is still using the preinstalled OSMC that came on the internal storage. I know how to flash an SD card with n00bs (which I used to use for my raspberry pi), but I can’t figure out how to access the native storage to assess the situation. Also, if I put an SD card in the system with n00bs on it, the system doesn’t do anything different at start up than has been previously mentioned.

Any help would be appreciated.

You can flash the latest version of OSMC from osmc.tv/download on to an SD card. OSMC will then partition the native storage and restore everything.

It’s possible that tutorial has made some unexpected changes. It seems to be a little bit old. If you follow it again, and still have problems, then you’ll likely know what the culprit is.

Do I have to use a certain type of SD card? Should the card be inserted into the Vero 2 before powering it on or after? I have tried both and 3 different cards (mind you, they are older cards) but nothing seems to happen

Did you install using the official OSMC installer from osmc.tv/download?

Did you definitely select the ‘Vero 2 image’

An SDHC card should be fine. Make sure it’s put in the SD slot which is the top opening on the side.

These sound like obvious points but just covering the basics. If this doesn’t work – no problem. First step would be to check that the SD card is being read.

  • Add a random file called ‘blah.zip’ (must have ZIP extension), can be an empty file
  • Find a non-conductive pin
  • Hold it in as Vero 2 is booting
  • Wait until you see a picture of an Android
  • Go to Apply update from EXT
  • Choose SD card
  • Do you see ‘blah.zip’?

Before powering it on, so the installer can be read and loaded in to RAM.

Sam

I flashed the card with Vero 2 (2016.05-1 079ec7c3e09fb235350ecd376bed55d9) from osmc.tv/download

You say the SD slot is the “top” slot. The SD Card I am using only fits in the “bottom” slot of the two that are beside the USB ports.

What is a non-conductive pin? If I need to do this, I don’t understand these instructions.

I’m pretty sure it should reboot on its own. You may have interrupted the update process by unplugging it.

Bottom port indeed. I was meaning to say not the top port.

A non conductive pin, i.e. not metal, could be a toothpick. There is a switch inside the audio port nearest the HDMI. You can click this with a thin, non-conductive pin.

You should do this while booting and you will get a Recovery screen. Then you can verify if the SD card is being read by following the steps above.

Sounds like the kernel is not being loaded if that’s all that is on the screen. It can get corrupted if power is lost during the update process.

Sam

I tried hold pushing the button with a toothpick and holding it in place while plugging in the Vero 2. It still comes up with the same. “Please stand by” screen. I help the pin down for over a minute without any change. (I did hear and feel that the button was being pushed, so I know I am doing that part right.) I tried this with both the SD card in and out. No change.

Okay, this is quite odd. Here’s something you can try

  • Put the SD card in a computer
  • Rename ‘kernel.img’, to ‘recovery.img’.
  • Put SD card back in

Even without holding a toothpick in, if the card is correctly formatted, and the bootloader can’t load the kernel on the internal storage, it should load this kernel as an emergency. You can also try holding the toothpick in to force it to load from the external storage immediately.

Sam

1 Like

This seemed to fix the problem. Is the system now installed on the SD Card or is it on the internal HD? Can I remove the SD card, and if so how and when can I do that safely?

Power off the device by selecting the shut down option

Remove SD

Should be good thereafter

The system doesn’t shut down after installing updates, it either just relaunches Kodi, or if certain updates were installed such as a kernel it automatically reboots, although the screen may remain blank a few seconds before it reboots.

It sounds like you may have actually unplugged the power while it was still in the middle of shutting down before rebooting, which may have lead to file system corruption that caused the problem.

It’s important not to pull out the power during the update process so next time if nothing seems to be happening give it a few more minutes just to make sure and pull the power out as a last resort.

I tried rebooting the device, taking the card out and booting it up again, but the system would not boot.

The readout I get is:
Looking for root file system device /dev/vero-nand/root
FATAL ERROR: could not find root file system device /dev/vero-nand/root - if this is a USB install please check the USB drive is connected.

Osmc intramuscular Rescue Console.
For help and support see http://osmc.tv/help

I tried reinstalling the whole system via the SD card and did not remove the card on reboot, but it still comes up with the same error on any subsequent boot attempts. I have tried this with a fresh install as well as with some addons activated, and it doesn’t seem to make a difference.

For now, I have disabled updates so that system never tries to reboot, but it I ever want to turn the system off, I basically have to restart from scratch.

Is there a way to use the rescue console that comes up to find the file system properly and get it to boot normally?

Does a reinstallation work? What do you see on your screen?

What is attached to the Vero? Are you using the officially supplied equipment (charger etc)?

Sam

A reinstall works until I reboot the device. I am using all the official hardware. The only thing that is plugged in other than that is my usb external Hard drive. I have also tried booting with the harddrive unplugged. Makes no difference. Everything I reinstall I use the guidelines above. I put the kernel.img file on the SD card, rename it to recovery, and boot while pushing the pin in with a toothpick. I can’t get it to properly recognize the SD card and reinstall unless I do all of these.

Okay. Leave the external disk unplugged for a couple of days.

Does the installer actually show up when you rename kernel.img?

Sam

Yes, it goes through the whole installation process without any problems. I just can’t shut down the device after a fresh install or it will give me the above error

That is really weird.

Just to clarify, do these steps cause an issue:

  • Power on Vero with recovery SD card
  • Set up OSMC in the tutorial (Language, WiFi etc etc)
  • Do nothing else. Go to shutdown.
  • Power off after 30 seconds (unplug)
  • Plug it back in

If this is causing an issue, this is strange. Happy to look into this in more detail for you.

Sam

I tried a fresh reset just now. I have always done an initial update before trying to reboot in my previous attempts. This time I just went through the initial set-up (picking the language, agreeing to terms of service etc.) and got to the main menu. I selected “Power off device” and it hangs when shutting down. The screen read out is as follows:

Starting LSB: Start MTP daemon…
] Started LSB: Start MTP daemon.
] Reached target Multi-User System.
] Reached target Graphical Interface.
Starting Update UTMP about System Runlevel Changes…
] Started Update UTMP about System Runlevel Changes.

After 10 minutes of waiting, I unplugged the device, waited 30 seconds, and plugged it back in. It booted up just fine.

After this I tried taking the SD card out after unplugging it, and it still booted up fine (also still hangs on shut down.)

After this I did the initial update like I have done in the past by going to My OSMC -> Updates -> Manual Settings -> Search for Updates. After the update is applied and the system automatically restarts, it give the same error as before “could not find root filesystem…” etc. This time, however, the SD card I used to recover the Vero 2 is not in the device. This update seems to be causing the issue.

I will go ahead and reinstall as before, but not do the initial update (as this appears to work from the test that I just did) and I will keep updates off. It is still intriguing, however, that the system still hangs when trying to shutdown without doing this initial update.

1 Like

Which version of OSMC did you download?

Good.

We need to know what version you loaded on the SD. If you install 2016.06-2 (from osmc.tv), you should be up to date already. You will see the OSMC version in the bottom left of My OSMC.

Possibly an older version of OSMC where text stayed on screen post-halt. Not a fault, but not the best way to tell the user it’s safe to pull the plug…

Let me know how you get on

Sam