Vero 4k+ audio pass through

Just received my Vero 4k+ after spending the past few years with kodi on a raspberry Pi 2. The Vero seems excellent by the way!

However I am having a problem with some of the HD audio formats being passed through to my AVR, which I realise may not be a Vero issue, but it did seem to work (to an extent) with my Pi.

I have a Denon AVR X2000 capable of decoding Dolby TrueHD and DTS-HD MA, however as the AVR does not have HDMI 2.0 its lacking in some of the visuals, now as compromise what I have always done is fed my Pi/Vero to the TV to get the best picture possible, enabled audio pass through and had the audio go via ARC to the Denon AVR.

Now when i say this used to work to an extent with the Pi, any files encoded with DTS-HD MA, Dolby TrueHD etc would get passed through to the TV and then essentially stripped down to either DTS or Dolby before being sent to the AVR - I have been told this is due to the limitations of the ARC and is normal behaviour for this TV. While not ideal it was a compromise until I could get an upgraded AVR that supports HDMI 2.0.

However with the Vero in exactly the same set up any files encoded in any HD audio format, no audio is sent to the AVR at all and the AVR displays PL II with no actual audio being output.

I realise this may not be anything vero related but Ive been playing for a good couple of hours now and I may just be missing something obvious, so any suggestions are welcome.

Thanks

Please have a look here and follow this guide which should give you the best settings for your audio setup: Connecting up your equipment for best audio

Can you show us a photo / screenshot of your audio settings as well?

Cheers

Sam

of course

If you’re relying on ARC, then disable TrueHD and DTS-HD capable receiver.
Set number of channels to 2.0

That should do the trick.

1 Like

Thanks for the quick reply, ill give that a go if theres no way of getting it to pass a regular DTS like it was doing before?

Out of pure interest why would you set number of channels to 2, maybe I’m missing something but seems counter-intuitive for a 5.1 system?

If you disable DTS–HD and TrueHD, you will get regular DTS passed through as you had on your other device.

I suspect your TV doesn’t support LPCM5.1. You can try it at 5.1; but if it doesn’t work, set it to 2.0. Your TV will still pass through AC3 and DTS accordingly.

Sam

Just tried it, does work but its not passing through regular DTS, or at least thats not what my AVR is telling me as its coming up with PLII when DTS-HD and TrueHD is disabled, but I am getting sound at least.

Also I tried both 2.0 - worked and 5.1 also worked but dialogue was so low it was inaudible

You need to enable ‘Boost center volume on downmix’ for it to sound normal.

That’s odd. Can you enable debugging under Settings -> Logging?

Play the file again and when you see no DTS light on the AV, go to My OSMC -> Logs and upload all of the logs and give us the URL?

Cheers

Sam

All done
https://paste.osmc.tv/izawukucos

Let’s take a look.

I’m not sure that a lot of TVs accept DTS directly.

If you hadn’t had said you were using it with a previous device I wouldn’t have expected your TV to do so. Can you let me know the make and model of the TV?

From your log I can see that we are sending a DTS (core) signal to your display.

If your AVR supports optical audio, this may be a better option. It’s always best to avoid routing through the TV if possible.

Sam

Another possible solution might be this: Audio playback issues and surround - #14 by JimKnopf
With this solution you may get HD audio to your AVR and 4K to your TV at the same time… It costs around 150 bucks, but you’ll get the best of your Vero, your TV and your AVR without having to upgrade or make compromises.

Maybe some users over in that thread can give you some feedback how they’re doing with that solution.

It seems a steep solution compared to an optical cable which will just be a couple of quid.

Yeah sure its a samsung Q7F, but recently changed from a samsung ks7000, you’ve got me doubting myself as to whether this was on my previous TV now.

I could give the optical a go when i get round to getting a cable, thought about it previously but didn’t see that I would get any additional benefits over the set up I had before

It’s not clear to me if your TV supports this.
For now – you can disable DTS and keep AC3 enabled.

I would recommend using an optical cable which you can get in Currys or Argos quite quickly for a few pounds.

When you get it, connect it to your Vero 4K and disable HDMI audio under Settings -> Display -> Mute HDMI audio (and reboot).

Sam

Thanks I didn’t know this sort of thing existed, although i think for 150 I’d rather put it towards a new AVR that fully supports 4k with HDMI 2.0.
A little annoyed with denon over this anyway as when I originally bought the AVR it was advertised as 4k ready but in practice its far from it

Thanks I’ll give it a go

If you’re thinking about an upgrade anyway, it’s probably best not to invest that much money into such a solution… Absolutely right :+1:t2:

Well, that’s the thing with 4K, I guess. It wasn’t really ready from the manufacturers’ side at the time, but they still advertised what was there. Hoping that my AVR (a Denon AVR-X4300H) will still be supporting all the formats needed when I fully switch to 4K.

@sam_nazarko’s solution is the best then :slightly_smiling_face:

Great — let us know if you need help with anything

Sam

1 Like