Vero 4k+ audio pass through

Thanks for all your help guys, obviously this optical cable business wasn’t what I thought it would be, thats my misunderstanding.

I just wanted my audio from my Vero to pass through to my AVR via ARC, and for DTS-MA and Dolby TrueHD to be passed as regular DTS and Dolby, just like it was with my raspberry pi with kodi, and it was suggested that the optical cable may solve this problem, but i think there may have been some misunderstanding over what I was after in that respect. If people tell me that doing this over ARC is not possible with the vero thats fine (although I’m a little confused as to why) and if its also not possible over optical it looks as if my only option is either a new AVR or one of these HDMI splitter devices people have suggested - not really money I wanted to spend at this stage seeing as though my pre vero raspberry pi did this already without the need for extra equipment.

As stated before thank you all for your time and input, it is appreciated.

With an optical cable, you can send DTS and Dolby Digital to your AVR.
You can also pass through core tracks from DTS-HD and DD+ etc.

oh thats what I was asking before? as its not for me, its either sending no audio, or just regular 2 channel.
I just got a response saying ‘HDMI to go to TV and optical to AVR’ and ‘S/PDIF only supports 2.0 channel PCM’

That’s odd. Maybe your receiver doesn’t support decoding Dolby / DTS etc via optical? I’d be surprised if that was the case.

It does though as when I play a DTS or Dolby track via optical it correctly decodes it, however when I play a DTS-MA or TrueHD it does not send the core tracks

That might be a bug on our side.

Could it be the same bug thats causing this behaviour on ARC as thats behaving in exactly the same manner

Possibly – yes.

ok do you need any more information from me or shall I just leave it with you?

I will see if I can reproduce the problem first.


S/PDIF does indeed only support 2.0 PCM channels (take note of the PCM here! It does not support more than 2.0 channels PCM). It also supports Dolby Digital and DTS which was not debated here. The issue is with audio being sent to a TV via HDMI and the TV passing audio on via ARC/S/PDIF-out… Some TVs will pass on Dolby Digital and DTS as well, some will ONLY pass on 2.0 PCM (which is what seems to be the case with your TV, mine does the same). But most will probably not pass on the DTS core track or the additional Dolby track. This will probably not work in most cases, therefore passthrough of HD audio formats (DTS-HD MA and Dolby TrueHD) has to be disabled.

There’s nothing wrong with the Vero. I’d urge you to read up on those two links I posted earlier… They will explain all of this in more detail and will probably be very helpful for you :+1:t2:

For what it’s worth, I’ve been following this thread since the beginning because I have exactly the same situation with my new Vero, albeit with different equipment. I have a Sony KD-65X8500D and a Yamaha HTR-6063. I also tried the optical suggestion which only resulted in a mixture of silence and PCM 2.0. I’ve got back to ARC as well for now, but TrueHD and DTS-HD MA are still problematic.

The comment earlier in this thread that “S/PDIF only supports 2.0 channel PCM”, along with the advice to set the speaker output to 2.0 also really confused me. Doing that left me with only PCM 2.0 being output by the amp, and to me that seemed perfectly logical, albeit not a proper multi-channel solution. If thats not the expected result, then I’m very relieved.

So I guess this is really only a long-winded +1 post, which is why I didn’t make it earlier. I just wanted to mention that there is more than one person experiencing this issue, and offer any help you need from me in terms of testing and logs.

Thanks for the help.

Please guys… Read the wiki articles I posted before. They do explain all of this in a lot of detail and guide you to the settings you probably should use.

The settings in your case @Arathen and @james.a.milner will probably be these:

@Chillbo has explained to me that you might be trying to use ARC with the optical connection. You should be running the optical cable directly from Vero to your AVR.

Can you clarify how things are connected?



@sam_nazarko @Chillbo Just to get things straight before we all end up going down the wrong track again. My TV does pass on Dolby Digital and DTS, I know this because this is what it has done prior to me getting the vero, therefore why should I be disabling these formats?

As stated previously yes when i tried optical connection it went from Vero straight to AVR

@sam_nazarko @Chillbo other users also say my TV supports this feature, and I have experience of it working so I don’t understand why theres an automatic assumption that my TV doesn’t support it

I had optical going direct from the Vero to the AVR.

That said, I also need my ARC connection to be physically connected because my TV does other things which need audio passed back to the amp. I did turn on “mute the hdmi connection” (don’t remember the exact label) when testing optical tho.

Ok, if you’re saying it supports it, we shouldn’t talk about it possibly not supporting it, sure :+1:t2::wink:

There are four passthrough settings here… DTS and DTS-HD as well as AC3 and Dolby TrueHD. As you want to use ARC (which maxes out with the non-HD audio formats DTS and Dolby Digital) you should disable DTS-HD and Dolby TrueHD. Vero will then send the core of DTS-HD streams as well as the additional Dolby track of Dolby TrueHD streams (or transcode it to a Dolby Digital stream, if there’s no additional lossy track, which isn’t there very often) - which is exactly what you described as your old setup with a Pi in your intial post (see the below remark about Pi as well. :wink:
Does this make clear why you’ll have to disable DTS-HD and Dolby TrueHD?

And channels have to be set to 2.0 as this setting ONLY affects PCM audio, not passthrough. And S/PDIF as well as ARC do only support 2.0 PCM channels. So, the above mentioned settings should give you exactly what you want. These settings also apply to you, @Arathen, when using optical…

And these settings would also work in this scenario for you, @james.a.milner, if you’d be using optical.

As a side note: Pi is not capable of passing on DTS-HD or Dolby TrueHD. It only passes them on decoded as 5.1 or 7.1 LPCM or it only passes on the core track or a trancoded AC3 track.

Brilliant thank you, this does make perfect sense. And I do understand where you’re coming from.

I’ve never said something was wrong with my vero I have always suspected it was something in my settings but couldn’t put my finger on it.

I will give these suggestions another go when I get home tonight but I do think I have tried this combination before with no success, but I’ll give it another go in case I missed something.

Don’t get me wrong I would love to use the optical output of vero directly to the AVR rather than having audio signals passing through extra unnecessary devices, but while I have the TV plugged into to the ARC of the AVR (I have to leave this like this to allow control of my AVR with my TV remote through CEC and the passback of audio from tv apps such as Netflix) I just get no sound out the AVR from the optical channel, as soon as I unplug the HDMI from my TV to AVR sound comes through via optical - I understand this is an issue with my TV or AVR but can’t see a way round it that would let me use optical from my vero and ARC from my TVs native apps without constantly unplugging cables.