Vero 4k+ not starting anymore


About a week ago I turned off my Vero because HDMI CEC wouldn’t work anymore and I didn’t have the motivation to look into it.

Now I tried to turn it back on, but its not doing anything. When I plug in the power, the red LED turns on and stays on forever. There is absolutely no HDMI output and the device does not connect to the LAN.

I tried the USB Stick and Toothpick method and a different wall outlet. Nothing.

Is there anything more I can try, or is this thing a brick after only five months?

I am seriously bugged with the vero right now, there always seems to be another issue…

If the red light is on solid, then the device isn’t booting.
Can you verify that you are using the supplied power supply and that it is directly connected to the wall?

Are there any other peripherals attached to the device?

If you have another 5V, 2A power supply, you could try this.
If you have a USB cable, you could try powering the device from USB (disconnecting the power supply first).

What issues have you been experiencing? I’ve looked over your forum post and support ticket history and couldn’t find anything that would suggest you’ve experienced a large number of problems with the device



Thanks for the quick reply.

I previously had it connected to a power strip, which worked so far. Now I tried a direct wall outlet, as suggested in the forum.

I had a USB drive, the remote receiver, LAN and HDMI connected. Tried with everything off, only HDMI, only LAN etc.

How would I power the device from USB? Would I need a Female to Female cable?
I don’t have another power supply with a barrel connector.

I had initial setup issues with multi channel sound, the occasional issue with CEC bugging out, and often the Vero would randomly return from suspend and power on the AVR and TV, even if all the CEC settings to power other devices are turned off. Or the vero would randomly switch the TVs source, while not beeing in use at all.

Most of my issues could be resolved with a lot of tinkering, and mostly only reading the forums.

You’re welcome.

We don’t recommend doing this. This can cause problems after some time.

You can use a USB-A to USB-A cable. If you have one, then I would recommend plugging it in to a PC and seeing if the device is recognised.

It’s hard to comment without knowing more about these issues. But for sure, the random switching to another source should be fixed in the next update. @fzinken already confirmed this.


No need to. I think the main issue with the sound was resolved when using a newer rated HDMI cable. Even though I had a 2.0a cable before it wouldn’t work as expected.

Just earlier when using the installer: It only downloaded a 1b file and then obviously failed extracting it. The installer then tells to look in the log file, but does not state where it file is. After finding it there was no error in the log, it just stopped after extracting… Deleting the file and re-downloading worked.

I don’t have such a cable. I tried a USB-A to USB-C Cable to connect it to a laptop or a USB-PD power supply but in both cases the vero doesn’t even turn the LED on once.

What now? Is it worth trying to reinstall using a SD card, or does it not even boot far enough to be able to reinstall? I would need to format a card that is in use, because I don’t have a spare one available.

If that happens again check C:\Users\YourUsername\osmc-installer.log.

I don’t think that will work.

We can send you a new power supply if you open a support ticket. This may solve the problem.


Alright, I will make that tomorrow. Hopefully shipping won’t take too long :slightly_frowning_face:
Do I just use the contact form the on the website?

Would be nice of the installier to show that :wink:

Thank you for your quick response.

Yes, or go to and click the Support tab and open a new ticket.


Hello Sam, I haven’t received any update on my support ticket #946755 for almost two weeks. Can you please take a look at it?

I am checking.

I now got similar problem. I can’t start vero anymore. It comes the blue screen and then the menu and after that out of nowhere the signal is gone. Before the update that never happened. Somehow this update destroyed my vero :confused:

I don’t think the update has damaged your device.
Have you tried reinstalling OSMC?

If you have command line knowledge, you could move your Kodi user data directory away.

The most common reason for black screen after the OSMC splash screen is that the user has selected a resolution which is not compatible with their display.

I remember that you had signal issues in the past and would recommend you check the advice there: Vero 4k+ Blackouts.


The return label should have been sent via a third party email.
I have updated your ticket with the returns label attached directly.


Because my queries in the support issue are ignored once more, I have to ask you again publicly to please respond to my issue!

It’s now at 9 weeks that this thing stopped working out of the blue and I am starting to think that I have to write off the 100€ I paid.
Maybe it would be best for me to just pack the remote and power supply in a box and send it to you as well, as they are useless without the Vero itself!

Or do you think that we can actually resolve this?

I have sent you a returns label. My understanding is that you have used it to return the item. I’m waiting to receive the item back.

Until I receive the unit back, I’m unable to provide any further details regarding the status of the device.

Once the item is received back; we will rectify the problem promptly



It’s been almost 5 weeks since I sent it and I asked you multiple times how long it usually takes, because I don’t think that it should take this long.

And when I don’t get any answers on the support ticket for over a week, it’s not very trust building.

I don’t have any ETA for returns from Germany to the U.K., but do agree that this is a long time.

I have asked that you provide proof of postage / return details so I can investigate this further on our side.

From what I can see, we have responded to all of your messages via the support system to date. I will resend my most recent messages as I think that you must have some issues with receiving emails from us reliably.

I have re-sent the correspondence. If you have not received it, please let me know.

In short: once the item is received back, we will process it within a working day and issue a replacement.

I have received your message and I can see it in the ticket log. However I have no message from you dated from the 18th. Neither is there one in the issue log. So if you sent one then I actually haven’t got it.

Regarding the proof of posting, I was wondering myself, but DHL took the item without a receipt. There was no bar code to scan on it. Basically it is a stamped letter.

Thank you for trying to help me.

When the email is re-sent, the ticket time stamp is updated which is why you see a newer date. But you should be able to see the correspondence under the ticket section.

Usually the person at the desk should enter the return details in to the system. This then generates a receipt which has proof of postage and a tracking number. This needs to be done at a Deutsche Post post-office. I believe DHL is still a separate entity and they will not be able to forward the package.