Vero 4K+ on Kodi 19 unusable after trying skins

I recently updated my Vero 4K+ to Kodi 19 Matrix and I’m experiencing a lot of problems with it after trying to enable some skins that were updated to Kodi 19; Project Aura, Arctic Zephyr Reloaded and Arctic Horizon.

All of a sudden I got lots of freezes (which require reboots by pulling out the power cable), crashes (to the sad-face icon), or just black screens (which also require reboots). It especially seemed to worsen after enabling Arctic Horizon.

I switched back to the default Estuary skin, but now practically nothing works any more. The moment I reboot the Vero 4K+ by removing and putting in the power cable, it boots up normally. But then when I select settings it immediately freezes, having to reboot again by power cable. So I can’t even go into settings to enable debug logging. When I select anyting else, like browsing through the movie list or addon list, it works for a few seconds and then everything freezes as well. If I just let it sit at the homescreen after booting, it stays responsive for at least 30seconds to a minute or something, and then it freezes by itself without my doing anything, or the screen just turns black.

I managed to get into the Vero through WinSCP during the small window I have before it freezes, and I managed to delete the skins I installed from the addons folder before the Vero froze up again. But that did not help.

What can I do now to fix this?

Hi

Check out: Reinstalling OSMC - Vero 4K - OSMC

You may want to try a fresh setup. if you upgraded there may be plugins and/or settings which are not compatible still sitting around. SSH into the vero, and rename the /home/osmc/.kodi directory to something like .kodi.bak, and reboot. You many want to copy in the .kodi/userdata/sources.xml to keep those configs. And selectively copy in some of the settings.xml files from various hard-to-configure plugins from the .kodi/userdata/addon_data.

May want to also review the kodi forum for those skins/plugins to see what their Matrix status is (not all plugins are ready for matrix)

Does reinstall through a disk image set me back to Kodi 18.9? I’d like to stay on Kodi 19 though.
Am I then better off with renaming the .kodi folder?

I just renamed my .kodi folder and rebooted to let it build a fresh setup. But it didn’t fix the problem. I’m still getting random freezes , though not as quick. It now freezes after I browsed the menu for a a bit to adjust some settings, or sometimes also just straight away when I select settings or anything else. Then I have to pull the power again to reboot it.

Also, I can’t copy or move settings files from my backupfolder to the new .kodi folder through SSH with winscp. It either shows an reading-only error or ‘error listing directory’ with the message below. And I can’t download the folder locally to my PC as well, it just aborts midway and loses connection.

Command 'ls -la ’
failed with return code 2 and error message
ls: reading directory ‘.’: Input/output error.

If I reinstall it with a diskimage, can I then still access my .kodi.bak folder? I’d like to not lose that so I can restore some settings.

No, when you install new disk image everything will be removed from the emmc. But that I/O Error above doesn’t look good.
Suggest to try to upload logs grab-logs - A so we can check if the are any explanations for that.

I noticed after my fresh install of the test build that there are only 5 or six skins showing in the add ons menu (the “get more” isn’t there anymore in the interface menu)
Luckily for me Aeon Silvo was one of them which is what I use.
Worked fine that way for me.

Well, it seems to have gotten worse without me doing anything else. If it boots up (and that’s IF because it sometimes also just straight up does not boot when I put in the powerplug) the Vero goes to the homescreen and when I select anything (Videos, Settings, etc) it immediately freezes and I have to reboot again.

If I try to SSH into it while it’s booted up and on the homescreen, it just keeps saying ‘connecting to host’ in WinSCP and does not connect. So I can’t put in commands, and I also can’t enable logs or even select MyOSMC from the homescreen…

I could reinstall and reformat by putting in a usb with the disk image, but I would really like to get the .kodi folder off it so I don’t lose my settings.

Doesn’t sound good an most likely not much you can rescue from that.
Maybe try another power supply to exclude that as a source of the issue.
Otherwise a reinstall via SD Card/USB Stick would be the next step. But it might be that the emmc has a problem.

I gave up and just tried to reinstall, since nothing worked anymore.

But reinstalling from an USB with the diskimage also does not work unfortunately; it first shows up as Formatting… but then it shows: Install failed: can’t mount root.

If I try again it displays; Install failed, please contact support. Hardware is faulty.

Yeah guess @sam_nazarko need to comment but I fear the EMMC is gone.

Are you able to copy a file on to the current system and see if it is stored properly? This could rule out an eMMC issue.

At the moment it doesn’t even boot up anymore.
It just displays this message on my TV:

Waiting for root filesystem device /dev/vero-nand/root

So I can’t SSH into it with WinSCP because it doesn’t have a network connection.

Do you have a USB-A cable? We could try a low level format

Unfortunately I don’t have a USB-A to USB-A cable, only USB-A to micro usb or USB-C.

/edit:
The message was updated to:

FATAL ERROR: could not find root filesystem device /dev/vero-nand/root

You would need a USB-A cable (USB-A to micro USB/USB-C won’t work)

Alright, I’d have to go and buy one then. So just a double headed usb a cable like this? https://media.s-bol.com/R66Qx7J10ByV/550x510.jpg

In order to connect it to my pc? Hopefully the vero will respond to it then cause at the moment it doesn’t respond to anything.

Yes.

I’ve got a USB-A cable now, but it doesn’t seem to work.

My Vero doesn’t seem to boot up anymore, at all. When I plug in the power, nothing happens and my TV says ‘no signal’. And when I connect it through the USB cable to my desktop, also nothing happens. My PC does not recognize the Vero.

Anything else I can try?

1 Like

Make sure the cable is connected to the white port.

Sam