Vero 4k slow remote control response

Hi there, just received my brand new vero 4k device, really happy with it so far. Only one thing bugs me, the response time of the remote control is a bit slow, there is a slight delay, when i press a button it takes like 0.3 secs to react. Is there anything I can do about this or is it normal behaviour?

Are you using the official remote, or an IR remote?
It should be pretty much instant; but the sound of the click can be delayed.

I’m using the official remote and its not only the sound that’s delayed

Is this on the main menu?

Is the Vero 4K very far away?
Are you running intense tasks on the device, or scraping a library in the background for instance?

You could also try re-pairing the remote:

  • Remove the USB from Vero 4K
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K for 2 minutes. Turn it back on. The remote should now work

Thanks for your reply! The vero isnt doing anything in the background. I followed the steps to pair the remote and it seems to be responding a bit faster now, still not instant but better, thanks for the help!!

When you power up the Vero the first time, it takes a while (especially if you have a large media repository) until it calmes down. I tend to wait 2 hours on my setups before doing anything (This is coming from kodi BTW).
Does all kind of things in the beginning like checking/updating plugins etc.

Ok, will wait and see if it improves over the next few days.
Thanks for the fast reply’s, really helpful!

I just received my Vero and I’m experiencing the same issue. Not only that but the sound is delayed by more than half a second which is incredibly annoying.
The Vero is doing exactly nothing right now, not even plugged in the network or connected to the Wi-Fi. I’m dreading the moment when it will actually need to scrape the library.
Is there no other way to fix this?

Please try and scrape the library and let me know if there are any issues with this.

The Vero 4K uses ALSA. If you select your audio device to ‘keep alive’ it should be fine.

Please take a video showing the slow remote response and I’ll be happy to look in to this further. I don’t notice a significant delay on my remote; but there is indeed a repeat filter in eventlircd to slow down duplicate presses. Perhaps this needs tweaking.

Sam

Ensure that audio output is set to HDMI not PCM.
Also is only navigation with the Vero remote slow or also with your CEC TV remote?

I’ll try your suggestions and see if tweaking something with the eventlircd daemon helps in any way.
Is there documentation somewhere or do I just ssh into the Vero and start digging around?

You can edit this file /lib/systemd/system/eventlircd.service.

And change:

ExecStart = /usr/sbin/eventlircd --evmap=/etc/eventlircd.d --socket=/var/run/lirc/lircd --repeat-filter --release=_UP -f

to

ExecStart = /usr/sbin/eventlircd --evmap=/etc/eventlircd.d --socket=/var/run/lirc/lircd --release=_UP -f

And reboot

That will disable the repeat filter.

I tried all options, HDMI output instead of PCM, the keep alive for Audio is set to 5 minutes, and I repaired the remote. The repeat-filter didn’t impact much on the situation.
Now the response time seems slightly better, but audio keeps being delayed. In particular with multiple presses it creates a flurry of sounds that kind of mesh together.

Try to leave the 4k plugged in and powered on over night. With network connected and scraped library.

See if it is better the next morning.

Is the Vero 4K connected directly to the TV, or something in between?
System load would be interesting to see.

Remote speed isn’t something we’ve ever really had complaints about.

Sam

The Vero is connected directly to the TV.
I followed @mcobit suggestion and left it powered overnight, with network and scraped library, no visible improvement. Load in the morning was load average: 2.36, 2.22, 2.17, with kodi.bin as the top process. I have no addons installed except for Weather Underground and I left no task running, as far as I know.

And you are experiencing slow library scraping too? Any other performance issues?

The audio delay on remote press is expected because of how audio is handled on the device but there should be no other effects

Library scraping is definitely slower than my laptop, however I didn’t try with truly new files.
Most of my library already has a movie.nfo and images in the folder of every file, so it’s quite likely that OSMC is just importing those (should be the default).
Playback however is perfectly fine, movies never stutter or buffer and play-pause is instantaneous, with the caveat below.

Why? I already changed the audio output to HDMI, and even when resuming audio playback (movies and songs) there’s a couple of seconds of delay. I have these settings:

Audio output device: AML-M8AUDIO, HDMI
Channels: 2.0
Output configuration: Optimized
Maintain original volume on downmix: ON
...
Keep audio device alive: 2 Minutes
Send low volume noise: ON
...

Do you have Adjust Refresh Rate on?
Setting to Fixed might get audio going quicker.

Audio will always have a slight delay when the sink is opened; as there is a buffer between Kodi -> ALSA -> then the i2s.