Vero 4k+ & Sonos Arc interference

Hi all, firstly sorry for the long post, just trying to get it all down. I have a problem that seems to have started presumably from a software update to something as it hasn’t been an issue before about the last 3 months. I have an LG OLED65C8PLA with HDMI 1 = vero 4k, HDMI 2 eARC = Sonos Arc, HDMI 3 = Nintendo Switch, HDMI 4 = Virgin Media TV box. If I have the Vero connected it “steals” the Arc’s connection making the audio only work through in TV speakers and also unable to connect the Arc to the TV by running the TV Setup in the Sonos app (the app says another device is interfering with it) If I unplug or restart the Vero it works fine. If I unplug the Vero and get the Arc working then plug the Vero back in it usually works fine for a time, maybe a day then goes again. If I reboot the Vero the same happens. I first thought CEC on the Vero but I already had this disabled. Enabled and disabled again just in case. Any pointers would be great! Thanks, Mike

I think you can join 4k+ CEC EARC issue

Thanks @shamael
I’ll post a link on that topic to mine to include me in it.

Can you post some logs so we can see if your device has indeed recently updated and we can work out what version of OSMC you are running?


Hi Sam, see here
I’m running latest release given when using Manual controls in the OSMC gui.

This is while the Sonos Arc is not working. I tried while the logging was enabled to connect my Arc using the Sonos app and got the message again something is interfering.

Sorry I meant to say, I have CEC disabled as I do not want it enabled. So the issues I have are with CEC disabled in the OSMC gui and always has been.

1 Like

Does the ARC connection get stolen immediately or only after Kodi starts?


Hi Sam, if I reboot the Vero with everything connected I regain ARC connection so having it physically connected is not enough to make to happen. Vero needs to be booted. It is a bit tricky though as after a reboot I do usually get ARC connectivity back for a period until it fails again so not massively conclusive. Can I break the boot cycle at a point that might be useful?

Can you clarify what you mean by this?
If the unit is not powered – then eARC will not work.

Vero needs to be fully booted up before it gets stolen. If Vero is connected to HDMI with its power removed or connected to power but not completed starting up then ARC is not stolen.

Okay, if you know how to use SSH there are a couple of things we could check


Sure, go for it.

Hi Sam, i realise it is Febuary but i hope you had a good festive period.
I’ve been checking in on this issue and see nthis post 4k+ CEC EARC issue - #58 by darwindesign that suggests the issue does lie with CEC and siabling it at the physical layer is the solution. While this will i imagine “fix” the issue i don’t see it as a solution. What’s your take on it? Is there anything i can do to assist with diagnosing? Would you say the pin 13 disabling is a legit method (assuming you don’t actually want to use CEC functionality on the Vero).

I know you were asking for Sam’s opinion but I just wanted to chime in to ask how modifying a cable wouldn’t be “a legit method”. All communication is done on this single wire so not connecting it simply removes that device from the conversation. Maybe you wouldn’t want to do this if your using some high dollar cable, but for most people who are just using what they have laying around or paid less for their cable than the cost of a CEC disabling adapter (which just does the same thing) what is the harm? The worst case scenario is that you push in the wrong pin and you destroy a cable.

EDIT: I am just now reading through the CEC EARC thread, so please disregard. Sounds like the only viable option is to revert to 22.03-01 if we can find it or buy a CEC blocker which would negate my being able to use my TV/receiver remotes I assume.

Wow! First post I see in the forums and luckily it’s my exact issue. I have a Vero 4K+ plugged into a Yamaha a2070 which is out to a Sony XBR-65X930E ARC. I have to daily reboot the Vero to ‘release/reset’ Arc, otherwise audio either doesn’t work at all or routes through the TV speakers only. I also cannot use my TV or reciever remotes to control the Vero until rebooting the Vero. The Vero is fine since I can access it from the Kore app and control it and even start streaming, albeit with no audio.

This only began happening about 8 months ago or so. I can’t imagine that it’s a voltage issue with a pin/cable since it only recently started happening. Wouldn’t a voltage issue have always been there?

I have tried a few different cables for all devices including different HDMI ports on my receiver. I’m now on monoprice 8k ultra high speed cables on both devices after trying another brand of slightly higher priced 4k cables.

I am on the latest Sony firmware in an attempt to fix the issue. I updated my receiver as well.

hi @darwindesign, as far as i’m concerned i could take the pin 13 mashing fix and run but that is very much a workaround in my mind as it doesn’t get to the root of the problem. I imagine @sam_nazarko would rather find a concrete reason for it happening than start bundling CEC disabling adapters with each Vero purchase (sarcasm intended). The issue doesn’t seem to be specific to any manufacturer of TV or soundbar and i know my set up has not changed before the issue started happening. This would leave the Vero as the likely cause. Also “worst case scenario” if the issue comes down to some underlying hardware or software fault then any manufacturer of a product would rather find and fix this than suggest people don’t use CEC (or any other) functions and resort to 3rd party adapters to stop problems. Plus, it just doesn’t look good for a professional product. But hey, i could be wrong.

I didn’t intend to suggest this method was anything other than a hack/workaround.

Although it may seem like CEC problems are common with the Vero by seeing numerus posts about it on its support forum, I would submit that the number of users who are reporting issues are a very small fraction of the user base. Not to minimize any particular users problems as everyone desires to have a trouble free experience with something they paid for, but some perspective may be in order. There does seem to be some software aspect that came with an update that increased the number of people who were having issues. Sam has repeated posted about his desire to find and solve this issue but the cause has been difficult to pinpoint. Sam has never, that I recall, suggested disabling CEC altogether as I have. I, as a regular OSMC user, who just happens to be a volunteer mod, and has no affiliation with OSMC otherwise, and who doesn’t speak as a representative for the company, offered up a solution that I use myself to anyone who may see it as a viable solution to any issues they may have.

Absolutley agree. I’m just here trying to help and give any assistance that i can. I’m no moderator but used OSMC on other devices and now a Vero for years, it’s fantastic. My concern (because i care about the product as we all do), is about giving full and useful information on any issues i have with it to better the product and help others, nothing more. As i am having the issue myself, if anyone needs anything more from me then happy to provide.

CEC is complicated. Despite it being a standard, every TV manufacturer renames it and have their own quirky implementations.

Projects like libCEC (upstream) are basically a database of quirks handling and trying to massage the different types of way that devices behave and handle CEC.

I’m still working on it and looking in to it, but I don’t know what’s causing these new problems unfortunately. At the same time, we’re looking at things like allowing an ultra low power standby with CEC wakeup at the same time. So I suspect we’ll have a number of CEC improvements in the not so distant future that aren’t just bug fixes.

As for @darwindesign’s suggestion. CEC is a one wire bus and operates on a single wire. This is why one device in the mix that behaves differently can cause so much chaos. If you use an HDMI cable where pin 13 is disconnected, the device will be completely disengaged from CEC.