Vero 4K+ suddenly stopped working

My Vero 4K+ suddenly stopped working. One moment i was watching tv, the next moment no signal. I unplugged the powersupply of the Vero 4K+, waited 10 minutes and then plugged the powersupply back in. But no light to indicate it was powering up, no signal to the tv, and no ssh connection possible.

I already tried the spare osmc-powersupply i ordered some time ago, but this had no effect and i doubt that powersupply could be faulty.

What are the preferred steps to troubleshoot this situation?

Thanks in advance…


Do you see a red light by the optical (SPDIF) port?


Yes, there is a red light behind the optical (SPDIF) port.



The device then is receiving power.
Do you remember the last version of OSMC you were using?

If you look carefully, do you see the red light for a second or two before the system starts?



The last version of OMSC i was using was the october 2020 update, i did not not yet install the november 2020 update.

The red light (behind the optical port) is on as soon as i switch on the power and stays on. The red cross on the front of the Vero 4K+ never comes on.


So, any idea what i can try next?


The first thing I’d suggest is to reinstall OSMC.

So, that is downloading an image and writing it to an usbstick/sdcard, and then starting the vero 4K+ up with the usbstick/sdcard attached right?

And what image should i download/use, the october or november version?

And after that reinstall the backup i made before upgrading to the october version?


Hai there,

I used the OSMC installer to reinstall OSMC on a sdcard and an usbstick (both tested before using). Then powered up the Vero 4K+ with the sdcard inserted, no effect. Next powered up the Vero 4K+ with the usbstick attached, but also no effect.

With both tries there is nothing to indicate that anything is happening, no red cross, no signal to the tv, nothing that i can see to indicate that the reinstalling-process is working. And i let it sit doing what it is supposed to do for about 15 minutes, so as not to interfere with the reinstalling.

Am i missing or overlooking something obvious?



Can you please show a screenshot of the contents of the SD/USB so we can check that you imaged it correctly?

Sure, here it is…


That looks OK.

My suggestion is to open a support ticket with order details so we can investigate this further.


I opened a support ticket and will wait for your response.




Hello again,

Since i do not get any response anymore on my support ticket for 3 weeks now, despite several messages asking for a response, i decided to get back to my original thread to get some help.

In short: after some time going back and forth on the support ticket, checking several causes, the last option was to send my Vero 4K+ back to OSMC, so i did that. The verdict was that the device failed due to using the wrong powersupply, and there was nothing left to do. End of story after 20 months of life for the OSMC flagship device.

Now, that was very confusing, since my Vero 4K+ has only been powered by it’s official OSMC powersupply that came with the unit. And i have made that clear several times in the support ticket.

Because i know i have never used any other powersupply than the original OSMC powersupply i was at a loss. Also because if i were to buy a new device then that device would be powered the same way, and run the risc of failing also after 20 months.

So i decided to test every device connected to my Vero 4K+ at the time of failure.

Selfpowered HDD: no problem.
OSMC DVB-T2 dongle: no problem.
OSMC powersupply: 5.3 volt (oke i think)
OSMC spare powersupply: 5.03 volt (oke i think)
OSMC USB 3.0 powered Hub: 5.1 volt !!!

And that last one surprised me, since i specifically bought the official OSMC powered usb hub (and a spare OSMC spare powersupply) because of several warnings i read in some topics on this forum about “power backfeeding usb hubs” and that they can damage your device. I received the OSMC powered usb hub shortly before my Vero 4K+ failed, and it was actually connected to my Vero 4K+ at the time it failed. And connected to the usb hub was the self powered HDD and the OSMC DVB-T2 dongle.

Now, with all the switches on the usb hub in the off position there is no power backfeeding, but with any of the switches in the on position there is 5.1 volt power backfeeding on the cable connecting the usb hub to any device. And thus, my Vero 4K+ was receiving power from it’s own OSMC powersupply and receiving power from the OSMC usb hub. And if i read several warnings correctly on this forum you should never power the Vero 4K+ (or any other device) by it’s own powersupply and a usb hub at the same time.

This last finding was reported back to OSMC via the support ticket, but i get no response anymore.

So at this point in time i have no Vero 4K+ anymore, that has been shipped back to OSMC, with nothing left to do about that. I do however have a OSMC powered usb hub that is backfeeding power, and that was connected shortly prior to my Vero 4K+ failing due to “using the wrong powersupply”. And i do not get any response anymore on my support ticket.

I can accept that no device has the eternal life (that is why i also ordered a spare OSMC powersupply alongside the OSMC usb hub). But it is getting almost impossible to accept the “using the wrong powersupply” explanation i got from OSMC knowing now that i have an OSMC powered usb hub that is backfeeding power when it is absolutely not meant to do that.

If i screwed up, than i happily spend the money for a new Vero 4K+, since i loved every moment of it when it was working for 20 months. I even asked several times what a replacement unit was going to cost me, before i checked the malfunctioning usb hub, but i never received an answer to that question either in the last 3 months.

But i don’t think i screwed up here, since i only used the official OSMC equipment, and one of those has been found to be faulty.

Sorry if the above comes over as terribly impatient or angry, but i am really disappointed by this whole support experience. I just want to get this sorted out, and in the proces of that just taken seriously.

So if anyone can help me to figure out what to do now, and get this sorted, that help will be very appreciated.


Hi Olav

We responded to your ticket weeks ago. Unfortunately there is not much further we can add.

  1. The device is significantly past its warranty period. We offered to receive this back and take a look to fix it as a gesture of good will but said we could not guarantee this would be possible.
  2. The device seems to have been damaged by use of the incorrect power supply. This cannot be caused by USB, because the damage is near the barrel jack connector

I will send you another email tomorrow outlining the options. But unfortunately this device itself cannot be repaired. The mainboard is damaged.


Yes, your last response was on the 11th of february, but there has never been a response to my message concerning the faulty usb hub on the 13th of february. Nor any response on my 2 messages after that on the 21st of february and the 28th of february.

And yes, you stated that there was no guarantee the device could be fixed. I agreed to that when i shipped the device back to OSMC.

And i will repeat this again, my Vero 4K+ has only ever been powered by the official OSMC powersupply, and never by any other powersupply. And as discussed in the support ticket the powersupply was not used in any way that could be damaging, it has always been plugged into it’s own wallsocket and no extension leads were ever used.

And in your reply above there is still no mentioning of my faulty usb hub, but now you say the device “seems” to be damaged by use of the incorrect powersupply, wich is much less sure than what you say in the support ticket where you say this is a fact.

Without having seen the damage with for myself, i have asked in the support ticket for any logical reasoning about your statement i have used an incorrect power supply, but never received any answer.

And now you are asking me to believe that, yes the device is damaged, but that is still the result of using an incorrect powersupply and not because of the faulty OSMC usb hub you sold. While on the forum you have stated that powering the Vero 4K+ by it’s own powersupply and a power backfeeding usb hub can damage the device.

And for 20 months my Vero 4K+ has not malfunctioned, but a few days after attaching the faulty OSMC usb hub it failed. And that to me is no coïncidence.

If the OSMC powered usb hub is backfeeding power, and thus has a proven manufacturing fault from the start, how can you maintain that i caused the damage to my Vero 4K+ (by suggesting i used an incorrect powersupply, when i definately have not) ? Is it not just as likely that my Vero 4K+ has a manufacturing fault, or that the original OSMC powersupply is faulty/failing ?

I repeat what i wrote to you in the support ticket, that i have answered all your questions truthfully and that i never used anything else but the original OSMC powersupply.

Wether you choose to believe that or not is up to you.


I have responded to your messages more recently than that. I am happy to resend these for you.

As I mentioned: if your Vero had a manufacturing fault, it would not have worked for the duration that it did, it would have failed either instantly or within hours of use.

I also mentioned that the USB hub will backfeed power to the Vero when connected and that this is safe. The damage to the device is at the barrel - not at USB PHY.

This is not the case. You can use both the official hub and PSU together without any issue.



Now this is getting confusing:

  1. I received every response from you in my support ticket and in my mail, but i have not received any response (in my support ticket or email) after the 11th of february. But i have received your reply you send just a couple of minutes ago. And i somehow now can not get into my support ticket, from where i reply to your replies, i just get an 404 page not found error.

  2. There are a couple of posts on this forum clearly stating a power backfeeding usb hub can damage the Vero 4K+:

  • If you power via USB and the DC barrel you can damage the device (your words, not mine).
  • That you should never power the Vero 4K+ simultaniously by the barrel connector and the usb port(s).
  • That is why the OSMC powered usb hub does not backfeed power, unlike some other usb hubs that don’t respect the usb specifications.

And one to sum it all up:

  • The OSMC powered USB 3.0 hub won’t pass on any power to the Vero via the blue upstream USB cord (which is meant to connect the hub to the host device). So, powering the OSMC USB hub with its PSU and the Vero with its PSU at the same time is no problem at all… And connecting whatever device to the USB hub won’t be a problem then either. The OSMC USB hub will never pass power to the host device (the Vero in this case).
    Just hubs that don’t respect USB specs and deliver power to the host device as well, those are a problem.

So back to your statement above that it is safe to use both the official hub and PSU together without any issue, you mean the official hub when it is not backfeeding power i assume. Because i specifically bought the OSMC usb hub because it would not/never backfeed power, taking to heart those warnings because that could damage the Vero 4K+ as stated in the forum (your words, not mine). And my OSMC usb hub is definitely backfeeding power. So either i am misunderstanding you (english is not my native language) or you are now saying a power backfeeding OSMC usb hub could never cause problems. But even regardless of that, it should not, and therefore is faulty.

  1. In your reply concerning the details for shipping my Vero 4K+ back to OSMC dated the 8th of january this year you stated:
    “If you can print this email or include your order number in the return that will be helpful. We will get you a new working unit out shortly. I apologise for the inconvenience here”.

And that gave me confidence the situation would be handled carefully and fairly, but after that reply things returned back to the usual “you have used an incorrect powersupply”.

I think this is enough for this evening. I will await your reply tomorrow and will take things from there.



You should respond to tickets via your email client’s ‘Reply’ function. This will re-open the ticket and update messages as unread.

This is not applicable for the OSMC hub.
The issue isn’t actually backfeeding from the USB hub, but hubs that backfeed voltage unexpectedly, where it can be an out of spec voltage (this would cause the damage).

I do apologise for that. This is a canned response that is sent for returned goods that are in warranty. I sent you this message but did advise before that the device was out of warranty we could only do our best to repair the device but not guarantee it. You seem to recognise this in your previous posts.

Honestly – if it was possible, I would have happily taken care of this for you (fixed it and shipped it back). Hopefully you can see other feedback (A bit of praise) that confirms this. But this device itself is dead and cannot be repaired.