Vero 4K + / TrueHD & DTS-MA Sometimes works, often doesn't

On MKVs with a 7.1 audio track - either TrueHD or DTS-MA - I’m getting no passthrough audio at my amp (Pioneer VSX-919) most of the time. If I stop and start the same MKV a few times, sometimes I get sound.

5.1 tracks work 100% of the time.

Here’s a log where I only got TrueHD 7.1 coming through on the fourth start attempt (Avengers.Infinity.War.2018.UHD.BluRay.2160p.TrueHD.Atmos.7.1.HEVC.REMUX-FraMeSToR.mkv)

I bought the Vero to get the 7.1 audio that I was missing on my Pi, so this is quite disappointing. I’ve read some other threads with a similar complaint to mine but with Denon amps, but most of those problems seem to have been corrected months ago. I don’t get pops or noise of any kind. When it works it’s perfect, when it doesn’t it’s just silence.

Any ideas?

I see quite lots of:

channel count should be 8, we got 2 aborting

in the logs. You sure you got 8 channels? (7.1) - or is the audio going through your TV which has only 2 channels?

You should get 7.1 reliably if you disable passthrough.

Straight from Vero to the Amp. I get 7.1 working occasionally. I’m definitely mostly not crazy :slight_smile:

Thanks for the comment. I know you’re correct. But I’m also intending to get a new amp for Atmos 7.1.2 in the next six months and now that I have a Vero that doesn’t work with passthrough 7.1 today, I’m having a touch of buyer’s remorse and anxious to get it sorted out.

It’s just a ‘workaround’ as long as you don’t need Atmos. Quality should be the same.

Your issue is not generally experienced by other users so I’m just having a close look at that log for you.

Edit: What happens if you set your desktop resolution to 1080p60Hz instead of 1080p50Hz? That’s the only difference I can see between your setup and mine.

@frozenpea. Have you tried updating your receiver’s firmware? I had a client with the same problem before. It turns out his receiver wasn’t updated.

That’s quite normal, surprisingly! I’m more worried about this:

19:31:30.821 T:4078715472   DEBUG: ------ Window Deinit (Custom_Cache_Progress.xml) ------
19:31:30.821 T:4078715472   DEBUG: Resolution 1920x1080 @ 50.00 - Full Screen (16) not a very good match for fps 23.976 (weight: 0.043), trying 2:3 cadence
19:31:30.822 T:4078715472   DEBUG: Resolution 1920x1080 @ 50.00 - Full Screen (16) not a very good match for fps 23.976 with 2:3 cadence (weight: 0.166), choosing 60 hertz
19:31:30.822 T:4078715472   DEBUG: 60 hertz refreshrate not available, choosing highest
19:31:30.822 T:4078715472  NOTICE: Display resolution ADJUST : 1920x1080 @ 50.00 - Full Screen (16) (weight: 0.043)

On my device i get this:

12:54:55.789 T:4081324624   DEBUG: ------ Window Deinit (Custom_Cache_Progress.xml) ------
12:54:55.790 T:4081324624  NOTICE: Display resolution ADJUST : 1920x1080 @ 23.98 - Full Screen (28) (weight: 0.000)

I can’t immediately see why @frozenpea’s device is not switching to 24Hz. This could be upsetting the audio timings.

Edit: Aha! Please reboot your device with your AVR and TV turned on. If you turn on vero without the TV on, it doesn’t pick up all the display modes. A fix for that will be in the next upgrade.


It’s an old amp, kinda pre-dates customer friendly updateable firmware but it is running the latest version I found on some dodgy site (circa-2010).

Done. Also set desktop res to 60hz per your previous post.

New logs - again, audio worked on the fourth play. Butttt… before i remembered to turn debug on, it worked on the third play. Just mentioning because it’s not always four times (I have had it work first go at least once).

I don’t think this is related the Vero 4K+. I use it for both DTS-HD.MA 7.1 and TrueHD 7.1 in addition to Atmos and DTS:X without any issues. I could be a bad cable or issues with your receiver/surround processor.

Regarding HDMI and surround receivers/processors. What most people don’t think over - disconnecting and connecting HDMI cables from the receiver/processor can kill the HDMI board very easy. Be careful and turn the device off before connecting or disconnecting any HDMI device.

I can’t find anything in the logs that indicates an issue. If there is anything that can be done to vero to help, we would need to narrow down the types of files that have this problem. The example in the log is 4k and Atmos. Your amp is 3 years older than Atmos. Is it also a problem with 1080p and non-Atmos but TrueHD files? What about 1080p and DTS-MA?

I’ve done some additional testing from my library focusing on a mix of different audio tracks. What I’ve found is any TrueHD or DTS-MA track is problematic. 5.1 is also a problem! So my assertion that 7.1 is the issue is wrong. I didn’t notice earlier because so few are in 5.1.

Standard DD, DD+ or DTS work 100% of the time.

Yeah it’s an old amp, but I have no problems whatsoever with these audio formats from my (equally old) bluray player, which is why i thought it must be something quirky with the Vero.

Tell me what additional specific data I can provide to help you identify the cause. I appreciate your prompt replies so far :slight_smile:

(i updated the thread title to remove the 7.1 reference)

I’m not sure we can help you. (@sam_nazarko may have other ideas). It could be some quirk of signal timing between vero and the AVR which would be very difficult to track down. Have you tried different HDMI cables, using a different HDMI input on the AVR and/or a squirt of contact cleaner/lub in the HDMI plugs and sockets?

As I say, the pragmatic answer is not to use passthrough and save up for a modern AVR. I don’t think we’ve had other reports of these symptoms, but correct me if I’m wrong.

Edit: Maybe we need to add your AVR to the list here DTS-HD-MA not always recognised on Denon and Marantz but no problems with TrueHD reported there.

When you have no sound – what do you see on the AVR in terms of lights? Is it different to when it works?


Just says Stereo, as if I hadn’t left the Kodi menus. It doesn’t flicker or change at all.

When I get sound, it shows the format and the channels.

Do you have the remote that comes with the Vero, what does it show for the audio channels when you press the hamburger/menu button while a film is playing with TrueHD?

Are you able to get a menu up on the Pioneer? I have a status button on my old Denon and it shows the format of the input channels. I.e. 3/2/0.1 for 5.1. Are you able to do similar?

Not sure I’m helping.

I have a DTS-X and Dolby Atmos amp and have no issue with passthrough and the Vero 4K
Have you able to use a Dobly or DTS demo disc and test all channels separately ?

Sometimes you have to manually chose the audio track on an MKV file and make sure it’s the one you want to play…

I have the same issue as frozenpea.
Pass through bitstreaming sometimes works, often doesn’t on the same file.
My specific issue is that when it doesn’t there is a loud noise through the system.

I’ve set the Vero 4K+ to pcm output and it sounds amazing with 7.1 channels.
I’m just worried if/when I upgrade my processor to handle Atmos/DTS-X then I will def need bitstream output for the height channel information.

I’m running an older but very good Anthem D2V processor. Thinking of replacing with Anthem AVM60 or Martantz 8805.

Can you confirm if any DTS formats are affected? We know about TrueHD issues, especially with Atmos. DTS formats are generally OK now. (Exceptions noted above.)

There are reports of newer Anthems not playing DTS-HD-HRA tracks. Beware.