Vero IR Remote Issues

Hey everyone,

I just got my Vero today, and wanted to ask about the remote. I haven’t seen anyone else mention this issue, so I’m thinking this issue may not be common. About 50% of the time, after I let go of a button, the Vero will keep pressing as if I hadn’t let go.

For example, when I press OK to play a video (and release the button), it starts to play the video but then rapidly starts pausing and unpausing the video. Or scrolling through media from an NFS server, pressing (and releasing) the down button will send it flying to the bottom of the list.

With my limited knowledge of LIRC, it seems like it’s getting the button press signals from the remote, but not the button release signal. Anyone else experience any issues like this?

Thanks in advance!


Are you connected via WiFi?


I have the same issue and only with wifi, no problem with cable ethernet
thanks for the momentary “trick fix”

Yes, I am connected via WiFi.


I have seen another report of this behaviour myself, and I can see the cause of the issue. I’ll take a stab at fixing it tonight. It should also bring better WiFi throughput as well


1 Like

That’s great news, thanks Sam!

I also had this issue with wifi and switched to wired ethernet for a quick fix

This morning I had to hard reboot (pulled the plug) my vero as the wired network connection had failed. all other machines on my network are still running fine and the vero crashed/stalled when i pressed the button for a reboot via shutdown menu. Rebooted and all seems fine

I too have experienced this issue in my setup.
Strangely as it seems, the remote was working fine before I decided to manually update Vero. After the update I shutdown Vero and booted it. After the boot, while on the movies menu, the remote goes haywire.
I’ll try the use of wired network only and see if it gets worked around.


Can you try updating via My OSMC and trying WiFi and remote now?

The issue should now be addressed now


Just updated and tried it, it’s not any better. It seems like the button repetition stops after a few seconds now, but it is still happening.

Did you reboot your system, I forget whether the prompt to reboot after update has been added for WiFi

Can you also let me know how to replicate this exactly?


Yep, I did reboot, and even checked for updates again after.

Right out of the box, I set it up for WiFi (no Ethernet at all) and tried to use the remote. I haven’t done any special setup, this just happens from trying to use the IR remote that came with the Vero while using the WiFi connection.

So you’re having this issue on the main menu without doing anything such as streaming etc? This is most peculiar, as the issue before seemed to present only under some form of network traffic.

Sorry, I’m just playing a video from an NFS server, as I stated in the original post. It also happens when just scrolling through the files/folders on the NFS server, it does not seem to happen on the main menus.

1 Like

Ok that helps, I’ll check it out.


Here’s an example of the issue, you can see it quite clearly in the beginning and end of the video. It doesn’t happen every time, maybe about 50% of the time. And sometimes it doesn’t respond to the button presses at all.

1 Like

Thanks for making a video of it, I am seeing the same issue. with both my Vero remote, harmony emulating mce, and rc6 mce remotes. for me its not as much 50% closer to 30% which makes it that extra annoying because its harder to reproduce and capture logs.

it am also streaming over nfs.

So I just opened up my vero and pulled out the IR window! wow that is a thick piece of plastic. looks like this has sorted out my issue, maybe that bit of plastic was blocking some of the IR. not suggesting you do the same, might void warranty etc… but it seems to help a lot don’t have many dropped button clicks

I too am having remote issues. When I click
, say the down arrow, there is a pause then the whole range of options scroll past with no way of stopping it, it was OK yesterday but neither hard or soft boot has helped.

Just done manual update but still on “super scroll”