Vero V puts UHD content on 1/4 of the screen

This is something new I have not seen before. What is going on here? Applies to all UHD (2160p) content. TV is LG OLED CX 77" (this has been working flawlessly for years).

Same material on Zidoo Z9X works with no issues.

Even Kodi menu gets drawn in top left corner when setting resolution to 3840x2160p (2D).

4096x2160p (2D) works fine, so problem only applicable to 3840x2160p (2D) - regardless of refresh rate.

Have a look at this thread: 4K videos playing wrong size on Vero V

I’m lost, tried everything in linked thread - issue is still the same.

Resolved it, but got confused since I actually got connected to the wrong Vero V device :rofl:

This did the trick:

systemctl stop mediacenter && awk -v RS='' '{sub(/<resolutions>.*<\/resolutions>/,"<resolutions/>"); print}' ~/.kodi/userdata/guisettings.xml>tmp && mv -f tmp ~/.kodi/userdata/guisettings.xml && systemctl start mediacenter

The following post has listed how to fix a setup without profiles from within Kodi as well as a terminal command for people who use profiles…

Glad this is now working for you


1 Like

I’m in the middle of The Mandalorian marathon :smiling_face_with_three_hearts:
Just ripped the UHD discs for season 1 + 2.

1 Like

Enjoy and sorry about the inconvenience. Have a good New Year.

1 Like

Thank you Sam, and the same to you :smiley: