VERO4K+ unable to play x.h265 HDR 4K and crashes [SADFACE] 2 to 3 min in to the Movie [Isolated to KODI 18]

@sniferx1, I have also PM’d a link to @sam_nazarko to an extract from one of my 4K mkv files to see if that helps with diagnosis, as I too have had the playback crash a few minutes into 4K titles, not sure which OSMC version introduced this bug, as the files used to play fine.

@sam_nazarko and OSMC Teams

It’s almost a month and requesting an update on this reported issue.

As I inform already this issue is replicated on my 4K+ BOX and other 3 4K boxes.

As a user I really want to get this issue fixed as I am kind is fed up of kids complaining about SAD face while watching movies.

I got no problems on my KODI install on my MAC Book therefore this is 100% related to VERO builds.

I am happy to provide more logs however someone clearly need to clarify why the provided logs not sufficient as even I upload new logs it will show the same issue.

P.S: I am disappointed that I had to use PLEX to play 4K movies until this issue resolved as I was a fan of OSMC since day 1 and this is the reason I supported the team by having 4 Vero boxes at my home.

If you can play without crashing when passthrough is turned on then you could set settings>system>audio>(make sure your viewing advanced or expert view)
Number of channels: 2
Allow passthrough: enabled
Dolby Digital capable receiver: enabled
Enable Dolby Digital transcoding: enabled
DTS capable receiver: disabled (unless you actually know you can pass this)

Not related to crashing but as a FYI you might want to give a check through your advancedsettings.xml file as I see some tags that were removed from Kodi quite a few years ago. It might be worth a revisit there. Keeping 200 recent items seems like a bad idea IMO. I see you commented out your insanely large cache but if your doing something that is memory heavy on your box you might actually want to override the fairly large cache that the Vero is defaulting to. I would probably go with something like 160MB with a read factor of 4 if you need it, or just setting the cache mode to 0 if you don’t.

@sniferx1 are you still using the upnext service? I seem to recall that it’s been causing other people problems. Try disabling it if you are still using it and see if that helps.

I’ve replied to your PM.

I can’t reproduce the issue since May 2019.

I suspect there may be an issue on the NAS side, as you’ve stated that this only occurs if the device is left overnight.

The logs you provided were for an older build of OSMC and we have made changes since then, which is why I was hoping to get some new debug logs highlighting the issue.

@sam_nazarko

I am currently experiencing 3 issues and for the sake of not mixing things I have kept them separate.

Issue 1: What reported in this thread [ SAD Face / Crash while playing 4K movies]

Issue 2: What reported in below thread and SAD Face while Skipping with progress bar

Issue 3: Each morning can’t play any movies and require to reboot the VERO device [This is the issue I PM you but now I have created a topic for public tracking]

I will post new logs regardless. I am using Synology NAS and nothing changed in the NAS side since KODI 17. I also post the NAS speed test results and we can’t blame the NAS.

Also I got no issues playing same 4K titles via my MAC KODI on WIFI and this also showing no issues at NAS side.

If you truly believe it’s NAS please share some tips and help to chase the NAS manufacturer.

@darwindesign Thanks heap for taking your time to help me. This issue is not isolated to passthrough enable / disable.

Given initial evidence showed files are playing with NO AUDIO with passthrough mode enabled, I invested on DOLBY Atmos soundbar and and got one.

Unfortunately now the issue 100% reproducible even with passthrough mode enabled. It’s a 2.1 soundbar and I have enabled the settings correctly and as below.

I also know Dolby sound received by the soundbar as it’s DARK BLUE light turning on as per soundbar specification.

I have connected the VERO 4K to soundbar directly via HDMI and then Passthrough to TV for the VIDEO.

Number of channels: 2.1
Allow passthrough: enabled
Dolby Digital capable receiver: enabled
Enable Dolby Digital transcoding: enabled
DTS capable receiver: disabled

@bmillham Thanks for this valuable tip. I will disable this also. As per your feedback I have already disabled the “Watchdog” service and now I will disable this and will post the logs If the issue happen again.

Let’s get this solved.

I assumed you were setup differently. The correct settings should actually be…

Number of channels: 7.1
Allow passthrough: enabled
Dolby Digital capable receiver: enabled
Enable Dolby Digital transcoding: disabled
DTS capable receiver: disabled

1 Like

!!!eureka

I did a below change and let a movie played for 3 hours. To my suprise not crash while playing a movie.

I am not that technical and this means an issue related to KODI handling of NFS mounts and now we got a clear evidence. What is next @sam_nazarko? How to fix this…

I have mount the 4K movies as a local HDD via

osmc@MBRVero4Kplus : ~ $ sudo nano /etc/fstab
192.168.1.117:/volume1/4K_Content /home/osmc/4K_Direct nfs noauto,x-systemd.automount 0 0

Then I have added the mount as a local drive and then played the file without scanning to Movies Lib.

Movie used have issue now playing fine with this workaround. Given I have 4x Vero boxes, 1 MAC at home on KODI I need to use central DB and scanning and having local copies not helpful at least this will allow me to play movies until a solid fix available.

I will try this as well. Thanks for this…

P.S: Attached is my sound settings… Can you kindly confirm these are correct. My soundbar details as below as well.

Soundbar Specs: [Infini Pro | Soundcore]

SPECS

Audio
  • Drivers: 2 × 3” Subwoofers, 2 × 2.5” Mid-Range Drivers, 2 × 1” Tweeters, 2 × Bass Ports
  • Output: 120W
  • Decoder: Dolby Digital, Dolby TrueHD, Dolby Digital Plus, Dolby atmos
  • EQ Mode: Movie, Music, Voice
Dimensions & Weight
  • Length: 36.6 inches / 930 mm
  • Width: 4.7 inches / 120 mm
  • Height: 2.4” /61mm
  • Weight: 116 oz / 3.3kg
Connectivity
  • Bluetooth Version 5.0
  • Supports A2DP1.2, AVRCP1.5, and SBC decoding
  • Range: 10 m / 33 ft
  • HDMI Arc
  • HDMI In
  • Digital Optical input
  • AUX in (3.5 mm)
  • Bluetooth Version 5.0
  • Input: USB (For service only)

Vero4K+ Audio Settings:

Some NAS seem to not work to work as well with current versions of Kodi than they had in the past and system mounts can cure this problem. You do not have to give up your MySQL or redo your library fortunately. What you need to do on all your systems is to setup fstab and do a pathsub in your advancedsettings.xml file.

  <substitute>
    <from>nfs://192.168.1.117/volume1/4K_Content/</from>
    <to>/home/osmc/4K_Direct</to>
  </substitute>

or something of that general effect for ALL of your sources that you setup fstab for
(note that I have never done this myself but this is the way I understand it to work)

1 Like

The manual for that is fairly sparse and does not actually answer the question I would need to be sure.

The basic rundown is that the channel setting is the number of LPCM channels your input device (soundbar) supports. This setting is NOT how many speakers you have. If you set it to 7.1 and play a DTS soundtrack and get sound then your soundbar supports 8 channel LPCM and that is the setting you should use with DD transcoding off. If you get no sound when you play a DTS soundtrack with those settings then you would want the 2 channel setting I outlined above. Since the soundbar is Atmos I would expect it support what any Atmos AVR supports, but this would require testing as the manual does not list it one way or another.

@darwindesign

When you free can you kindly review below Kodi log and confirm my path substitute working? Your suggestion is much appreciated. Once this working I will replicate across other VERO boxes.

https://paste.osmc.tv/oqipesumas.vhdl

My new advancedsettings.xml as below and updated all tags accordingly your feedback and validate in KODI Wiki for TAG validity

<?xml version="1.0" encoding="utf-8"?>
<!-- General Settings -->
<advancedsettings>
    
    <!-- MySQL Library -->
    <videodatabase>
        <name>MyVideos</name>
        <host>192.168.1.117</host>
        <user>xbmc</user>
        <pass>****</pass>
        <type>mysql</type>
        <port>3307</port>
    </videodatabase>
    <musicdatabase>
        <name>MyMusic</name>
        <host>192.168.1.117</host>
        <user>xbmc</user>
        <pass>****</pass>
        <type>mysql</type>
        <port>3307</port>
    </musicdatabase>
    

   <pathsubstitution>
  	<substitute>
  	  	<from>nfs://192.168.1.117/volume1/4K_Content/4K Movies/</from>
   	  	<to>/home/osmc/4K_Direct/4K Movies/</to>
  	</substitute>
 	<substitute>
   		 <from>nfs://192.168.1.117/volume1/4K_Content/4K Tv Shows/</from>
    		<to>/home/osmc/4K_Direct/4K Tv Shows/</to>
  	</substitute>
	<substitute>
  		<from>nfs://192.168.1.117/volume1/4K_Content/Test Clips/</from>
    		<to>/home/osmc/4K_Direct/Test Clips/</to>
  	</substitute>
   </pathsubstitution>
   

  <cache>
    <buffermode>1</buffermode>
    <memorysize>160428800</memorysize>
    <readfactor>4</readfactor>
  </cache>

    
    <!-- Video Library Tweaks -->
    <videolibrary>
        <importwatchedstate>true</importwatchedstate>
        <recentlyaddeditems>25</recentlyaddeditems>
        <dateadded>1</dateadded>
    </videolibrary> 
    
    <videoscanner>
        <ignoreerrors>true</ignoreerrors>
    </videoscanner>
    

 <loglevel hide="true">2</loglevel>
	
</advancedsettings>

make sure you put the actual password in for the MySQL db.

test the path subs on the first box before copying to the other boxes. Make sure you have added fstab entries and they are working for all of the paths you are subbing. You will have to edit the fstab on all the boxes as well. Make sure you are accounting for the spaces in fstab (\040). I don’t know if the spaces are an issue with the path sub or not but since the wiki doesn’t mention it I assume not. Testing will answer that question.

<ignoreerrors>Why? If this is an issue get better at naming your files.

<loglevel>Remove this. When you need to do this add it as a log level ‘1’ and then remove it after your done. This setting is a lot more complicated than the wiki would lead you to believe. When you want a loglevel 2 you get that from turning it on in the GUI.

Suggest to remove the cache setting, the default is already optimized

@darwindesign I have marked this post as resolved via KODI “pathsubstitution”. Even this is not the proper solution I am happy as I can play all files now. Hopefully KODI will fix this in later releases.

For other users who experiencing the same issue below are the steps it got resolved for me.

Step 1: Create local folders according to your NAS folders

E.G: I have created below in my Vero Box --> Home

4K_Direct 
Movie_Belly
TVShows_Belly

Step 2: Modify your fstab to mount the shared NAS folders to created folders in above step

osmc@MBRVero4Kplus : ~ $ sudo nano /etc/fstab

Step 3: Add the fstab entries
E.G: Below is my fstab and make sure you change it to match yours

192.168.1.117:/volume1/4K_Content /home/osmc/4K_Direct nfs noauto,x-systemd.automount  0  0
192.168.1.117:/volume1/Movie_Belly /home/osmc/Movie_Belly nfs noauto,x-systemd.automount  0  0
192.168.1.117:/volume1/TVShows_Belly /home/osmc/TVShows_Belly nfs noauto,x-systemd.automount  0  0

**Step 4: Add the pathsubstitution entries to your "advancedsettings.xml **

E.G: Below is my “advancedsettings.xml” and make sure you change it to match yours

 <pathsubstitution>
  	<substitute>
  	  	<from>nfs://192.168.1.117/volume1/4K_Content/4K Movies/</from>
   	  	<to>/home/osmc/4K_Direct/4K Movies/</to>
  	</substitute>
 	<substitute>
   		 <from>nfs://192.168.1.117/volume1/4K_Content/4K Tv Shows/</from>
    		<to>/home/osmc/4K_Direct/4K Tv Shows/</to>
  	</substitute>
	<substitute>
  		<from>nfs://192.168.1.117/volume1/4K_Content/Test Clips/</from>
    		<to>/home/osmc/4K_Direct/Test Clips/</to>
  	</substitute>

	<substitute>
  		<from>nfs://192.168.1.117/volume1/Movie_Belly/</from>
    		<to>/home/osmc/Movie_Belly/</to>
  	</substitute>
	<substitute>
  		<from>nfs://192.168.1.117/volume1/TVShows_Belly/</from>
    		<to>/home/osmc/TVShows_Belly/</to>
  	</substitute>
   </pathsubstitution>

**Step 5: Reboot the box **

I’m not sure what you mean by this. This is a completely valid way to run your library. You could completely redo your library so your database points to the new location instead of the old one but you would gain nothing from this. If your referring simply to system mounts working better than Kodi network paths then I would say you would have to bring that up with team Kodi. If there was something to be done in OSMC to fix whatever issue is going on with certain peoples setups that are proving problematic then Sam and his team would have already done it.

It’s not really a Kodi issue. When you mount a share using fstab, it’s doing it as part of the kernel so will perform better and use less resources. When you mount via Kodi then the mount is running in userland and will require more system resources. The issue is just that the NFS and SMB userland libraries on linux are not as optimized as the kernel based libraries.

@sniferx1 if you are really brave, you could modify the MySQL database so you don’t have to use the path substitution. That would require that all your systems use fstab mounts of course, and if you have other windows based system then you would have to use path substitution on them. And you would be in danger of completely hosing your database if you don’t run the SQL commands correctly. I personally have done this a number of times when I moved content to different shares.

So, while fixing the database is not really difficult, it’s not something you should try unless you understand SQL commands and the risks if you make a mistake and how it may affect other systems using the same database.