Vero4k -> Vero4k+ migration issues

Device OSMC Version
Vero4k OSMC November 2020 2020.11-1
Vero4k+ OSMC August 2021 2021.8-1 then OSMC December 2021 2021.12-1

I created a backup of everything on my “old” Vero4k (including add-ons and thumbnails).
Then on the Vero4k+ I selected the option to restore everything.

After the restore I’ve noticed the following issues:

  • /etc/fstab was not restored
  • The Home menu only has one item Settings, all other items (Movies, Collections, TV Shows, Videos, Music, …) are gone
  • The database was restored to MyVideos116.db but Kodi on Vero4k+ uses MyVideos119.db

The first thing makes me wonder, if other files were also not properly restored. I might have to go through the entire list and check manually.

The second might be an issue with the new OSMC skin. At least it could warn me that I cannot restore the skin settings. I also ran into a problem when I tried to configure the new skin. It said an add-on was required and when I clicked on it to install it, I got the message that the add-on was not compatible. Hmm.

Not sure what to do about the third one. I probably can’t just rename 116 to 119, because the db schema is most likely a bit different. So how do I migrate the db version from 116 to 119?

What is the best way to debug this? Yes, I could turn on debugging and send the logs. However, the backup is 3.5GB, thus if the debugging mode were to list every file and whatnot when restoring the thumbnails, the logs would be huge. If you don’t mind I can do this. Otherwise, maybe you can suggest another option. e.g. start with only trying to restore the /etc/fstab.

For the first issue, I don’t think the backup utility had an option to include the fstab back then so that would be something that would have to be recreated.

As for the second issue go into the skin settings and install the optional add-ons and see if that gets that working again. I’m really not sure on how well it does or does not migrate from the old though. Perhaps @Chillbo has some insight here.

For the final issue I would suspect that because MyVideos119.db existed on the new install and the restore did not have that file then both existed and Kodi wasn’t looking to do an upgrade. If you ssh in and…

systemctl stop mediacenter
rm .kodi/userdata/Database/MyVideos119.db
systemctl start mediacenter

with the db from the backup still there then that should get your db back and updated automatically.

Yes, there is a checkbox for fstab on the old system. It is also in the backup file.

That’s the thing. I can’t install it, because I get the error message that it is not compatible. That’s the weird thing. The UI let’s me click on install, but then it tells me “no, no”.

Awesome, this worked. Thanks.

No clue why it didn’t restore. Can’t you just manually copy it over?

When he gets a chance I suspect that chillbo may be able to guide you through finding a working solution on this.

Your very welcome.

You are running two different versions of Kodi which lead to issues. My recommendation would be to first update the Vero4k to the December 2021 version and then do the backup that you then restore on the Vero4k+ December 2021 version.

1 Like

Of course I can. And I most likely will. But that was not my point. I am puzzled why the file wasn’t restored.

Oh, wait. I was checking /etc/fstab but it seems the fstab was restored into the .kodi folder instead. Hmmm, interesting. So maybe that’s the way this works. When I checked overwrite files I thought it would do just that.

No, I’d rather not do that. Otherwise I will have 2 broken UIs. For now the “old” one will stay as it is, until the new one is working properly.

Well your choice, but transferring the backup between the two will break your new system.

It already broke my new system as I mentioned in item number 2.

If I update my old system and that one is broken too, what then?

If you didn’t want to upgrade the old unit to current then there is still the option to install the older version of Kodi on the new box, restore to that, then upgrade the new box back to current.


The skin should offer information on this in the setting description text in the bottom half of the screen: The addon hasn’t been published in the Kodi repo for v19 yet. Don’t ask me why. But there is a version compatible that you’d have to install manually: GitHub - kodi-community-addons/ Kodi add-on to create skin backups and themes

1 Like

Backups should be restored from / to the same version.

1 Like

This seems like a good idea. I will search how to downgrade on this forum, since I have never done a downgrade on a Vero.
I will try Chillbo’s suggestion first.

Thanks for the info. I will try this out as soon as I get to it. (After the New Year’s break I have to catch up at work and I’m mostly beat in the evenings. I hope I get to it before the weekend.)

1 Like

You would need to do a reinstall with an older image (in your case the November/December 2020 image that is Kodi 18.1 based)

Right, I just don’t know how. But I will figure it out. I would just boot from a usb stick and overwrite the internal disk (flash storage), but there is no BIOS, so how do I boot from USB? As I said, I will have to search for that info. No biggie. Right now I am a bit pressed for time, but I will be looking into it on the weekend.

1 Like

Sorry that it took so long, but I ran into a few issues. Thus I ended up reimaging the Vero4k+ (as @fzinken suggested) with the same image (2020.11-1 40a5c21d282206c233bec8b0d1b53304) I am using on my Vero4k.

But now all of a sudden WiFi does not work anymore. I cannot select a network as you can see in the pic below. The section that usually lists all the available networks is empty.

Is it possible that this iamge has a bug that does not show up when the Vero is updated to it via OTA?

Either way, now I am stuck. Is there a hotfix I can install?

Please don’t tell me to use an Ethernet cable. If I do and invest a few hours to restore the backup and get the system to the same point my old Vero4k is, and then the update does not fix my WiFi issue, all that work was for nothing. Afaik the Wifi should work out of the box - and it did with the image that came with the Vero4k+.

Great, thanks, I’ll try that. Need to find an Ethernet cable now, otherwise I won’t be able to connect to the Vero to run these commands… :wink:

However, please note, this is OSMC November 2020 2020.11-1, because I’m trying to migrate from my other Vero4k which is on OSMC November 2020 2020.11-1. The issue you linked to is current with OSMC December 2021.