Videos with VC-1 Codec doesn´t play properly

I think it’s Warners and Universal that got into the habit of taking their existing encodes that they did for HD-DVD and just slapping them on their blu-ray releases.

The Bourne films, Jurassic Park and sequels, The Matrix trilogy etc etc. All VC-1 on blu-ray.

I’ve got 46 blu-ray remuxes that are VC-1.

Very disappointing to hear they won’t play well on my soon to come Vero 4k. Ah well I MAY consider a re-encode at near lossless levels.I’m just not a fan of re-encoding.

@Mevlock I know that the problem is being worked on, and knowing Sam, he will come up with a solution for it.

I’m still hyped for my box arriving :wink:

New toys are always fun. And I like to tinker.

And VC1 IS a dead format really anyway. So it’ll either get fixed or those remuxes will get replaced eventually.

Box came today. Loving the software. Very nice.

Regarding VC1, Sam you might want to take a look at libreelecs code. An s905 build is playing VC1 fine on my Vero 4k. So should be fixable. I took a quick look myself but it’s been decades since I’ve done any serious coding and I’m far too rusty to even make sense of it :slight_smile:


I actually spoke to kszaq/LE about this issue (VC-1) a while ago and we both experience problems decoding VC1 on AML with new kernels. We don’t want to go back to older versions as we’d lose support for features such as HDR; 10-bit and properly functional HD audio.

The consensus is that we need a bitparser in Kodi v18.
However, it seems that VC1 content seems to play as expected at 60Hz, so there may be something we can do to resolve this.

I agree that it is better to replace files (if possible) than hang on to some format that is nearly dead. Because if you don‘t have problems now, you sure will have them in 5 or 10 or 20 years with players of future generations. „File hygene“ is alot of work and sometimes annoying but neccessary. I recently had to replace some files from a pretty exotic encode as well… first I tried to find a solution with settings, then bothered Sam, then realized that I spent more time finding a solution than it would actually cost me to just replace those files.

I guess I’m just a little confused as to why current builds of LE, which, as far as I know, are using current kernels, are playing VC1 fine at the correct refresh rates. Or at at least they aren’t stuttering the way they are in OSMC.

I’ve yet to sit and watch a film all the way through. But currently every one of my VC1 files is stuttering in osmc, but playing smooth in LE.

Regarding replacing them for better encodes, that certainly is the ideal solution for a dying format. But so far there are are still plenty of VC1 encoded blu-rays that haven’t been upgraded by the studios, and they are pretty major releases too.

Re-encoding myself would just result in a loss of quality.

I did find reference to a patch here from earlier on in the year

but that seems to have been added to osmc and I’ve no clue if it’s even related to the problem. guess I’ll just hang fire and keep LE on the sd card for the occasional VC1 film.

We have had that patch in OSMC for Vero 2 and Vero 4K since early March. I also spoke to the author (Markus) by email. It does fix small stutters; but that doesn’t seem to be the overall problem with VC-1 currently.

I spoke to kszaq a couple of weeks ago and it was made clear that there are still issues with VC1 content. Different AMLogic devices use different kernels. I think the ODroid C2 one is the most out of date. But there may be a regression here in newer kernels.

I’m looking in to the VC1 issue (and compiling a couple of test builds) as we speak.


Thanks for the info, one of the reasons I picked up the Vero 4k is the outstanding support you provide.

The overall package is great, love the actual packaging it came in too!

It’s probably a niche issue right now and one that will become more so with time. Plus I’m certainly not short of machines to playback VC1 lol. It would just be nice to have this little niggle sorted if only for the wife acceptance factor :wink:

If you need any testing done just let me know.

It will be fixed. I’ll let you know when I have something ready to test


1 Like

Please see this thread to test some improvements.

I’m looking forward to your feedback.


Tested some of my VC-1 Movies and all playing very well! Again a great job done by @sam_nazarko! Thanks a lot!

1 Like

Has this reverted? VC-1 playback is choppy under 18, running with refresh rate switching and the May ‘19 update.

Yes its a bug sam is fixing it it seems

Awesome thanks!