Volume Down / Mute key failure [SOVLED]

Received a new rPi 2 and installed KOD, with Logitech K400 keyboard. This keyboard was working perfectly. For some reason only the volume-up button works and the mute / volume down is not working.

Any suggestions to diagnose / troubleshoot would be appreciated. Thanks.

Yes, I have had the same problem with two wireless keyboards that previously worked fine with Raspbmc and Openelec. I used the keymap in this thread to get them back in OSMC. I customised it but you can try as is but most stuff is not needed, otherwise generate your own.

Info on modifying key maps here:

@pscriven: it sound like you have successfully overcome some of these keyboard problems. This leads me to wonder: What is the process to embed this success in the RC / builds so that this is no longer an issue in future installations / instances.

Raspbmc went through a similar maturity process where initially there was no Logitech K400 support and eventually it was baked into the build. Having said that, I’m wondering why that success was not transferred / translated to the OSMC source. Understanding this and auditing the process may significantly improve the quality of the system: a real opportunity.

I think it is in the process of being added, try putting this in /userdata/keymaps https://dl.dropboxusercontent.com/u/30655053/hama_mce.xml
Let me know if it works. If it dost is in the process of being added

@Dilligaf: Thank you. Confirming success and recommending that the file be included. As I community member, I would like to express gratitude to all that are contributors that maintain and improve OSMC.

Command Line Steps:
cd /home/osmc/.kodi/userdata/keymaps
wget https://dl.dropboxusercontent.com/u/30655053/hama_mce.xml
sudo reboot

Hopefully, this lesson learned here can be systematically applied to ensure that the goodness / functionality in the last release of RaspBMC finds its way into OSMC.

Cool, you probably want to use wget --no_check_certificate as most installs I believe don’t have ca certificates

I noticed that when I held down the volume up / down key, it moved the volume only one notch. In RaspBMC, holding the volume button would move the volume continuously until mute or max volume was achieved. To enable this capability is this a file setting or a configured somewhere else?

The exact same thing is happening to me. First the mute/voldown buttons didn’t work. I applied the fix from @Dilligaf which works, but now pressing either button just alters the volume by one notch. It’s a little uncomfortable to use.

Could we get a more permanent fix?