Where to start troubleshooting a Remote that stopped working

My Vero4K+ (Family Room) supplied IR remote has stopped working about a year ago.
I was getting by using Yatse app, but would now like to resolve the issue.

I replaced the battery, powered cycled the unit, and re&re’d the IR detector.

I also have another newer Vero4K+ installed in another room (Theater) and except for no Blue light it works OK. Both units have the latest firmware.

I tried using the Theater remote on the Family Room Vero4K, but it did not work. And the Family Room remote on the Theater Vero4K did not work either. (Both units were rebooted prior to test)

How should I proceed to troubleshoot the Family Room setup?

Are you referring to the official OSMC remote? This is RF, so make sure your receiver is plugged in.

You can also look to this post for some troubleshooting info

Receiver is plugged in…my mistake thinking it was IR.

Got some light on the box …
The non-functioning remote is on my Vero4K box
The Theater box is a Vero4K+.

I can see the Blue LED light up on the remote, but it has no effect on the Kodi screen.
And I tried the receiver on both of the ports on the Vero4K.

I am also not using the onboard Ethernet, but rather an external 1Gbs dongle…one recommended on this site. Everything is functional using Yatse.

Did you try to re-pair it?

Yes. Tried several times.
The Vero4K box boots up with the blue light on, but disconnecting the receiver and holding down the Home and OK buttons has no effect on the blue light.

I also just tried selecting the “osmc-remote-lircd” script from the My OSMC screen…but no luck there. Not sure how to undo that now…or if I need to.

Do you see a long flash on the blue light or a short pulse?
Can you go to My OSMC -> Logs and upload all logs?


No change to the blue light on the box at all.
All logs just uploaded… laqebisipi

Seems I was confusing the IR dongle with the RF dongle, and the blue light on the box with the one on the remote.

I re-read the pairing article…this time with the pictures…, and tried again. But still no luck.
The led on the remote does blink 3 times, but after re-inserting the RF dongle, it still doesn’t work… even after a reboot.

Did it blink 3 times AFTER you re-inserted the RF dongle or BEFORE?

It flashes after holding down the Home/OK buttons for a few seconds…so before inserting the RF receiver.

Excuse my English: Flash means for me to shine steadily, to blink means on/off/on/off …
What happens if you insert the RF dongle while the remote control still flashes after pressing Home+OK?

Your log doesn’t show a dongle inserted. Was it inserted when you uploaded the logs?

I will start from the beginning…
Step 1: Power up Vero4K, wait for Kodi menu
Step 2: Remove and Replace Remote Battery. No Blue LED on remote.
Step 3: Remove RF Receiver
Step 4: Press and hold Home and OK buttons.After a few seconds bright blue led observed on Remote. Release buttons and faint blue led observed on remote.
Step 5: Insert RF receiver. Blue LED on remote fades to very faint then goes out. Remote not functioning.
Step 6: Insert RF receiver into Windows 10 notebook. RF Receiver is not detected.
Step 7: Insert RF receiver into Windows 7 Pro notebook. RF receiver not detected.
Step 8: Borrow RF receiver from my Vero4K+.
Step 9: Insert this RF receiver into Windows 10 notebook. RF Receiver is detected in device manager as a USB Input device under Human Interface Devices.

Conclusion: RF receiver from Vero4K is faulty. RF receiver from Vero4K+ is functional.
Solution: Somehow determine RF Receiver specifications and acquire replacement.

Providing the logs obtained while conducting this detailed task would have been quite useful in confirming without doubt that there is a problem with your receiver.

Are there specifications available for the USB RF Receiver?

It is not practical to order another RF Remote after accounting for exchange rate, shipping cost, brokerage duties and sales tax.

I don’t think you can use a generic receiver with that remote. I would recommend sending an email to support@osmc.tv and inquire about a replacement there.

If the remote is in warranty it will be replaced free of charge.

There are no brokerage duties (assume you mean customs fees) or additional import taxes on the OSMC Store for any orders placed.

Are you sure that you ordered the product from us? There are never any additional fees - the price you pay on the site is the final price.


I bought both Vero boxes online from your website about a year apart. The Vero4K I bought about 2 years ago (April 20 2018 Order#16965), the Vero4K+ 1 year ago. Unfortunately, the older unit, the Vero4K, is the one with the RF receiver issue, and I assume it is now well out of warranty.
It would be nice if the remote was functioning…makes it easier for the wife. But it is not a major issue for me.
I was hoping the problem would have been resolved in the setup or configuration. Both units have performed flawlessly since purchased.