Widevine add-ons stopped working from 01/09

Well, that’s disconcerting. I’d swear I haven’t changed anything since last night, but somehow Disney and Amazon are both working again this morning. Very mysterious.

Only thing I can think of is that some other add on (InputStream perhaps) has updated in the background.

Under OSMC, there are no update at all of inputstream.adaptive.
LibreElec inputstream.adaptive is more recent (2.4.8-1).
I made some tests this morning with a new RPI3 B+ and LibreElec 9.2.8 : after installation from scratch and all updates, I put my kodi backup via SSH as usual. And bingo, latest Widevine is downloaded without any problems, and everything works fine with that at first try (TV + Amazon + Disney + Netflix). The only difference is the general speed : beside the Vero, the RPI3 is awfully slow, even with all overclock settings ! What’smore (and not trivial), there’s no need of preparation for Netflix, cause LibreElec has already all libs needed : with OSMC on Vero 4k, you have to put a patch before installing Netflix, or it won’t even start (I had also forgotten this point…). I don’t remember I had to do the tip on the RPI3 with OSMC.

I’ve updated the original post with details on the status for Kodi v19.x. Test builds are now available for Vero and Raspberry Pi devices with Debian Buster.

Many thanks,


1 Like

I’m afraid mine is still not working. I updated my system with Sam’s proposed repo, then reinstalled the Widevine library, but no effect. Some relevant info here:

  • This is the NEW package that got installed with dist-upgrade:

  • And these are the ones that got UPGRADED:
    libntfs-3g883 mediacenter-addon-osmc mediacenter-eventclients-common-osmc mediacenter-send-osmc mediacenter-skin-osmc ntfs-3g vero364-kernel-osmc:arm64

If all of that is correct, then I might have a problem with my Inputstream Helper configuration. Can anybody that got it working again (either with Sam’s new builds or with Matt Huisman’s solution) answer these two questions?

  • When Inputstream Helper warns you that OSMC might not support the latest Widevine CDM library and suggests you install an older version, which option did you choose?

  • What exact Widevine CDM version is working for you? You can check that in the Inputstream Helper addon (first button on the top). I’ve tried with 4.10.2252.0 (13982.88.0) and 4.10.1679.0 (13505.73.0), but none of them work in my system.

Thaks a lot!

Sam, could you please also list in the original posts which packages one is suppose to see updated (as the update is via command line, so package names should be visible this time).

So, do I understand correctly that if I’m on the staging repository, my Vero 4K+ should now be compatible with the latest Widevine (4.10.2252.0)?

If so, then that doesn’t seem to be happening. I’ve installed the latest Widevine version, but out of Netflix, Disney+ and Prime Video, none is currently playing video.

EDIT: Here are logs: https://paste.osmc.tv/soqumehese

(There is probably an error near the beginning where I tried to launch Netflix too soon. But once everything had loaded I went back in and tried to play something, which failed - that should be in there too, together with similar failures for Disney+ and Amazon after it.)

It’s fixed for Pi2,3,4 but not Vero because Vero Kodi build failed due to an issue with binary add-ons.
I’m investigating.

Turns out it’s because the Pi versions were built slightly earlier, but some changes to Kodi PVR add-ons prevent us from building on Debian Buster as they depend on a newer version of TinyXML which needs a newer version of CMake.

So we might need to wait for a couple of days for all platforms to be supported.

Hi, I am on RPI 4. Ive updated using the test build. However now I am getting the following error:

2021-09-15 18:12:19.904 T:815 DEBUG : AddOnLog: inputstream.adaptive: CDM LoadNativeLibrary error: /home/osmc/.kodi/cdm/libwidevinecdm.so: cannot open shared object file: No such file or directory
2021-09-15 18:12:19.904 T:815 ERROR : AddOnLog: inputstream.adaptive: Unable to load widevine shared library (/home/osmc/.kodi/cdm/libwidevinecdm.so)

I’ve opted to install the newer widevine when asked if I wanted to install the old one because I figured now we need the new one? Also I’ve checked to see if /home/osmc/.kodi/cdm/libwidevinecdm.so exists and it does.

Any ideas?

Vero 4K/4K+ should be built and fixed now.

I had my own downstream workaround but was able to persuade the binary add-on maintainer to revert changes:

[Matrix] final Matrix change to correct test builds and take as Version 19.0.0 by AlwinEsch · Pull Request #160 · kodi-pvr/pvr.dvblink · GitHub.


Hi Sam,

I’m not getting any new updates. Perhaps the new packages are the same version as the ones I got yesterday, before last night’s build? If that’s the case, what packages should I ‘apt-get reinstall’?

Thanks a lot!

Please try checking again. There was a problem with the mirror synchronisation system which prevented mirrors from syncing with our server.

This has since been resolved.


I just tested the update with my Vero4k+ and it worked for me.

I used the instructions at the top of the thread, plus I had to force the update for Widevine, and for that I used @matthuisman notes:

curl https://k.slyguy.xyz/.decryptmodules/widevine/4.10.2252.0-linux-armv7.so | sudo tee /home/osmc/.kodi/cdm/libwidevinecdm.so >/dev/null

These are the packages that my Vero downloaded from buster-devel:

1 Like

Thanks for confirming that this worked as expected.

It worked for me too, thank you very much.

However, something weird happened after this update. I lost the side menu (the one that lets you configure the Viewtype, upate your library, etc) of my skin (Xonfluence).

These are the NEW packages that got installed:

And these got UPDATED:
libc6 locales

Is there any obvious package in this update that may have conflicted with my skin, making the side bar disappear?

I can open a new thread if necessary, I thought I should tell about it here since it seems to be a side effect of the proposed update to fix the Widevine issue.

Thanks again!

No - I don’t think anything could have changed that.

Hi @sam_nazarko ,

Thanks very much for working on this issue.

Apologies in advance if this is down to me or unrelated. I’ve run the update on my Vero 4K+, but Netflix and Amazon Prime playback continues to fail.

I ran the update, rebooted, opened Netflix, widevine then prompted to update which succeeded. Shortly after, I think that either Neflix hung or osmc crashed ‘sad face screen’ and then rebooted.

From clean boot: Open Netflix, select “The Chair” from my list and play episode 3. Spinnning circles for about 15 seconds then screen goes black, playback began here before, then spinning circles return and UI locks.

Debug log uploaded https://paste.osmc.tv/acoxivucaf (IPs and hosts sanitised)

Tried rebooting several times, and trying Nettflix again but without any luck.

During the upgrade the following warning was displayed The 'netbios name' is too long (max. 15 chars). Summary below of the package upgrade.


python-crypto python-ldb python-samba python-tdb samba-common samba-common-bin vero364-image-4.9.113-48-osmc:arm64


libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libntfs-3g883 locales mediacenter-addon-osmc mediacenter-eventclients-common-osmc mediacenter-send-osmc mediacenter-skin-osmc multiarch-support ntfs-3g vero3-mediacenter-osmc vero364-kernel-osmc:arm64

# specific packages downloaded


Did you update your Widevine libraries too?

Thanks for getting back to me.

After the reboot at the end of the upgrade, OSMC prompted me to upgrade widevine and that appeared to succeed:

~/.kodi/cdm$ pwd

~/.kodi/cdm$ strings -a libwidevinecdm.so | grep -F "4.10"

Following your reply I renamed the ~/.kodi/cdm folder. OSMC then re-downloaded and installed Widevine, which succeeded, but playback still failed.

Built the test code to query the library version from issue #678 on the inputstream.adaptive Github repo, running it returns:

~/.kodi/cdm$ LD_LIBRARY_PATH=. ~/cdmtest/cdmtest
CDM Version: 4.10.2252.0

No update for me, do I need to trigger it manually?

following this procedure (on top) killed my Vero. I can’t boot anymore. no ssh access. nada. any idea how to revive it?