WiFi Connection on R-Pi 4

I just got a Raspberry Pi 4 to test out using it as a media center, primarily for Netflix, Disney+, Spotify, etc. I’m currently running into network issues.

According to System Info, I’m running OSMC using KODI 19.4. This was loaded onto the SD card via the Raspberry Pi Imager a day or two ago. I ran through basic initial setup but otherwise it is default settings.

When I go into My OSMC > Network > Wireless I can see my 2.4 GHz with an x, a lock, and 4 white dots (4 out of 5 bars of service?).

Issue 1
I cannot see my 5 GHz network. It appears as though R-PI 4 should have the capability to do this unless I am mistaken. Is there something I’m missing or need to configure?

Issue 2
When I try to connect to the 2.4 GHZ network it prompts for a password. It notes “Configuring…” for a while before displaying a Connection Failed message with status stating no wireless connection. I’m using a Logitech wireless keyboard as input but have entered the PW using both the letter keys and navigating the on-screen keyboard.

On which channel is your 5 GHz network? Certain channels would need you to configure your country via the CRDA tool.

You could try it from command line

Progress!

The second thread was really useful. I am now able to see and connect to my 5GHz network by setting my region. HOWEVER, every time I restart, the region resets to default (unset) and the connection no longer initializes.

osmc@osmc:~$ osmc@osmc:~$ iw reg get
global
country 00: DFS-UNSET
        (2402 - 2472 @ 40), (N/A, 20), (N/A)
        (2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, NO-IR
        (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, NO-IR
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, NO-IR
        (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
        (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
        (57240 - 63720 @ 2160), (N/A, 0), (N/A)

osmc@osmc:~$ sudo iw reg set US
osmc@osmc:~$ iw reg get
global
country US: DFS-FCC
        (2402 - 2472 @ 40), (N/A, 30), (N/A)
        (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57240 - 63720 @ 2160), (N/A, 40), (N/A)

osmc@osmc:~$ shutdown -r now
osmc@osmc:~$ iw reg get
global
country 00: DFS-UNSET
        (2402 - 2472 @ 40), (N/A, 20), (N/A)
        (2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, NO-IR
        (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, NO-IR
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, NO-IR
        (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
        (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
        (57240 - 63720 @ 2160), (N/A, 0), (N/A)

How do I make the region settings persistent?

Check this post

Thanks for your assistance! For those that follow, the following are the key components of the process that worked for me.

sudo apt-get install iw
sudo apt-get install crda

## Test region to make sure connection works
iw reg get
sudo iw reg set <region>

## Could establish connection but did not persist through reboot, to make region persistent...
sudo nano /etc/default/crda