WiFi vs Wired Performance - huge difference

This looks correct for single band 802.11n in a reasonably clear environment. This is pretty much the best you’ll get for 802.11n

What would be fine but its just iperf which gets this performance.
Wget gets this:

root@osmcwohn:~# wget http://mirror.global-layer.com/speedtest/100mb.bin
converted ‘http://mirror.global-layer.com/speedtest/100mb.bin’ (ANSI_X3.4-1968) -> ‘http://mirror.global-layer.com/speedtest/100mb.bin’ (UTF-8)
–2017-01-09 17:26:12-- http://mirror.global-layer.com/speedtest/100mb.bin
Resolving mirror.global-layer.com (mirror.global-layer.com)… 109.202.98.200, 2a00:1678:0:2003::1337
Connecting to mirror.global-layer.com (mirror.global-layer.com)|109.202.98.200|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 100000000 (95M) [application/octet-stream]
Saving to: ‘100mb.bin.1’

100mb.bin.1 2%[ ] 2.13M 193KB/s eta 5m 13s

I just mounted the sahres via fstab AND IP Adress and started copying a file:

Still slow.
Its really strange, only iperf gets full speed in my network, every other applicatin (smb / wget) seems to be slow.

You are getting a speed test from that server, so it can be influenced by other networks. I don’t get a great speed with that URL either. It appears to be a NL web host.

All I can really suggest is trying something like NFS, FTP etc and check for QoS in your router.

Nfs with fstab and IP adress:

Still slow. QoS is off.

edit:

copied file with scp (sftp):

Also slow…

iperf between NAS and Raspi 3:

[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 37.7 MBytes 31.6 Mbits/sec 1 sender
[ 4] 0.00-10.00 sec 37.5 MBytes 31.4 Mbits/sec receiver

Looks fine. Every other protocol is slow only iperf is fast…
I tried copying a file to /dev/null but also in this case the speed is slow.
(to avoid that the SD is slow)

edit:
SD is not slow:
200000000 bytes (200 MB) copied, 21.3628 s, 9.4 MB/s
=75,2Mbit/s

edit:
I checked the CPU of router, nas and rpi and they are all fine (under 10%)

Ok now I have a constant good wifi performance but Kodi still stutters while playing a 1080p video. If I take a look at iftop in this moment the speed is 10Mbit/s and this seems to low. If the stuttering happens one cpu core is at 100%.
At the same time if I try other speedtests like wget this is also slow. If I stop the playback wifi is instantly fast again.

My assumption is that kodi is using the cpu that much that the os is not able to get proper wifi speeds. My idea is to change the nice value of kodi.
Is this possible and if yes how?

I followed this posting:

But the problem remained,

Hi,

I am not an expert at all, I m basically trying everything I m getting my hand on so don’t take my post as “the way to go”. That being said have you tried the next link in the exact post you quoted ( the changes to kodi advancedsettings.xml ? ) It helped a lot.

However, I still think the results I get are not normal. I m still investigating it. Maybe is it my Pi 3 integrated chip that’s causing all of this…