Will not boot up when inserted OSMC SDCARD into Raspberry Pi 2

I was running XBMC for over a year and loved it. But I decided to upgrade to OSMC and give it a shot but it will not even boot up.

Here is what I did.

  1. Took SDCARD from my Raspberry Pi 2 and formatted it.
  2. Went to OSMC.TV and downloaded the MAC DMG for the Raspberry Pi 2.
  3. After 20 minutes of downloading it installed on the SDCARD. I could see the contents. (bootcode.bin, cmdline.txt, config.txt, filesystem.tar.xz, kernel.mg, etc)
  4. Unmounted SDCARD from MAC
  5. inserted SDCARD into Raspberry Pi 2 and just got the Raspberry boot up screen (rainbow of colors) but would not load the kernel. On the raspberry the power lite is on, the Activity light goes green for about 1/2 a second then disappears and no boot up info.

What could be going on that it will not boot up?

Does the rainbow stay on permanently? It’s possible you still have a Pi 1.

Thank you so much for the quick response.

I bought it from Amazon when the New Pi 2 kit out and checked my order to confirm it is a Pi 2 kit.

One thing I did wrong is use the wrong SDCard!! My bad. I should have used the 8GB raspberry card that came with the kit.

Question, do I erase that card completely and then use the OSMC installer? The Raspberry card has the Recovery and Boot folder on it. Not sure what to do.

The OSMC installer will repartition the SD for you


Thanks again. Well, I did what you said and let the OSMC installer do the formatting but after the download and got the “Congratulations” I hit quit. Ejected the card from my mac and then inserted the sdcard into the Raspberry and NOTHING. Same thing as before. I have no idea why it does not boot up from the card. I am going to try it one more time and noticed at RC3 image now so will try that one.

PROBLEM SOLVED. I tried the Raspberry Pi 1 image and it worked. But when I looked at my Amazon order it clearly states Raspberry Pi 2 (NEW) kit. I ordered it in April 2014 when the Pi 2 kits were released.

Pi 2 came out in February 2015


Here is what I ordered…

CanaKit Raspberry Pi 2 (1GB) Ultimate Starter Kit (Over 40 Components: New Raspberry Pi 2 + WiFi Dongle + 8GB SD Card + Case + Power Supply and many more)
Includes New Raspberry Pi 2 (RPi2) Quad-Core 900 MHz 1GB RAM, CanaKit WiFi Adapter

Can you upload a picture of your device?


Not sure how to upload a picture but here is the link

If it boots the Pi 1 image but not the Pi 2 image you clearly have a Pi 1. There is no other possibility. You wouldn’t be the first person to be sold a Pi 1 B+ as a Pi 2. See the following thread for how to identify the device properly:

Send it back for an exchange or refund.

If you could take pictures of the front and back of your Pi and post them here with the Upload (Ctrl-G) button, I’d like to see what you were sold as a R. Pi 2.

From the links you’ve posted, it should be a R. Pi 2, but those can be updated over time. I wish the R.Pi people would have come out with a better version system so scammers couldn’t exploit quirks in their numbering and lettering.

The best way to tell is to look for the ram chip on the bottom side of the board - the Pi 2 has one there, the Pi 1 does not.

Otherwise the Pi 1 B+ and Pi 2 are VERY similar looking, especially on the top side - the only real difference on the top side is the CPU is in a slightly different location and has different writing on it, so it’s easy to see how they could get mixed up during packaging and shipping.

Booting a Pi 1 image but not a Pi 2 image is the real giveaway though. :wink:

Based on the time you say you bought it in 2014 or can’t be a Pi 2. Since they probably edited the description on Amazon then started selling Pi2 in place you should go to your email and see what was written on the order confirmation since it can’t of been edited over time.

I would say the easiest way to identify your Pi is this:

The Pi1 B+ has “Raspberry Pi Model B+ Vx.x. © Raspberry Pi 2014” written on the topside of the board, just above the logo.

The Pi2 B has “Raspberry Pi 2 Model B Vx.x © Raspberry Pi 2014” written to the right of the Broadcom chip, not above or below the logo.

Just got an RPI 2 and am trying to get it up and running.

I’m getting the same issue.

“Get the Raspberry boot up screen (rainbow of colors) but would not load the kernel. On the raspberry the power lite is on, the Activity light goes green for about 1/2 a second then disappears and no boot up info”

mine however goes into a power loop. The green light flashes, the pi turns off, and on, back to rainbow.

I have tried the following with the following results (All using OSMC installer)

  • Device Rpi2/ image RC3 Rpi2 (downloaded through installer)
    result = power loop

the rest i manually downloaded images from here Download - OSMC and installed as the “local image” choice in the osmc installer.

  • Device Rpi2/image RC3(rpi2) = power loop
  • Device Rpi1/image RC3(rpi2) = power loop
  • Device Rpi2/image RC2(rpi2) = power loop
  • Device Rpi2/image RC3(rpi1) = stuck on rainbow screen
  • Device Rpi1/image RC3(rpi1) = stuck on rainbow screen.

Here are some pictures of my Rpi2. I purchased off element 14 who are reliable.

the box also says “raspberry pi 2”.

Any Help? Its obviously not the same issue that i’ve got an Rpi1…

front of device

So i tried out OpenOlec and it was doing the same thing. power looping till it stopped.
as the loop was fast i gave it a few goes because the “stopping” at the end was a bit different.

after 3 times it worked.

So i reformatted the card again back with Rpi2/RC3(Rpi2) and it did the power loop
i let it run through for a while. 12 times. it then turned off.
I turned it back on after that and alas, it started installing.

It appears that the Raspberry Pi 2 when installing/formatting for new kodi builds for the first time will power loop itself multiple times.

It’d be great if the OSMC installer or download page mentioned this for future reference :slight_smile:

I’ve never had this happen to me. . .

Except, of course, when I was trying out a power supply that wasn’t up to the task.

What’s yours rated at?

There is only one reboot in the install process, and it will inform you when it’s going to happen

Check your power supply